aboutsummaryrefslogtreecommitdiff
path: root/devel/gtkparasite/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-09-23 09:31:30 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-09-23 09:31:30 +0000
commitab686017c2a0f93b6f34986f6fa9a3c7ec7d4988 (patch)
treeb7ed009e9afe2a819188e565265eba70712c66b4 /devel/gtkparasite/Makefile
parent2188341716c75f2c02161ffba59e27e4d1211cfc (diff)
downloadports-ab686017c2a0f93b6f34986f6fa9a3c7ec7d4988.tar.gz
ports-ab686017c2a0f93b6f34986f6fa9a3c7ec7d4988.zip
Notes
Diffstat (limited to 'devel/gtkparasite/Makefile')
-rw-r--r--devel/gtkparasite/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/gtkparasite/Makefile b/devel/gtkparasite/Makefile
new file mode 100644
index 000000000000..c7629d42b8c4
--- /dev/null
+++ b/devel/gtkparasite/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gtkparasite
+# Date created: 2009-02-19
+# Whom: Ashish Shukla <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkparasite
+PORTVERSION= 20090819
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= pav
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= GTK+ UI debugging tool
+
+USE_PYTHON= 2.5+
+USE_GNOME= gtk20 pygtk2
+WRKSRC= ${WRKDIR}/chipx86-gtkparasite-a3d862d4a91ea27222e4273a6797f3e47efe6e83
+GNU_CONFIGURE= yes
+PORTDOCS= USAGE
+PLIST_FILES= lib/gtk-2.0/modules/libgtkparasite.a \
+ lib/gtk-2.0/modules/libgtkparasite.la \
+ lib/gtk-2.0/modules/libgtkparasite.so
+USE_AUTOTOOLS= autoconf:262 automake:110 libtool:22
+
+pre-configure:
+ cd ${WRKSRC} && ${REINPLACE_CMD} -e '/.\/configure/d' ./autogen.sh \
+ && ./autogen.sh
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/USAGE ${DOCSDIR}
+
+.include <bsd.port.mk>