aboutsummaryrefslogtreecommitdiff
path: root/devel/guikachu
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-11-07 13:50:53 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-11-07 13:50:53 +0000
commit9fcf538bfca7ab19cd141563d03848f852862527 (patch)
tree7e8b961de9ad8f4b8a3b3cf841f558852efea4ec /devel/guikachu
parente862f8cb7b4d7937878588982d435220e9153f7f (diff)
downloadports-9fcf538bfca7ab19cd141563d03848f852862527.tar.gz
ports-9fcf538bfca7ab19cd141563d03848f852862527.zip
Notes
Diffstat (limited to 'devel/guikachu')
-rw-r--r--devel/guikachu/Makefile33
-rw-r--r--devel/guikachu/distinfo2
-rw-r--r--devel/guikachu/pkg-descr5
-rw-r--r--devel/guikachu/pkg-plist91
4 files changed, 131 insertions, 0 deletions
diff --git a/devel/guikachu/Makefile b/devel/guikachu/Makefile
new file mode 100644
index 000000000000..1db15045dd69
--- /dev/null
+++ b/devel/guikachu/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: guikachu
+# Date created: 7 Nov 2004
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= guikachu
+PORTVERSION= 1.5.4pre2
+CATEGORIES= devel palm gnome
+MASTER_SITES= http://cactus.rulez.org/projects/guikachu/download/
+
+MAINTAINER= bland@FreeBSD.org
+COMMENT= Resource editor for PalmOS(tm) systems
+
+LIB_DEPENDS= gnomeuimm-2.6.1:${PORTSDIR}/x11-toolkits/libgnomeuimm26 \
+ gnomevfsmm-2.6.1:${PORTSDIR}/devel/gnome-vfsmm
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GCC= 3.4
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/mime_packagedir/s|(mimedir)|(prefix)/share/mime|' \
+ -e '/(UPDATE_MIME)/s|(mimedir)|(prefix)/share/mime|' \
+ ${WRKSRC}/data/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/devel/guikachu/distinfo b/devel/guikachu/distinfo
new file mode 100644
index 000000000000..fe064770c58c
--- /dev/null
+++ b/devel/guikachu/distinfo
@@ -0,0 +1,2 @@
+MD5 (guikachu-1.5.4pre2.tar.gz) = e09e4e6f6bec0d940742ea50e10d035b
+SIZE (guikachu-1.5.4pre2.tar.gz) = 1236057
diff --git a/devel/guikachu/pkg-descr b/devel/guikachu/pkg-descr
new file mode 100644
index 000000000000..72b5192eeba6
--- /dev/null
+++ b/devel/guikachu/pkg-descr
@@ -0,0 +1,5 @@
+Guikachu is a resource editor for PalmOS(tm) systems. It allows you
+to visually create dialog boxes, menu bars and windows for your
+Palm application in the GNOME desktop environment.
+
+WWW: http://cactus.rulez.org/projects/guikachu/
diff --git a/devel/guikachu/pkg-plist b/devel/guikachu/pkg-plist
new file mode 100644
index 000000000000..a4fb387f43d3
--- /dev/null
+++ b/devel/guikachu/pkg-plist
@@ -0,0 +1,91 @@
+bin/guikachu
+bin/guikachu2rcp
+@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/guikachu-form-editor.schemas > /dev/null || /usr/bin/true
+etc/gconf/schemas/guikachu-form-editor.schemas
+@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/guikachu-form-editor.schemas > /dev/null || /usr/bin/true
+@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/guikachu-interface.schemas > /dev/null || /usr/bin/true
+etc/gconf/schemas/guikachu-interface.schemas
+@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/guikachu-interface.schemas > /dev/null || /usr/bin/true
+share/gnome/application-registry/guikachu.applications
+share/gnome/apps/Development/guikachu.desktop
+share/gnome/guikachu/fonts/bigbold.txt
+share/gnome/guikachu/fonts/bigfont.txt
+share/gnome/guikachu/fonts/boldfont.txt
+share/gnome/guikachu/fonts/ledfont.txt
+share/gnome/guikachu/fonts/stdfont.txt
+share/gnome/guikachu/fonts/symbol.txt
+share/gnome/guikachu/fonts/symbol11.txt
+share/gnome/guikachu/fonts/symbol7.txt
+share/gnome/guikachu/glade/guikachu.glade
+share/gnome/guikachu/target-defs/ebook-l.guikachu-target
+share/gnome/guikachu/target-defs/ebook-p.guikachu-target
+share/gnome/guikachu/target-defs/palm-color.guikachu-target
+share/gnome/guikachu/target-defs/palm.guikachu-target
+share/gnome/help/guikachu/C/bitmaps.html
+share/gnome/help/guikachu/C/form-editor.html
+share/gnome/help/guikachu/C/guikachu-doc-html.css
+share/gnome/help/guikachu/C/guikachu.docbook
+share/gnome/help/guikachu/C/index.html
+share/gnome/help/guikachu/C/menu-editor.html
+share/gnome/help/guikachu/C/pictures/add-res.png
+share/gnome/help/guikachu/C/pictures/bitmap-window.png
+share/gnome/help/guikachu/C/pictures/bitmapgroup-window.png
+share/gnome/help/guikachu/C/pictures/form-editor-preview-greyscale.png
+share/gnome/help/guikachu/C/pictures/form-editor-preview.png
+share/gnome/help/guikachu/C/pictures/form-editor-resize.png
+share/gnome/help/guikachu/C/pictures/form-editor-selection.png
+share/gnome/help/guikachu/C/pictures/form-editor-tree.png
+share/gnome/help/guikachu/C/pictures/main-window-app-res.png
+share/gnome/help/guikachu/C/pictures/main-window.png
+share/gnome/help/guikachu/C/pictures/menu-editor.png
+share/gnome/help/guikachu/C/pictures/palette.png
+share/gnome/help/guikachu/C/pictures/preferences.png
+share/gnome/help/guikachu/C/pictures/prop-dropdown.png
+share/gnome/help/guikachu/C/pictures/prop-id.png
+share/gnome/help/guikachu/C/pictures/prop-ref.png
+share/gnome/help/guikachu/C/pictures/prop-size.png
+share/gnome/help/guikachu/C/pictures/prop-spin.png
+share/gnome/help/guikachu/C/pictures/prop-string.png
+share/gnome/help/guikachu/C/pictures/prop-stringlist.png
+share/gnome/help/guikachu/C/pictures/prop-text.png
+share/gnome/help/guikachu/C/pictures/prop-toggle.png
+share/gnome/help/guikachu/C/resource-win.html
+share/gnome/help/guikachu/C/resources.html
+share/gnome/help/guikachu/C/using.html
+share/gnome/help/guikachu/C/widgets.html
+share/gnome/mime-info/guikachu.keys
+share/gnome/mime-info/guikachu.mime
+share/gnome/pixmaps/guikachu-96.png
+share/gnome/pixmaps/guikachu-application-x-guikachu-96.png
+share/gnome/pixmaps/guikachu.png
+share/locale/az/LC_MESSAGES/guikachu.mo
+share/locale/ca/LC_MESSAGES/guikachu.mo
+share/locale/cs/LC_MESSAGES/guikachu.mo
+share/locale/de/LC_MESSAGES/guikachu.mo
+share/locale/en_GB/LC_MESSAGES/guikachu.mo
+share/locale/es/LC_MESSAGES/guikachu.mo
+share/locale/hu/LC_MESSAGES/guikachu.mo
+share/locale/ja/LC_MESSAGES/guikachu.mo
+share/locale/nl/LC_MESSAGES/guikachu.mo
+share/locale/pl/LC_MESSAGES/guikachu.mo
+share/locale/pt/LC_MESSAGES/guikachu.mo
+share/locale/pt_BR/LC_MESSAGES/guikachu.mo
+share/locale/ru/LC_MESSAGES/guikachu.mo
+share/locale/sr/LC_MESSAGES/guikachu.mo
+share/locale/sr@Latn/LC_MESSAGES/guikachu.mo
+share/locale/sv/LC_MESSAGES/guikachu.mo
+share/locale/tr/LC_MESSAGES/guikachu.mo
+share/locale/uk/LC_MESSAGES/guikachu.mo
+share/locale/wa/LC_MESSAGES/guikachu.mo
+share/mime/application/x-guikachu.xml
+share/mime/packages/guikachu.mime.xml
+share/mime/text/x-rcp.xml
+@dirrm share/gnome/help/guikachu/C/pictures
+@dirrm share/gnome/help/guikachu/C
+@dirrm share/gnome/help/guikachu
+@dirrm share/gnome/guikachu/target-defs
+@dirrm share/gnome/guikachu/glade
+@dirrm share/gnome/guikachu/fonts
+@dirrm share/gnome/guikachu
+@exec update-mime-database %D/share/mime
+@unexec update-mime-database %D/share/mime