aboutsummaryrefslogtreecommitdiff
path: root/devel/gvfs
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-01-17 19:09:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-01-17 19:09:19 +0000
commit4a8ee477e6fba392f4febbeb358593676a3fc648 (patch)
tree89a3cf4913dd78772a9dc3b1aa583b000fbd576f /devel/gvfs
parent55923938e0af54880ac44d12c203dfb3418bfcf3 (diff)
downloadports-4a8ee477e6fba392f4febbeb358593676a3fc648.tar.gz
ports-4a8ee477e6fba392f4febbeb358593676a3fc648.zip
Notes
Diffstat (limited to 'devel/gvfs')
-rw-r--r--devel/gvfs/Makefile31
-rw-r--r--devel/gvfs/files/patch-config.h.in12
-rw-r--r--devel/gvfs/files/patch-configure128
-rw-r--r--devel/gvfs/files/patch-daemon_gvfsbackendgphoto2.c44
4 files changed, 175 insertions, 40 deletions
diff --git a/devel/gvfs/Makefile b/devel/gvfs/Makefile
index 9344a9d13caa..0144bfeea697 100644
--- a/devel/gvfs/Makefile
+++ b/devel/gvfs/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gvfs
PORTVERSION= 1.12.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -12,14 +12,16 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME virtual file system
-LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus \
- soup-gnome-2.4:${PORTSDIR}/devel/libsoup-gnome \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- gnome-keyring:${PORTSDIR}/security/libgnome-keyring
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring
-USES= gettext gmake pkgconfig
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
USE_XZ= yes
-USE_GNOME= glib20 gnomehack gnomeprefix intlhack intltool
+USE_GNOME= glib20 gnomeprefix intlhack intltool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -36,7 +38,6 @@ SAMBA_DESC= Samba support
GLIB_SCHEMAS= org.gnome.system.gvfs.enums.xml
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MFUSE}
@@ -48,7 +49,7 @@ PLIST_SUB+= FUSE="@comment "
.endif
.if ${PORT_OPTIONS:MSAMBA}
-LIB_DEPENDS+= smbclient:${PORTSDIR}/net/samba-libsmbclient
+LIB_DEPENDS+= libsmbclient.so:${PORTSDIR}/net/samba-libsmbclient
GLIB_SCHEMAS+= org.gnome.system.smb.gschema.xml
PLIST_SUB+= SMB=""
.else
@@ -57,7 +58,7 @@ PLIST_SUB+= SMB="@comment "
.endif
.if ${PORT_OPTIONS:MCDDA}
-LIB_DEPENDS+= cdio_paranoia:${PORTSDIR}/sysutils/libcdio
+LIB_DEPENDS+= libcdio_paranoia.so:${PORTSDIR}/sysutils/libcdio
PLIST_SUB+= CDDA=""
.else
CONFIGURE_ARGS+= --disable-cdda
@@ -65,7 +66,7 @@ PLIST_SUB+= CDDA="@comment "
.endif
.if ${PORT_OPTIONS:MGPHOTO2}
-LIB_DEPENDS+= gphoto2:${PORTSDIR}/graphics/libgphoto2
+LIB_DEPENDS+= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
PLIST_SUB+= GPHOTO2=""
.else
CONFIGURE_ARGS+= --disable-gphoto2
@@ -73,7 +74,7 @@ PLIST_SUB+= GPHOTO2="@comment "
.endif
.if ${PORT_OPTIONS:MAVAHI}
-LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS+= libavahi-client.so:${PORTSDIR}/net/avahi-app
GLIB_SCHEMAS+= org.gnome.system.dns_sd.gschema.xml
PLIST_SUB+= AVAHI=""
.else
@@ -82,7 +83,7 @@ PLIST_SUB+= AVAHI="@comment "
.endif
.if ${PORT_OPTIONS:MHAL} || ${PORT_OPTIONS:MGPHOTO2} || ${PORT_OPTIONS:MCDDA}
-LIB_DEPENDS+= hal:${PORTSDIR}/sysutils/hal
+LIB_DEPENDS+= libhal.so:${PORTSDIR}/sysutils/hal
RUN_DEPENDS+= gnome-mount:${PORTSDIR}/sysutils/gnome-mount
PLIST_SUB+= HAL=""
.else
@@ -90,4 +91,8 @@ CONFIGURE_ARGS+=--disable-hal
PLIST_SUB+= HAL="@comment "
.endif
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib*.so.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gio/modules/lib*.so
+
.include <bsd.port.mk>
diff --git a/devel/gvfs/files/patch-config.h.in b/devel/gvfs/files/patch-config.h.in
new file mode 100644
index 000000000000..aca6bcf45a75
--- /dev/null
+++ b/devel/gvfs/files/patch-config.h.in
@@ -0,0 +1,12 @@
+--- config.h.in.orig 2012-05-15 20:07:21.000000000 +0200
++++ config.h.in 2014-01-17 19:49:23.000000000 +0100
+@@ -51,6 +51,9 @@
+ /* Define to 1 if gphoto2 is available */
+ #undef HAVE_GPHOTO2
+
++/* define to 1 if gphoto2.5 is available */
++#undef HAVE_GPHOTO25
++
+ /* Define to 1 if you have the `grantpt' function. */
+ #undef HAVE_GRANTPT
+
diff --git a/devel/gvfs/files/patch-configure b/devel/gvfs/files/patch-configure
index a2b691355797..efc346b66ed4 100644
--- a/devel/gvfs/files/patch-configure
+++ b/devel/gvfs/files/patch-configure
@@ -1,29 +1,103 @@
---- configure.orig 2010-05-28 10:24:40.000000000 +0200
-+++ configure 2010-05-28 10:25:59.000000000 +0200
-@@ -16253,7 +16253,7 @@
- $as_echo_n "(cached) " >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-larchive $LIBS"
-+LIBS="-larchive -lcrypto -lmd $LIBS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
+--- configure.orig 2014-01-17 19:42:49.000000000 +0100
++++ configure 2014-01-17 19:43:03.000000000 +0100
+@@ -17233,6 +17233,100 @@
-@@ -16298,7 +16298,7 @@
- if test x$with_archive_libs != x/usr/lib; then
- ARCHIVE_LIBS="-L$with_archive_libs -larchive"
- else
-- ARCHIVE_LIBS="-larchive"
-+ ARCHIVE_LIBS="-larchive -lcrypto -lmd"
- fi
- else
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for archive_entry_filetype in -larchive" >&5
-@@ -16307,7 +16307,7 @@
- $as_echo_n "(cached) " >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-larchive $LIBS"
-+LIBS="-larchive -lcrypto -lmd $LIBS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
+ $as_echo "#define HAVE_GPHOTO2 1" >>confdefs.h
++
++pkg_failed=no
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GPHOTO2" >&5
++$as_echo_n "checking for GPHOTO2... " >&6; }
++
++if test -n "$GPHOTO2_CFLAGS"; then
++ pkg_cv_GPHOTO2_CFLAGS="$GPHOTO2_CFLAGS"
++ elif test -n "$PKG_CONFIG"; then
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libgphoto2 >= 2.5.0\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "libgphoto2 >= 2.5.0") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_GPHOTO2_CFLAGS=`$PKG_CONFIG --cflags "libgphoto2 >= 2.5.0" 2>/dev/null`
++ test "x$?" != "x0" && pkg_failed=yes
++else
++ pkg_failed=yes
++fi
++ else
++ pkg_failed=untried
++fi
++if test -n "$GPHOTO2_LIBS"; then
++ pkg_cv_GPHOTO2_LIBS="$GPHOTO2_LIBS"
++ elif test -n "$PKG_CONFIG"; then
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libgphoto2 >= 2.5.0\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "libgphoto2 >= 2.5.0") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_GPHOTO2_LIBS=`$PKG_CONFIG --libs "libgphoto2 >= 2.5.0" 2>/dev/null`
++ test "x$?" != "x0" && pkg_failed=yes
++else
++ pkg_failed=yes
++fi
++ else
++ pkg_failed=untried
++fi
++
++
++
++if test $pkg_failed = yes; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++
++if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
++ _pkg_short_errors_supported=yes
++else
++ _pkg_short_errors_supported=no
++fi
++ if test $_pkg_short_errors_supported = yes; then
++ GPHOTO2_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "libgphoto2 >= 2.5.0" 2>&1`
++ else
++ GPHOTO2_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "libgphoto2 >= 2.5.0" 2>&1`
++ fi
++ # Put the nasty error message in config.log where it belongs
++ echo "$GPHOTO2_PKG_ERRORS" >&5
++
++ as_fn_error $? "Package requirements (libgphoto2 >= 2.5.0) were not met:
++
++$GPHOTO2_PKG_ERRORS
++
++Consider adjusting the PKG_CONFIG_PATH environment variable if you
++installed software in a non-standard prefix.
++
++Alternatively, you may set the environment variables GPHOTO2_CFLAGS
++and GPHOTO2_LIBS to avoid the need to call pkg-config.
++See the pkg-config man page for more details." "$LINENO" 5
++elif test $pkg_failed = untried; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
++$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
++as_fn_error $? "The pkg-config script could not be found or is too old. Make sure it
++is in your PATH or set the PKG_CONFIG environment variable to the full
++path to pkg-config.
++
++Alternatively, you may set the environment variables GPHOTO2_CFLAGS
++and GPHOTO2_LIBS to avoid the need to call pkg-config.
++See the pkg-config man page for more details.
++
++To get pkg-config, see <http://pkg-config.freedesktop.org/>.
++See \`config.log' for more details" "$LINENO" 5; }
++else
++ GPHOTO2_CFLAGS=$pkg_cv_GPHOTO2_CFLAGS
++ GPHOTO2_LIBS=$pkg_cv_GPHOTO2_LIBS
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
++$as_echo "yes" >&6; }
++
++$as_echo "#define HAVE_GPHOTO25 1" >>confdefs.h
++
++
++fi
+ else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Not building with gphoto2 support. Need OS tweaks in hal volume monitor." >&5
+ $as_echo "$as_me: WARNING: Not building with gphoto2 support. Need OS tweaks in hal volume monitor." >&2;}
diff --git a/devel/gvfs/files/patch-daemon_gvfsbackendgphoto2.c b/devel/gvfs/files/patch-daemon_gvfsbackendgphoto2.c
new file mode 100644
index 000000000000..d2a369967729
--- /dev/null
+++ b/devel/gvfs/files/patch-daemon_gvfsbackendgphoto2.c
@@ -0,0 +1,44 @@
+--- daemon/gvfsbackendgphoto2.c.orig 2012-05-16 02:01:50.000000000 +0800
++++ daemon/gvfsbackendgphoto2.c 2014-01-18 01:43:32.000000000 +0800
+@@ -1647,7 +1647,9 @@
+ return;
+ }
+
++#ifndef HAVE_GPHOTO25
+ DEBUG (" '%s' '%s' '%s'", info.name, info.path, info.library_filename);
++#endif
+
+ /* set port */
+ rc = gp_camera_set_port_info (gphoto2_backend->camera, info);
+@@ -2590,7 +2592,11 @@
+ }
+ }
+
++#ifdef HAVE_GPHOTO25
++ rc = gp_camera_folder_put_file (gphoto2_backend->camera, dir, new_name, GP_FILE_TYPE_NORMAL, file_dest, gphoto2_backend->context);
++#else
+ rc = gp_camera_folder_put_file (gphoto2_backend->camera, dir, file_dest, gphoto2_backend->context);
++#endif
+ if (rc != 0)
+ goto out;
+
+@@ -3222,14 +3228,18 @@
+ if (rc != 0)
+ goto out;
+
+- gp_file_set_type (file, GP_FILE_TYPE_NORMAL);
+ gp_file_set_name (file, write_handle->name);
+ gp_file_set_mtime (file, time (NULL));
+ gp_file_set_data_and_size (file,
+ dup_for_gphoto2 (write_handle->data, write_handle->size),
+ write_handle->size);
+
++#ifdef HAVE_GPHOTO25
++ rc = gp_camera_folder_put_file (gphoto2_backend->camera, write_handle->dir, write_handle->name, GP_FILE_TYPE_NORMAL, file, gphoto2_backend->context);
++#else
++ gp_file_set_type (file, GP_FILE_TYPE_NORMAL);
+ rc = gp_camera_folder_put_file (gphoto2_backend->camera, write_handle->dir, file, gphoto2_backend->context);
++#endif
+ if (rc != 0)
+ {
+ gp_file_unref (file);