aboutsummaryrefslogtreecommitdiff
path: root/devel/gwenhywfar/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-06-08 14:45:19 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-06-08 14:45:19 +0000
commit877d5ac090fe2e18a70da0f70fc033cb5dcd5476 (patch)
treec4f9df5061249bb76cc94886a8d20f136a34dec4 /devel/gwenhywfar/Makefile
parent32ecce3c9f1a24e4574aa7e272e9fcab01a5ba81 (diff)
downloadports-877d5ac090fe2e18a70da0f70fc033cb5dcd5476.tar.gz
ports-877d5ac090fe2e18a70da0f70fc033cb5dcd5476.zip
Notes
Diffstat (limited to 'devel/gwenhywfar/Makefile')
-rw-r--r--devel/gwenhywfar/Makefile68
1 files changed, 68 insertions, 0 deletions
diff --git a/devel/gwenhywfar/Makefile b/devel/gwenhywfar/Makefile
new file mode 100644
index 000000000000..f5b0ff66762a
--- /dev/null
+++ b/devel/gwenhywfar/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: gwenhywfar
+# Date created: 2005-05-05
+# Whom: Peter Cornelius <pcc.at.gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gwenhywfar
+PORTVERSION= 1.13.2
+CATEGORIES= devel net security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= lawrance@FreeBSD.org
+COMMENT= Multi-platform helper library for networking and security applications
+
+OPTIONS= SSLDEBUG "Enable gwenhywfar SSL debug (if SSL enabled)" off \
+ MEMDEBUG "Enable memory debugger statistic" off
+
+USE_LIBTOOL_VER=15
+USE_GETTEXT= yes
+USE_OPENSSL= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS+= %%PREFIX%%/lib/gwenhywfar/plugins/17/dbio
+ALL_TARGET= all
+
+# Examples to be installed from ${WRKSRC}/doc
+EXAMPLE_FILES= STYLE \
+ apidoc.h \
+ db2.png \
+ plugindescr.xml \
+ plugindescr.xsd \
+ plugindescr.xsd.in \
+ testdialog.xml
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+ALL_TARGET+= srcdoc
+PORTDOCS=*
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SSLDEBUG)
+# Enable appending of SSL connection in/output to /tmp/{read|written}.bin.
+CFLAGS+= -DGWEN_SSL_DEBUG
+.endif
+
+# Enable printing of memory debugger statistic at runtime.
+.if defined(WITH_MEMDEBUG)
+CFLAGS+= -DGWEN_MEMORY_DEBUG
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_CMD} Installing documentation...
+ ${MKDIR} ${EXAMPLESDIR}
+.for file in ${EXAMPLE_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${EXAMPLESDIR}
+.endfor
+ ${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${FIND} apidoc -mindepth 1 \! -type d \
+ -exec ${ECHO_CMD} "{} -> ${DOCSDIR}/{}" \; \
+ -exec ${INSTALL_DATA} ${WRKSRC}/{} ${DOCSDIR} \;
+.endif
+
+.include <bsd.port.post.mk>