aboutsummaryrefslogtreecommitdiff
path: root/devel/hgview/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-03-31 14:13:53 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-03-31 14:13:53 +0000
commit2ca2be37f02e498143145aaab11bb1a2c39eddd1 (patch)
treed5378221a9b02693f055a6c181ae5640fee1667b /devel/hgview/Makefile
parent214c9d247819326fb7847a7c7013d484f8bbb6e0 (diff)
downloadports-2ca2be37f02e498143145aaab11bb1a2c39eddd1.tar.gz
ports-2ca2be37f02e498143145aaab11bb1a2c39eddd1.zip
Notes
Diffstat (limited to 'devel/hgview/Makefile')
-rw-r--r--devel/hgview/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/devel/hgview/Makefile b/devel/hgview/Makefile
index 62eeacf23150..7f2476e3f9cd 100644
--- a/devel/hgview/Makefile
+++ b/devel/hgview/Makefile
@@ -11,10 +11,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Fast Mercurial log navigator written in pyqt4
RUN_DEPENDS= hg:${PORTSDIR}/devel/mercurial \
- ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui \
- ${PYTHON_SITELIBDIR}/PyQt4/Qsci.so:${PORTSDIR}/devel/py-qt4-qscintilla2 \
- ${PYTHON_SITELIBDIR}/mx/DateTime/__init__.py:${PORTSDIR}/lang/py-mx-base \
- ${PYTHON_SITELIBDIR}/docutils/__init__.py:${PORTSDIR}/textproc/py-docutils
+ ${PYTHON_PKGNAMEPREFIX}qt4-gui>0:${PORTSDIR}/x11-toolkits/py-qt4-gui \
+ ${PYTHON_PKGNAMEPREFIX}qt4-qscintilla2>0:${PORTSDIR}/devel/py-qt4-qscintilla2 \
+ ${PYTHON_PKGNAMEPREFIX}mx-base>0:${PORTSDIR}/lang/py-mx-base \
+ ${PYTHON_PKGNAMEPREFIX}docutils>0:${PORTSDIR}/textproc/py-docutils
BUILD_DEPENDS= hg:${PORTSDIR}/devel/mercurial \
pyrcc4:${PORTSDIR}/textproc/py-qt4-xml \
xmlto:${PORTSDIR}/textproc/xmlto \
@@ -25,14 +25,8 @@ USE_PYDISTUTILS=yes
USES= gmake
PORTDOCS= *
-MAN1= hgview.1
-
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|share/python-support/mercurial-common|${PYTHON_SITELIBDIR:C,^${PYTHONBASE}/,,}|' \
${WRKSRC}/hgviewlib/__pkginfo__.py
@@ -46,9 +40,7 @@ post-patch:
${WRKSRC}/setup.py
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>