aboutsummaryrefslogtreecommitdiff
path: root/devel/horde-chora
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 03:54:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 03:54:09 +0000
commit0825d343b67d333a5eb074ffc162e99e36afd05b (patch)
treefa9e30457336a2f3f64d4b8aec724296f7285e0a /devel/horde-chora
parent527b94968318c37ba67fae67811b60ad2500b11c (diff)
downloadports-0825d343b67d333a5eb074ffc162e99e36afd05b.tar.gz
ports-0825d343b67d333a5eb074ffc162e99e36afd05b.zip
Notes
Diffstat (limited to 'devel/horde-chora')
-rw-r--r--devel/horde-chora/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/devel/horde-chora/Makefile b/devel/horde-chora/Makefile
index c8230b1b3066..0329a050b774 100644
--- a/devel/horde-chora/Makefile
+++ b/devel/horde-chora/Makefile
@@ -35,6 +35,8 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-letter
.endif
NO_BUILD= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i.beforeChora
# Specify where your repository belongs.
# (You can reconfigure it after installation anyway)
@@ -70,21 +72,19 @@ do-install:
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
fi
.endfor
- @${PERL} -pi -e "s:%%CVSROOT%%:${CVSROOT}:;s:%%CONFDIR%%:${CONFDIR}:" \
+ @${REINPLACE_CMD} -e "s:%%CVSROOT%%:${CVSROOT}:;s:%%CONFDIR%%:${CONFDIR}:" \
${CONFDIR}/cvsroots.php
+ @${RM} ${CONFDIR}/cvsroots.php.beforeChora
@${CHOWN} -R www:www ${CHORADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.chora ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/chora:${CHORADIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/chora:${CHORADIR}:g" \
${HORDE_INC}/httpd.conf.chora
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeChora
- @${CP} -p ${HORDEDIR}/config/mime_drivers.php \
- ${HORDEDIR}/config/mime_drivers.php.beforeChora
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTCHORA::" \
+ @${RM} ${HORDE_INC}/httpd.conf.chora.beforeChora
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTCHORA::" \
${HORDEDIR}/config/registry.php
.if !defined(WITHOUT_ENSCRIPT)
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTCHORA::" \
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTCHORA::" \
${HORDEDIR}/config/mime_drivers.php
.endif
@${CP} -p ${HORDEDIR}/config/registry.php \