aboutsummaryrefslogtreecommitdiff
path: root/devel/hptools
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-07-28 00:11:02 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-07-28 00:11:02 +0000
commitde840348fef9795394e3b82dca31b0dee728456a (patch)
tree9a8a683d5a79e309c30a8680f28dbe3b275bed8c /devel/hptools
parenta8d0ccbf887b4dc8da43f35e106fc03eeae46ec8 (diff)
downloadports-de840348fef9795394e3b82dca31b0dee728456a.tar.gz
ports-de840348fef9795394e3b82dca31b0dee728456a.zip
Notes
Diffstat (limited to 'devel/hptools')
-rw-r--r--devel/hptools/Makefile42
-rw-r--r--devel/hptools/distinfo1
-rw-r--r--devel/hptools/pkg-descr9
-rw-r--r--devel/hptools/pkg-message43
-rw-r--r--devel/hptools/pkg-plist11
5 files changed, 106 insertions, 0 deletions
diff --git a/devel/hptools/Makefile b/devel/hptools/Makefile
new file mode 100644
index 000000000000..a700cb50cd41
--- /dev/null
+++ b/devel/hptools/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: hp48tools
+# Date created: June 2003
+# Whom: giffunip@asme.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= hptools
+PORTVERSION= 3.0.8
+CATEGORIES= devel
+MASTER_SITES= http://www.hpcalc.org/hp48/pc/programming/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= System RPL and assembly language tools for HP Calculators
+
+WRKSRC= ${WRKDIR}/Hptools/${CONFIGURE_TARGET}
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+CONFIGURE_SCRIPT= ../support/configure
+
+NO_CDROM= 'Commercial use is Prohibited'
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's,macintosh,__STDC__,' \
+ ${WRKDIR}/Hptools/common/envfile.c \
+ ${WRKDIR}/Hptools/rplcomp/defer.c \
+ ${WRKDIR}/Hptools/rplcomp/masd.c
+pre-configure:
+ @(${MKDIR} ${WRKSRC})
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/makerom ${PREFIX}/bin/rplcomp \
+ ${PREFIX}/bin/sasm ${PREFIX}/bin/sload
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/Hptools/doc/*.DOC ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/Hptools/doc/*.pdf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/hptools/distinfo b/devel/hptools/distinfo
new file mode 100644
index 000000000000..d1e6e6f9c742
--- /dev/null
+++ b/devel/hptools/distinfo
@@ -0,0 +1 @@
+MD5 (hptools-src-3.0.8.tar.gz) = 925a2b3ed75fe8524ac1e6b6ca18ac8f
diff --git a/devel/hptools/pkg-descr b/devel/hptools/pkg-descr
new file mode 100644
index 000000000000..9edebaf06238
--- /dev/null
+++ b/devel/hptools/pkg-descr
@@ -0,0 +1,9 @@
+HP Tools 3.0.x
+
+This is the free System RPL and assembly language (HP syntax and MASD
+[MetaKernel] syntax) development kit.
+
+for more information on how to program in SystemRPL or ML check
+WWW: http://www.hpcalc.org
+_______
+Jean-Yves (jean-yves.avenard@hydrix.com)
diff --git a/devel/hptools/pkg-message b/devel/hptools/pkg-message
new file mode 100644
index 000000000000..31a0bd8a34d9
--- /dev/null
+++ b/devel/hptools/pkg-message
@@ -0,0 +1,43 @@
+ HPTOOLS DISTRIBUTION LICENSE
+ ---------------------------
+
+HPTOOLS (c) 1998-2002 by Hewlett-Packard and Jean-Yves Avenard
+
+This license applies to all files of the HPTOOLS distribution except the files
+listed below as Exception files, in all formats including but not limited
+to source code distribution and documentation distribution. All the files
+of the HPTOOLS distribution except the files listed below as Exception files
+will be referred to as "HPTOOLS" in the following.
+
+Permission to make and distribute verbatim copies of HPTOOLS
+is granted provided that:
+1/ the copies are not made or distributed for resale
+2/ you conspicuously and appropriately include on each copy the Copyright
+Notice and Disclaimer of Warranty as well as this License.
+
+You may modify your copy or copies of HPTOOLS or any portion
+thereof for your personal use, but publishing or distributing any modified
+version of HPTOOLS in any format (including but not limited to source files,
+object files or printed files) without the written permission of the
+copyright holders is prohibited.
+
+Commercial use of HPTOOLS is prohibited without the written permission
+of the copyright holders.
+
+By copying, modifying or distributing HPTOOLS, you indicate your acceptance
+of this license. All these actions are prohibited by law if you do not accept
+this license agreement.
+
+
+Disclaimer of Warranty
+----------------------
+
+HPTOOLS source files, binaries and documentation are distributed in the hope
+that they will be useful, but the
+COPYRIGHT HOLDERS PROVIDES THE PROGRAM AND DOCUMENTATION "AS THEY ARE"
+WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT
+NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE. IN NO EVENT WILL THE COPYRIGHT HOLDERS BE LIABLE TO YOU
+FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL
+DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM OR
+DOCUMENTATION OF HPTOOLS.
diff --git a/devel/hptools/pkg-plist b/devel/hptools/pkg-plist
new file mode 100644
index 000000000000..2dd8a4f5322c
--- /dev/null
+++ b/devel/hptools/pkg-plist
@@ -0,0 +1,11 @@
+bin/makerom
+bin/rplcomp
+bin/sasm
+bin/sload
+%%PORTDOCS%%%%DOCSDIR%%/MAKEROM.DOC
+%%PORTDOCS%%%%DOCSDIR%%/RPLCOMP.DOC
+%%PORTDOCS%%%%DOCSDIR%%/RPLMAN.DOC
+%%PORTDOCS%%%%DOCSDIR%%/SASM.DOC
+%%PORTDOCS%%%%DOCSDIR%%/SLOAD.DOC
+%%PORTDOCS%%%%DOCSDIR%%/masd.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%