aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-EdisonAPI
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-08-08 17:21:45 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-08-08 17:21:45 +0000
commit25bf018f0fa446ca38508d35b6b3474e88d758d3 (patch)
tree45b457da59382af32e809be042d2a1a7cad9e952 /devel/hs-EdisonAPI
parent1c8feb1a3fd41782660f5439357efe8a9519c625 (diff)
downloadports-25bf018f0fa446ca38508d35b6b3474e88d758d3.tar.gz
ports-25bf018f0fa446ca38508d35b6b3474e88d758d3.zip
Notes
Diffstat (limited to 'devel/hs-EdisonAPI')
-rw-r--r--devel/hs-EdisonAPI/Makefile15
-rw-r--r--devel/hs-EdisonAPI/distinfo3
-rw-r--r--devel/hs-EdisonAPI/pkg-descr11
3 files changed, 29 insertions, 0 deletions
diff --git a/devel/hs-EdisonAPI/Makefile b/devel/hs-EdisonAPI/Makefile
new file mode 100644
index 000000000000..c17c2f457a0a
--- /dev/null
+++ b/devel/hs-EdisonAPI/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= EdisonAPI
+PORTVERSION= 1.3.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A library of efficient, purely-functional data structures (API)
+
+LICENSE= MIT
+
+USE_CABAL= mtl
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-EdisonAPI/distinfo b/devel/hs-EdisonAPI/distinfo
new file mode 100644
index 000000000000..c3562b5b71c7
--- /dev/null
+++ b/devel/hs-EdisonAPI/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1500996490
+SHA256 (cabal/EdisonAPI-1.3.1.tar.gz) = 95a3b8d01599520a50456219b5a2e9f7832bcddaaeb8e94ce777bd87a4a6b56e
+SIZE (cabal/EdisonAPI-1.3.1.tar.gz) = 30512
diff --git a/devel/hs-EdisonAPI/pkg-descr b/devel/hs-EdisonAPI/pkg-descr
new file mode 100644
index 000000000000..e83fa3d6151d
--- /dev/null
+++ b/devel/hs-EdisonAPI/pkg-descr
@@ -0,0 +1,11 @@
+Edison is a library of purely functional data structures written by Chris
+Okasaki. It is named after Thomas Alva Edison and for the mnemonic value
+EDiSon (Efficient Data Structures). Edison provides several families of
+abstractions, each with multiple implementations. The main abstractions
+provided by Edison are: Sequences such as stacks, queues, and dequeues;
+Collections such as sets, bags and heaps; and Associative Collections such
+as finite maps and priority queues where the priority and element are
+distinct.
+
+WWW: http://rwd.rdockins.name/edison/home/
+