aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-QuickCheck
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-06-03 21:32:25 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-06-03 21:32:25 +0000
commitccfe210c86c4e409c9145d21ed5cb6db100241b4 (patch)
treef67c66860659096fb350ea3f2daca3256364221b /devel/hs-QuickCheck
parentd9b6a79cb4f543c6bb7e5a0bf08a82fd97e408b1 (diff)
Notes
Diffstat (limited to 'devel/hs-QuickCheck')
-rw-r--r--devel/hs-QuickCheck/Makefile4
-rw-r--r--devel/hs-QuickCheck/distinfo4
-rw-r--r--devel/hs-QuickCheck/pkg-descr18
3 files changed, 15 insertions, 11 deletions
diff --git a/devel/hs-QuickCheck/Makefile b/devel/hs-QuickCheck/Makefile
index af659912f121..c650e1efc203 100644
--- a/devel/hs-QuickCheck/Makefile
+++ b/devel/hs-QuickCheck/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= QuickCheck
-PORTVERSION= 2.4.1.1
+PORTVERSION= 2.4.2
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
@@ -13,5 +13,7 @@ COMMENT= Library for random testing in haskell
LICENSE= BSD
+USE_CABAL= random
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/devel/hs-QuickCheck/distinfo b/devel/hs-QuickCheck/distinfo
index fb30b92ba9cb..31badbe4db68 100644
--- a/devel/hs-QuickCheck/distinfo
+++ b/devel/hs-QuickCheck/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/QuickCheck-2.4.1.1.tar.gz) = 92a711d613bf0ce61b5843386923abf112bf509fa37931a893222a2324b0791b
-SIZE (cabal/QuickCheck-2.4.1.1.tar.gz) = 25068
+SHA256 (cabal/QuickCheck-2.4.2.tar.gz) = 6f05c399ae7b70c09ab21337caf1211f43fd76d6ad9b3814a4009ddbf438179f
+SIZE (cabal/QuickCheck-2.4.2.tar.gz) = 25373
diff --git a/devel/hs-QuickCheck/pkg-descr b/devel/hs-QuickCheck/pkg-descr
index f940f045d589..11dab0c4ae90 100644
--- a/devel/hs-QuickCheck/pkg-descr
+++ b/devel/hs-QuickCheck/pkg-descr
@@ -1,10 +1,12 @@
-QuickCheck is a library for random testing of program properties. The programmer
-provides a specification of the program, in the form of properties which
-functions should satisfy, and QuickCheck then tests that the properties hold in
-a large number of randomly generated cases.
+QuickCheck is a library for random testing of program properties.
-Specifications are expressed in Haskell, using combinators defined in the
-QuickCheck library. QuickCheck provides combinators to define properties,
-observe the distribution of test data, and define test data generators.
+The programmer provides a specification of the program, in the form of
+properties which functions should satisfy, and QuickCheck then tests
+that the properties hold in a large number of randomly generated cases.
-WWWW: http://www.cs.chalmers.se/~koen
+Specifications are expressed in Haskell, using combinators defined in
+the QuickCheck library. QuickCheck provides combinators to define
+properties, observe the distribution of test data, and define test data
+generators.
+
+WWW: http://code.haskell.org/QuickCheck