aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-alex
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-08-13 18:44:10 +0000
committerOliver Braun <obraun@FreeBSD.org>2003-08-13 18:44:10 +0000
commit5e2a14700eba72c09c7328e3a62d5a8bff1789ac (patch)
tree504ddad85a4c3d3fdfceb1cf38c75977223c0163 /devel/hs-alex
parent64740c8f28b5709e9b7d8066ab989a16e1728f36 (diff)
downloadports-5e2a14700eba72c09c7328e3a62d5a8bff1789ac.tar.gz
ports-5e2a14700eba72c09c7328e3a62d5a8bff1789ac.zip
Notes
Diffstat (limited to 'devel/hs-alex')
-rw-r--r--devel/hs-alex/Makefile36
-rw-r--r--devel/hs-alex/distinfo2
-rw-r--r--devel/hs-alex/pkg-descr7
-rw-r--r--devel/hs-alex/pkg-plist25
4 files changed, 45 insertions, 25 deletions
diff --git a/devel/hs-alex/Makefile b/devel/hs-alex/Makefile
index d9966c87167e..3ee6f2aec313 100644
--- a/devel/hs-alex/Makefile
+++ b/devel/hs-alex/Makefile
@@ -6,33 +6,39 @@
PORTNAME= alex
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= devel haskell
-MASTER_SITES= http://www.syntaxpolice.org/~ijones/alex/
-DISTNAME= ${PORTNAME}
-DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
-
+MASTER_SITES= http://www.haskell.org/alex/dist/
PKGNAMEPREFIX= hs-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-MAINTAINER= obraun@FreeBSD.org
-COMMENT= Alex is a Lex-like package for generating Haskell scanners
+MAINTAINER= stolz@i2.informatik.rwth-aachen.de
+COMMENT= Alex is a tool for generating lexical analysers in Haskell
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= jade:${PORTSDIR}/textproc/jade
+.endif
+USE_BZIP2= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-BUILD_WRKSRC= ${WRKSRC}/src
-MAKEFILE= makefile
-ALL_TARGET= alex
+PLIST_SUB= "PORTVERSION=${PORTVERSION}"
+
+.if !defined(NOPORTDOCS)
+post-build:
+ ${GMAKE} -C ${WRKSRC}/alex/doc ps
+.endif
-do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/alex ${PREFIX}/bin
+post-install:
${MKDIR} ${EXAMPLESDIR}
-.for i in Alex.hs ctx.x lit.lx pp.x tiny.y xscan.x Tokens.x examples.x makefile state.x tkns.hs
- ${INSTALL_DATA} ${WRKSRC}/examples/$i ${EXAMPLESDIR}
-.endfor
+ ${FIND} ${WRKSRC}/alex/examples -type f -exec ${INSTALL_DATA} \{\} ${EXAMPLESDIR} \;
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/alex.ps ${WRKSRC}/doc/alex.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/alex/doc/alex.ps ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/hs-alex/distinfo b/devel/hs-alex/distinfo
index 240ec343bc9d..8c243e2a280d 100644
--- a/devel/hs-alex/distinfo
+++ b/devel/hs-alex/distinfo
@@ -1 +1 @@
-MD5 (alex-2.0/alex.tar.gz) = 3b109767f6fb0aaafed9170f99109aa5
+MD5 (alex-2.0-src.tar.bz2) = 14ff6abf21d81763b15afe151add9091
diff --git a/devel/hs-alex/pkg-descr b/devel/hs-alex/pkg-descr
index 7a8b31f2b1bb..78bbdcd6119d 100644
--- a/devel/hs-alex/pkg-descr
+++ b/devel/hs-alex/pkg-descr
@@ -1,4 +1,5 @@
-Alex is a Lex-like package for generating Haskell scanners
-by Chris Dornan.
+Alex is a tool for generating lexical analysers in Haskell, given a description
+of the tokens to be recognised in the form of regular expressions. It is similar
+to the tool lex or flex for C/C++ by Chris Dornan and Simon Marlow.
-WWW: http://www.syntaxpolice.org/~ijones/alex/
+WWW: http://www.haskell.org/alex/
diff --git a/devel/hs-alex/pkg-plist b/devel/hs-alex/pkg-plist
index c62f913b6feb..e1f2995db114 100644
--- a/devel/hs-alex/pkg-plist
+++ b/devel/hs-alex/pkg-plist
@@ -1,16 +1,29 @@
bin/alex
+bin/alex-%%PORTVERSION%%
+lib/alex-%%PORTVERSION%%/alex.bin
+lib/alex-%%PORTVERSION%%/AlexTemplate
+lib/alex-%%PORTVERSION%%/AlexTemplate-ghc
+lib/alex-%%PORTVERSION%%/AlexTemplate-ghc-debug
+lib/alex-%%PORTVERSION%%/AlexTemplate-debug
+lib/alex-%%PORTVERSION%%/AlexWrapper-basic
+lib/alex-%%PORTVERSION%%/AlexWrapper-posn
+lib/alex-%%PORTVERSION%%/AlexWrapper-monad
+lib/alex-%%PORTVERSION%%/AlexWrapper-gscan
+@dirrm lib/alex-%%PORTVERSION%%
%%PORTDOCS%%share/doc/alex/alex.ps
-%%PORTDOCS%%share/doc/alex/alex.pdf
%%PORTDOCS%%@dirrm share/doc/alex
-share/examples/alex/Alex.hs
+share/examples/alex/Makefile
share/examples/alex/Tokens.x
-share/examples/alex/ctx.x
+share/examples/alex/Tokens_gscan.x
+share/examples/alex/Tokens_posn.x
share/examples/alex/examples.x
-share/examples/alex/lit.lx
-share/examples/alex/makefile
+share/examples/alex/haskell.x
+share/examples/alex/lit.x
share/examples/alex/pp.x
share/examples/alex/state.x
share/examples/alex/tiny.y
share/examples/alex/tkns.hs
-share/examples/alex/xscan.x
+share/examples/alex/words.x
+share/examples/alex/words_monad.x
+share/examples/alex/words_posn.x
@dirrm share/examples/alex