aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-alex
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-01-31 22:24:58 +0000
committerOliver Braun <obraun@FreeBSD.org>2003-01-31 22:24:58 +0000
commitb7f2ff0214fa7251935b89c300853b23ed7deae6 (patch)
treedddb3acc09c22c130c3694e1e5d193a2f7be86b4 /devel/hs-alex
parenta92d5ca579eb3f830bf7ab11c57bf84355104700 (diff)
downloadports-b7f2ff0214fa7251935b89c300853b23ed7deae6.tar.gz
ports-b7f2ff0214fa7251935b89c300853b23ed7deae6.zip
Notes
Diffstat (limited to 'devel/hs-alex')
-rw-r--r--devel/hs-alex/Makefile37
-rw-r--r--devel/hs-alex/distinfo1
-rw-r--r--devel/hs-alex/pkg-comment1
-rw-r--r--devel/hs-alex/pkg-descr4
-rw-r--r--devel/hs-alex/pkg-plist16
5 files changed, 59 insertions, 0 deletions
diff --git a/devel/hs-alex/Makefile b/devel/hs-alex/Makefile
new file mode 100644
index 000000000000..c2b7a077a1e2
--- /dev/null
+++ b/devel/hs-alex/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: alex
+# Date created: 29 January 2003
+# Whom: Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
+#
+# $FreeBSD$
+
+PORTNAME= alex
+PORTVERSION= 1.1
+CATEGORIES= devel haskell
+MASTER_SITES= http://www.syntaxpolice.org/~ijones/alex/
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+
+USE_GMAKE= yes
+
+BUILD_WRKSRC= ${WRKSRC}/src
+MAKEFILE= makefile
+ALL_TARGET= alex
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/alex ${PREFIX}/bin
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in Alex.hs ctx.x lit.lx pp.x tiny.y xscan.x Tokens.x examples.x makefile state.x tkns.hs
+ ${INSTALL_DATA} ${WRKSRC}/examples/$i ${EXAMPLESDIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/alex.ps ${WRKSRC}/doc/alex.pdf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/hs-alex/distinfo b/devel/hs-alex/distinfo
new file mode 100644
index 000000000000..a870d229363d
--- /dev/null
+++ b/devel/hs-alex/distinfo
@@ -0,0 +1 @@
+MD5 (alex-1.1/alex.tar.gz) = 3b109767f6fb0aaafed9170f99109aa5
diff --git a/devel/hs-alex/pkg-comment b/devel/hs-alex/pkg-comment
new file mode 100644
index 000000000000..25de693237d5
--- /dev/null
+++ b/devel/hs-alex/pkg-comment
@@ -0,0 +1 @@
+Alex is a Lex-like package for generating Haskell scanners
diff --git a/devel/hs-alex/pkg-descr b/devel/hs-alex/pkg-descr
new file mode 100644
index 000000000000..7a8b31f2b1bb
--- /dev/null
+++ b/devel/hs-alex/pkg-descr
@@ -0,0 +1,4 @@
+Alex is a Lex-like package for generating Haskell scanners
+by Chris Dornan.
+
+WWW: http://www.syntaxpolice.org/~ijones/alex/
diff --git a/devel/hs-alex/pkg-plist b/devel/hs-alex/pkg-plist
new file mode 100644
index 000000000000..c62f913b6feb
--- /dev/null
+++ b/devel/hs-alex/pkg-plist
@@ -0,0 +1,16 @@
+bin/alex
+%%PORTDOCS%%share/doc/alex/alex.ps
+%%PORTDOCS%%share/doc/alex/alex.pdf
+%%PORTDOCS%%@dirrm share/doc/alex
+share/examples/alex/Alex.hs
+share/examples/alex/Tokens.x
+share/examples/alex/ctx.x
+share/examples/alex/examples.x
+share/examples/alex/lit.lx
+share/examples/alex/makefile
+share/examples/alex/pp.x
+share/examples/alex/state.x
+share/examples/alex/tiny.y
+share/examples/alex/tkns.hs
+share/examples/alex/xscan.x
+@dirrm share/examples/alex