aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-alex
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-06-05 11:59:16 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-06-05 11:59:16 +0000
commit3dca42aa929e7dfcd4ebbc1bb97cb17f85ef4880 (patch)
treef9481c8c56830bf321c4fe4fe9ea6ce269ff0926 /devel/hs-alex
parent91f16d9025f5c261b81f761ed589c502f5b56dd4 (diff)
- Respect custom PREFIX, LOCALBASE
- Bump port revision Reported by: QAT Approved by: gabor (mentor)
Notes
Notes: svn path=/head/; revision=235203
Diffstat (limited to 'devel/hs-alex')
-rw-r--r--devel/hs-alex/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/devel/hs-alex/Makefile b/devel/hs-alex/Makefile
index 0b47cae175b3..ab4bc067650f 100644
--- a/devel/hs-alex/Makefile
+++ b/devel/hs-alex/Makefile
@@ -6,6 +6,7 @@
PORTNAME= alex
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/alex/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -14,9 +15,11 @@ MAINTAINER= haskell@FreeBSD.org
COMMENT= Alex is a tool for generating lexical analysers in Haskell
BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= ${LOCALBASE}/share/xsl/docbook/html:${PORTSDIR}/textproc/docbook-xsl \
${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt
+
PLIST_SUB+= RMLIC="@comment "
.else
PLIST_SUB+= RMLIC=""
@@ -32,6 +35,10 @@ PORTDOCS= LICENSE html
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${PORTVERSION}
PORTEXAMPLES= *
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/share/xsl/docbook|${LOCALBASE}/share/xsl/docbook|' \
+ ${WRKSRC}/doc/configure.ac
+
do-configure:
cd ${WRKSRC} && runhaskell Setup.lhs configure ${CONFIGURE_ARGS}
cd ${WRKSRC}/doc && ${AUTOCONF} && ./configure --prefix=${PREFIX}