aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-ansi-terminal
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-05-21 21:49:50 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-05-21 21:49:50 +0000
commitfd3b774de34babff72c1b507a0af99ca099d101e (patch)
tree1b4530add524203e7554d7b3cc26a5bcc3096227 /devel/hs-ansi-terminal
parent261cb67402ec244fcb21a4d7a3247e5484003f3c (diff)
downloadports-fd3b774de34babff72c1b507a0af99ca099d101e.tar.gz
ports-fd3b774de34babff72c1b507a0af99ca099d101e.zip
Notes
Diffstat (limited to 'devel/hs-ansi-terminal')
-rw-r--r--devel/hs-ansi-terminal/Makefile29
-rw-r--r--devel/hs-ansi-terminal/distinfo3
-rw-r--r--devel/hs-ansi-terminal/pkg-descr6
-rw-r--r--devel/hs-ansi-terminal/pkg-plist19
4 files changed, 57 insertions, 0 deletions
diff --git a/devel/hs-ansi-terminal/Makefile b/devel/hs-ansi-terminal/Makefile
new file mode 100644
index 000000000000..c9a6cf21e0ee
--- /dev/null
+++ b/devel/hs-ansi-terminal/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: hs-ansi-terminal
+# Date created: May 21, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ansi-terminal
+PORTVERSION= 0.5.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Simple ANSI terminal support, with Windows compatibility
+
+OPTIONS= EXAMPLE "Build the example application" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_EXAMPLE)
+CONFIGURE_ARGS+= --flags="Example"
+EXECUTABLE= ansi-terminal-example
+PLIST_SUB+= MAYBE_EXAMPLE=""
+.else
+CONFIGURE_ARGS+= --flags="-Example"
+PLIST_SUB+= MAYBE_EXAMPLE="@comment "
+.endif
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-ansi-terminal/distinfo b/devel/hs-ansi-terminal/distinfo
new file mode 100644
index 000000000000..2429ab1ddead
--- /dev/null
+++ b/devel/hs-ansi-terminal/distinfo
@@ -0,0 +1,3 @@
+MD5 (ansi-terminal-0.5.1.tar.gz) = 6e6916a87980203381c337b711afcef5
+SHA256 (ansi-terminal-0.5.1.tar.gz) = d34e706305f12b2d9baf01805c034ccbd5220f5f84c355869d507c1ea684532e
+SIZE (ansi-terminal-0.5.1.tar.gz) = 12322
diff --git a/devel/hs-ansi-terminal/pkg-descr b/devel/hs-ansi-terminal/pkg-descr
new file mode 100644
index 000000000000..536f3d647320
--- /dev/null
+++ b/devel/hs-ansi-terminal/pkg-descr
@@ -0,0 +1,6 @@
+ANSI terminal support for Haskell: allows cursor movement, screen
+clearing, color output showing or hiding the cursor, and changing the
+title. Compatible with Windows and those Unixes with ANSI terminals, but
+only GHC is supported as a compiler.
+
+WWW: http://batterseapower.github.com/ansi-terminal
diff --git a/devel/hs-ansi-terminal/pkg-plist b/devel/hs-ansi-terminal/pkg-plist
new file mode 100644
index 000000000000..fadbc815b090
--- /dev/null
+++ b/devel/hs-ansi-terminal/pkg-plist
@@ -0,0 +1,19 @@
+@comment $FreeBSD$
+%%MAYBE_EXAMPLE%%bin/ansi-terminal-example
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/System/Console/ANSI.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/System/Console/ANSI/Common.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/System/Console/ANSI/Unix.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/System/Console/ANSI
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/System/Console
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/System
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old