aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-binary
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-01-30 10:11:36 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-01-30 10:11:36 +0000
commitbb2a4a32e295466d661b56f32f878e59d4f5ac3b (patch)
treed180494036115925f18fbc7a3cc08cc7d13051c1 /devel/hs-binary
parent80de8283418560597f36012582cc655eed8e5b03 (diff)
downloadports-bb2a4a32e295466d661b56f32f878e59d4f5ac3b.tar.gz
ports-bb2a4a32e295466d661b56f32f878e59d4f5ac3b.zip
Notes
Diffstat (limited to 'devel/hs-binary')
-rw-r--r--devel/hs-binary/Makefile11
-rw-r--r--devel/hs-binary/pkg-plist19
2 files changed, 10 insertions, 20 deletions
diff --git a/devel/hs-binary/Makefile b/devel/hs-binary/Makefile
index 73b07755d36f..da84c8155aba 100644
--- a/devel/hs-binary/Makefile
+++ b/devel/hs-binary/Makefile
@@ -7,6 +7,7 @@
PORTNAME= binary
PORTVERSION= 0.4.4
+PORTREVISION= 1
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -27,12 +28,16 @@ PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
PORTNAME=${PORTNAME} \
PORTVERSION=${PORTVERSION} \
SUBDIR=${CABALDIR}
-DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= LICENSE html
CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${PREFIX}/${CABALDIR} --libsubdir='' --datasubdir=''
-.ifndef (NOPORTDOCS)
+.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.else
+PLIST_DIRS+= %%DOCSDIR%%
+PLIST_FILES+= %%DOCSDIR%%/LICENSE
.endif
do-configure:
@@ -40,7 +45,7 @@ do-configure:
do-build:
cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
-.ifndef (NOPORTDOCS)
+.if !defined(NOPORTDOCS)
cd ${WRKSRC} && ${CABALCMD} haddock
.endif
diff --git a/devel/hs-binary/pkg-plist b/devel/hs-binary/pkg-plist
index b0b29313a345..a9e56d73bf36 100644
--- a/devel/hs-binary/pkg-plist
+++ b/devel/hs-binary/pkg-plist
@@ -2,24 +2,9 @@
%%SUBDIR%%/Data/Binary/Builder.hi
%%SUBDIR%%/Data/Binary/Get.hi
%%SUBDIR%%/Data/Binary/Put.hi
-%%SUBDIR%%/HSbinary-%%PORTVERSION%%.o
-%%SUBDIR%%/libHSbinary-%%PORTVERSION%%.a
+%%SUBDIR%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%SUBDIR%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
%%SUBDIR%%/%%PORTNAME%%-register.sh
-%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/html/%%PORTNAME%%.haddock
-%%PORTDOCS%%%%DOCSDIR%%/html/doc-index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/haddock-util.js
-%%PORTDOCS%%%%DOCSDIR%%/html/haddock.css
-%%PORTDOCS%%%%DOCSDIR%%/html/haskell_icon.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/minus.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/plus.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary-Builder.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary-Get.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary-Put.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-@dirrm %%DOCSDIR%%
@dirrmtry %%SUBDIR%%/Data/Binary
@dirrmtry %%SUBDIR%%/Data
@exec sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh