aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-blaze-builder
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2011-05-08 19:05:23 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2011-05-08 19:05:23 +0000
commite2eb708b23392748d0ea3a7b7e8a85ef631e0ea1 (patch)
tree2b24d8606ab8d7d341646d0e8372b96224fbb16b /devel/hs-blaze-builder
parent20902803355c74da169e677ea1979d9aba5b8990 (diff)
This library provides an abstraction of buffered output of byte streams and
several convenience functions to exploit it. For example, it allows to efficiently serialize Haskell values to lazy bytestrings with a large average chunk size. The large average chunk size allows to make good use of cache prefetching in later processing steps (e.g. compression) and reduces the sytem call overhead when writing the resulting lazy bytestring to a file or sending it over the network. WWW: http://github.com/meiersi/blaze-builder Approved by: pgj (mentor) Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=273800
Diffstat (limited to 'devel/hs-blaze-builder')
-rw-r--r--devel/hs-blaze-builder/Makefile21
-rw-r--r--devel/hs-blaze-builder/distinfo2
-rw-r--r--devel/hs-blaze-builder/pkg-descr9
3 files changed, 32 insertions, 0 deletions
diff --git a/devel/hs-blaze-builder/Makefile b/devel/hs-blaze-builder/Makefile
new file mode 100644
index 000000000000..b28a4dd5cf48
--- /dev/null
+++ b/devel/hs-blaze-builder/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-blaze-builder
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= blaze-builder
+PORTVERSION= 0.2.1.4
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Efficient buffered output
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= text>=0.10
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-blaze-builder/distinfo b/devel/hs-blaze-builder/distinfo
new file mode 100644
index 000000000000..7f1722cd5778
--- /dev/null
+++ b/devel/hs-blaze-builder/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/blaze-builder-0.2.1.4.tar.gz) = c28845628e071aa418ed13eeb03726e070039c3285a6d25f4a3b280eb9901464
+SIZE (cabal/blaze-builder-0.2.1.4.tar.gz) = 60358
diff --git a/devel/hs-blaze-builder/pkg-descr b/devel/hs-blaze-builder/pkg-descr
new file mode 100644
index 000000000000..b0596e949b82
--- /dev/null
+++ b/devel/hs-blaze-builder/pkg-descr
@@ -0,0 +1,9 @@
+This library provides an abstraction of buffered output of byte streams and
+several convenience functions to exploit it. For example, it allows to
+efficiently serialize Haskell values to lazy bytestrings with a large average
+chunk size. The large average chunk size allows to make good use of cache
+prefetching in later processing steps (e.g. compression) and reduces the sytem
+call overhead when writing the resulting lazy bytestring to a file or sending
+it over the network.
+
+WWW: http://github.com/meiersi/blaze-builder