aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-buddha
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2004-01-16 12:06:58 +0000
committerOliver Braun <obraun@FreeBSD.org>2004-01-16 12:06:58 +0000
commitefb6d0a51344e45b4a00b129c1e2e8a2f3838ae9 (patch)
tree38a01a1c3d1baba0601bc2fdee0a0b3cfa9c6499 /devel/hs-buddha
parentb96dc1d89ba8fe47695e75c51dd1b5a1ba3fd75f (diff)
downloadports-efb6d0a51344e45b4a00b129c1e2e8a2f3838ae9.tar.gz
ports-efb6d0a51344e45b4a00b129c1e2e8a2f3838ae9.zip
Notes
Diffstat (limited to 'devel/hs-buddha')
-rw-r--r--devel/hs-buddha/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/hs-buddha/Makefile b/devel/hs-buddha/Makefile
index c5a9d071c331..ddd403552634 100644
--- a/devel/hs-buddha/Makefile
+++ b/devel/hs-buddha/Makefile
@@ -18,6 +18,7 @@ COMMENT= A declarative debugger for Haskell 98
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
USE_GMAKE= yes
@@ -30,6 +31,10 @@ pre-everything::
@${ECHO_CMD} "They are available, unless your GHC has been built with WITHOUT_PROFILE=yes."
@${ECHO_CMD} ""
+post-patch:
+ @${REINPLACE_CMD} -e 's/-package lang/-package lang -package text/' \
+ ${WRKSRC}/transform/Makefile.in
+
pre-build:
@(cd ${WRKSRC} && ${GMAKE} depend)