aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-cpphs/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2004-06-14 18:28:55 +0000
committerOliver Braun <obraun@FreeBSD.org>2004-06-14 18:28:55 +0000
commit03ae7cbb7a3049c2127cea981d7567a5130c4aad (patch)
tree1101f1585569fdfa4070fc80d192ce485e4e4f02 /devel/hs-cpphs/Makefile
parentc708fa4cf8f6d7ef403f636e8a57d1a7ed2492fc (diff)
downloadports-03ae7cbb7a3049c2127cea981d7567a5130c4aad.tar.gz
ports-03ae7cbb7a3049c2127cea981d7567a5130c4aad.zip
Notes
Diffstat (limited to 'devel/hs-cpphs/Makefile')
-rw-r--r--devel/hs-cpphs/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/hs-cpphs/Makefile b/devel/hs-cpphs/Makefile
new file mode 100644
index 000000000000..16dab8fb28c5
--- /dev/null
+++ b/devel/hs-cpphs/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cpphs
+# Date created: 14 June 2004
+# Whom: obraun@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpphs
+PORTVERSION= 0.5
+CATEGORIES= devel haskell
+MASTER_SITES= http://www.cs.york.ac.uk/fp/cpphs/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A simplified re-implementation of cpp in Haskell
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+
+PLIST_FILES= bin/cpphs
+
+do-build:
+ @(cd ${WRKSRC} && ghc -o cpphs --make cpphs)
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/cpphs ${PREFIX}/bin/cpphs
+
+.include <bsd.port.mk>