aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-dlist/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-15 19:51:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-15 19:51:57 +0000
commita2d02bde1863c6beb593a7ca7b376382ac4f7a64 (patch)
tree75fed1c9a28140ff1bffb581a807219d0d6b72e0 /devel/hs-dlist/Makefile
parent32a1d5cb97a9da0077f45e3556a425f239c0b87a (diff)
Notes
Diffstat (limited to 'devel/hs-dlist/Makefile')
-rw-r--r--devel/hs-dlist/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/hs-dlist/Makefile b/devel/hs-dlist/Makefile
new file mode 100644
index 000000000000..3a550cb7ad08
--- /dev/null
+++ b/devel/hs-dlist/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: dlist
+# Date created: November 10, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= dlist
+PORTVERSION= 0.4.1
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/ \
+ http://carte.kerneled.org/mirror/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= A list-like type supporting O(1) append for Haskell
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+
+.include <bsd.port.mk>