aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-drift/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-08-21 20:49:30 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-08-21 20:49:30 +0000
commit5ffe51331570685ec560a5db1b007e2b3d64e424 (patch)
tree72eda43a11767de0e65c47661c93895bd4f03a63 /devel/hs-drift/Makefile
parentd6a00af6f5f6cc94355f4cf8efddaec89b6cfabe (diff)
downloadports-5ffe51331570685ec560a5db1b007e2b3d64e424.tar.gz
ports-5ffe51331570685ec560a5db1b007e2b3d64e424.zip
Notes
Diffstat (limited to 'devel/hs-drift/Makefile')
-rw-r--r--devel/hs-drift/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/hs-drift/Makefile b/devel/hs-drift/Makefile
new file mode 100644
index 000000000000..51fbccac83f6
--- /dev/null
+++ b/devel/hs-drift/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: drift
+# Date created: 13 August 2002
+# Whom: Oliver Braun <obraun@informatik.unibw-muenchen.de>
+#
+# $FreeBSD$
+
+PORTNAME= drift
+PORTVERSION= 2.0.r3
+CATEGORIES= devel
+MASTER_SITES= http://repetae.net/john/computer/haskell/DrIFT/
+DISTNAME= DrIFT-${PORTVERSION:S/.r/rc/}
+
+MAINTAINER= obraun@informatik.unibw-muenchen.de
+
+.if !defined(WITH_GHC)
+BUILD_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
+.else
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+.endif
+
+HAS_CONFIGURE= yes
+
+.if !defined(WITH_GHC)
+CONFIGURE_ARGS+= --with-hc=nhc98
+.else
+CONFIGURE_ARGS+= --with-hc=ghc
+.endif
+
+.if !defined(WITH_GHC)
+pre-everything:
+ @${ECHO} ""
+ @${ECHO} " DrIFT will be build with nhc98."
+ @${ECHO} " Define WITH_GHC to build with ghc."
+ @${ECHO} ""
+.endif
+
+.include <bsd.port.mk>