aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-drift
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-12-02 08:31:51 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-12-02 08:31:51 +0000
commit154d0ead44fde3261a9ce7c8b780dc4ca24bc474 (patch)
tree27940e0e046beca8eb34d42d70004409c9bd9b53 /devel/hs-drift
parent7379be860e13027b00b05babd61c923c41e432b5 (diff)
downloadports-154d0ead44fde3261a9ce7c8b780dc4ca24bc474.tar.gz
ports-154d0ead44fde3261a9ce7c8b780dc4ca24bc474.zip
Notes
Diffstat (limited to 'devel/hs-drift')
-rw-r--r--devel/hs-drift/Makefile8
-rw-r--r--devel/hs-drift/files/patch-src::GenUtil.hs11
-rw-r--r--devel/hs-drift/pkg-plist2
3 files changed, 18 insertions, 3 deletions
diff --git a/devel/hs-drift/Makefile b/devel/hs-drift/Makefile
index 74412b1b0c0b..e4ec705bb939 100644
--- a/devel/hs-drift/Makefile
+++ b/devel/hs-drift/Makefile
@@ -14,6 +14,11 @@ DISTNAME= DrIFT-${PORTVERSION}
MAINTAINER= haskell@FreeBSD.org
COMMENT= A type sensitive preprocessor for Haskell
+OPTIONS= NHC98 "Build with nhc98" off \
+ GHC "Build with ghc" on
+
+.include <bsd.port.pre.mk>
+
.if !defined(WITH_NHC98)
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
.else
@@ -23,6 +28,7 @@ BUILD_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
HAS_CONFIGURE= yes
INFO= drift
+PLIST_FILES= bin/DrIFT bin/drift-ghc
.if !defined(WITH_NHC98)
CONFIGURE_ARGS+= --with-hc=ghc
@@ -38,4 +44,4 @@ pre-everything::
@${ECHO} ""
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/hs-drift/files/patch-src::GenUtil.hs b/devel/hs-drift/files/patch-src::GenUtil.hs
new file mode 100644
index 000000000000..2782535f8450
--- /dev/null
+++ b/devel/hs-drift/files/patch-src::GenUtil.hs
@@ -0,0 +1,11 @@
+--- src/GenUtil.hs.orig Thu Dec 2 09:16:02 2004
++++ src/GenUtil.hs Thu Dec 2 09:16:33 2004
+@@ -85,7 +85,7 @@
+ import Monad
+ import qualified IO
+ import qualified System
+-import Random(StdGen, newStdGen, randomR)
++import Random(StdGen, newStdGen, Random(randomR))
+ import Time
+
+ {-# SPECIALIZE snub :: [String] -> [String] #-}
diff --git a/devel/hs-drift/pkg-plist b/devel/hs-drift/pkg-plist
deleted file mode 100644
index ab074d12510d..000000000000
--- a/devel/hs-drift/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/DrIFT
-bin/drift-ghc