aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-ghc-paths-docs
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-09-02 15:38:45 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-09-02 15:38:45 +0000
commit7d5781e5ab3aa2c4d9f46985acec697caae1c173 (patch)
treefb0e55efa60858746649977ee5813f549bfbad04 /devel/hs-ghc-paths-docs
parent9acc5ac910695e85c7d24401bfecd5d6e6da0d7f (diff)
downloadports-7d5781e5ab3aa2c4d9f46985acec697caae1c173.tar.gz
ports-7d5781e5ab3aa2c4d9f46985acec697caae1c173.zip
Notes
Diffstat (limited to 'devel/hs-ghc-paths-docs')
-rw-r--r--devel/hs-ghc-paths-docs/Makefile46
-rw-r--r--devel/hs-ghc-paths-docs/distinfo3
-rw-r--r--devel/hs-ghc-paths-docs/pkg-descr2
-rw-r--r--devel/hs-ghc-paths-docs/pkg-plist18
4 files changed, 69 insertions, 0 deletions
diff --git a/devel/hs-ghc-paths-docs/Makefile b/devel/hs-ghc-paths-docs/Makefile
new file mode 100644
index 000000000000..42fefe1d2cc6
--- /dev/null
+++ b/devel/hs-ghc-paths-docs/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: hs-ghc-paths-docs
+# Date created: July 09 2009
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= ghc-paths
+PORTVERSION= 0.1.0.5
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+PKGNAMESUFFIX= -doc
+
+MAINTAINER= jacula@gmail.com
+COMMENT= Documentation for ghc-paths
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ HsColour:${PORTSDIR}/print/hs-hscolour
+RUN_DEPENDS= hs-ghc-paths=${PORTVERSION}:${PORTSDIR}/devel/hs-ghc-paths
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+
+HSCOLOUR_VERSION= 1.13
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+CABAL_CMD= runghc Setup.hs
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL_CMD} configure --ghc --haddock-options=-w --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ${CABAL_CMD} haddock --executables --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
+
+do-install:
+ ${MKDIR} ${DOCSDIR}/html
+ cd ${WRKSRC}/dist/doc/html/ghc-paths && ${COPYTREE_SHARE} \* ${DOCSDIR}/html
+
+.include <bsd.port.mk>
diff --git a/devel/hs-ghc-paths-docs/distinfo b/devel/hs-ghc-paths-docs/distinfo
new file mode 100644
index 000000000000..97b714ae50b3
--- /dev/null
+++ b/devel/hs-ghc-paths-docs/distinfo
@@ -0,0 +1,3 @@
+MD5 (ghc-paths-0.1.0.5.tar.gz) = 8fdc122e65845d2d53734f78e22c5155
+SHA256 (ghc-paths-0.1.0.5.tar.gz) = ea9e97425894e3dbd7915e00e107e2e7fc07b6e8293fd2dd66a813f0673cba10
+SIZE (ghc-paths-0.1.0.5.tar.gz) = 2304
diff --git a/devel/hs-ghc-paths-docs/pkg-descr b/devel/hs-ghc-paths-docs/pkg-descr
new file mode 100644
index 000000000000..5c414bbc3ccf
--- /dev/null
+++ b/devel/hs-ghc-paths-docs/pkg-descr
@@ -0,0 +1,2 @@
+Hyperlinked documentation for the Ghc-Paths libraries.
+This documentaion is generated by HsColour and haddock.
diff --git a/devel/hs-ghc-paths-docs/pkg-plist b/devel/hs-ghc-paths-docs/pkg-plist
new file mode 100644
index 000000000000..82043f7091bd
--- /dev/null
+++ b/devel/hs-ghc-paths-docs/pkg-plist
@@ -0,0 +1,18 @@
+@comment $FreeBSD$
+%%DOCSDIR%%/html/GHC-Paths.html
+%%DOCSDIR%%/html/doc-index.html
+%%DOCSDIR%%/html/frames.html
+%%DOCSDIR%%/html/ghc-paths.haddock
+%%DOCSDIR%%/html/haddock-util.js
+%%DOCSDIR%%/html/haddock.css
+%%DOCSDIR%%/html/haskell_icon.gif
+%%DOCSDIR%%/html/index-frames.html
+%%DOCSDIR%%/html/index.html
+%%DOCSDIR%%/html/mini_GHC-Paths.html
+%%DOCSDIR%%/html/minus.gif
+%%DOCSDIR%%/html/plus.gif
+%%DOCSDIR%%/html/src/GHC-Paths.html
+%%DOCSDIR%%/html/src/hscolour.css
+@dirrm %%DOCSDIR%%/html/src
+@dirrm %%DOCSDIR%%/html
+@dirrmtry %%DOCSDIR%%