aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-git-annex
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
committerGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
commit109269205e521bb1d2d87678a391e5adefff88d6 (patch)
tree93f1f9278a9a48902904b7ff4a5ce711c10efe08 /devel/hs-git-annex
parentad7295cafd0e46ece6fcbf594ef39a767c296d0e (diff)
Notes
Diffstat (limited to 'devel/hs-git-annex')
-rw-r--r--devel/hs-git-annex/Makefile30
-rw-r--r--devel/hs-git-annex/distinfo4
-rw-r--r--devel/hs-git-annex/files/patch-Build__Configure.hs11
-rw-r--r--devel/hs-git-annex/files/patch-Build__InstallDesktopFile.hs20
-rw-r--r--devel/hs-git-annex/files/patch-git-annex.cabal11
5 files changed, 19 insertions, 57 deletions
diff --git a/devel/hs-git-annex/Makefile b/devel/hs-git-annex/Makefile
index 942cfa6572f6..678804215f3e 100644
--- a/devel/hs-git-annex/Makefile
+++ b/devel/hs-git-annex/Makefile
@@ -2,22 +2,18 @@
# $FreeBSD$
PORTNAME= git-annex
-PORTVERSION= 4.20130323
-PORTREVISION= 1
+PORTVERSION= 4.20130601
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Manage files with git, without checking their contents into git
LICENSE= GPLv3
-FILE_LICENSE= COPYRIGHT
-CABAL_SETUP= Setup.hs
-
-USE_CABAL= bloomfilter dataenc edit-distance hslogger HTTP IfElse json \
- lifted-base MissingH monad-control mtl network pcre-light \
- QuickCheck>=2.1 regex-tdfa SafeSemaphore SHA text \
- transformers-base utf8-string uuid
+USE_CABAL= bloomfilter dataenc dlist edit-distance extensible-exceptions \
+ hslogger HTTP IfElse json MissingH MonadCatchIO-transformers \
+ monad-control mtl>=2 network>=2.0 QuickCheck>=2.1 random \
+ SafeSemaphore SHA text unix-compat utf8-string uuid
USE_GMAKE= yes
USE_PERL5_BUILD= yes
@@ -33,15 +29,16 @@ RUN_DEPENDS+= rsync:${PORTSDIR}/net/rsync \
EXECUTABLE= git-annex git-annex-shell
STANDALONE= yes
-OPTIONS_DEFINE= S3 ASSISTANT INOTIFY WEBAPP PAIRING PRODUCTION
+OPTIONS_DEFINE= S3 ASSISTANT INOTIFY WEBAPP PAIRING PRODUCTION TDFA
OPTIONS_DEFAULT= S3 ASSISTANT
S3_DESC= S3 support
ASSISTANT_DESC= 'assistant' and 'watch' commands
INOTIFY_DESC= File system notifications support
-WEBAPP_DESC= Web application (req. assistant)
-PAIRING_DESC= Enable pairing (req. web application)
+WEBAPP_DESC= Web application (requires assistant)
+PAIRING_DESC= Enable pairing (requires web application)
PRODUCTION_DESC= Production build
+TDFA_DESC= Use regex-tdfa for wildcards
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
@@ -84,7 +81,7 @@ CONFIGURE_ARGS+= --flags="-Pairing"
.endif
# Disable all the other options
-CONFIGURE_ARGS+= --flags="-DNS -XMPP -Dbus"
+CONFIGURE_ARGS+= --flags="-DNS -XMPP -Dbus -WebDAV"
.if ${PORT_OPTIONS:MPRODUCTION}
CONFIGURE_ARGS+= --flags="Production"
@@ -92,5 +89,12 @@ CONFIGURE_ARGS+= --flags="Production"
CONFIGURE_ARGS+= --flags="-Production"
.endif
+.if ${PORT_OPTIONS:MTDFA}
+CONFIGURE_ARGS+= --flags="TDFA"
+USE_CABAL+= regex-tdfa
+.else
+CONFIGURE_ARGS+= --flags="-TDFA"
+.endif
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/devel/hs-git-annex/distinfo b/devel/hs-git-annex/distinfo
index ca821cf3cac6..7e93e176970a 100644
--- a/devel/hs-git-annex/distinfo
+++ b/devel/hs-git-annex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/git-annex-4.20130323.tar.gz) = 1f940d88b8ef91e18155a778b3665c7151f61567945259d41921e389beab779f
-SIZE (cabal/git-annex-4.20130323.tar.gz) = 2578033
+SHA256 (cabal/git-annex-4.20130601.tar.gz) = 96228918c356bc3e23693fd0c48e2557c68d97c769a7e76082851b91535cd250
+SIZE (cabal/git-annex-4.20130601.tar.gz) = 3332000
diff --git a/devel/hs-git-annex/files/patch-Build__Configure.hs b/devel/hs-git-annex/files/patch-Build__Configure.hs
deleted file mode 100644
index 159d7da5eb3e..000000000000
--- a/devel/hs-git-annex/files/patch-Build__Configure.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Build/Configure.hs.orig 2013-03-23 20:06:19.000000000 +0200
-+++ ./Build/Configure.hs 2013-05-09 22:49:33.000000000 +0200
-@@ -55,7 +55,7 @@
- key = "sha" ++ show n
- check = "</dev/null 2>/dev/null | grep -q '" ++ knowngood ++ "'"
- shacmds n = concatMap (\x -> [x, 'g':x, osxpath </> x]) $
-- map (\x -> "sha" ++ show n ++ x) ["sum", ""]
-+ map (\x -> "gsha" ++ show n ++ x) ["sum", ""]
- {- Max OSX sometimes puts GNU tools outside PATH, so look in
- - the location it uses, and remember where to run them
- - from. -}
diff --git a/devel/hs-git-annex/files/patch-Build__InstallDesktopFile.hs b/devel/hs-git-annex/files/patch-Build__InstallDesktopFile.hs
deleted file mode 100644
index de4e212d205a..000000000000
--- a/devel/hs-git-annex/files/patch-Build__InstallDesktopFile.hs
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./Build/InstallDesktopFile.hs.orig 2012-10-17 03:24:57.000000000 +0200
-+++ ./Build/InstallDesktopFile.hs 2012-11-06 11:26:23.567300019 +0100
-@@ -59,11 +59,15 @@
-
- writeFDODesktop :: FilePath -> IO ()
- writeFDODesktop command = do
-- datadir <- ifM systemwideInstall ( return systemDataDir, userDataDir )
-+ prefix <- catchMaybeIO (getEnv "PREFIX")
-+ let (sddir,scdir) = case prefix of
-+ Just p -> (p </> "share", p </> "etc/xdg")
-+ Nothing -> (systemDataDir, systemConfigDir)
-+ datadir <- ifM systemwideInstall ( return sddir, userDataDir )
- writeDesktopMenuFile (desktop command)
- =<< inDestDir (desktopMenuFilePath "git-annex" datadir)
-
-- configdir <- ifM systemwideInstall ( return systemConfigDir, userConfigDir )
-+ configdir <- ifM systemwideInstall ( return scdir, userConfigDir )
- installAutoStart command
- =<< inDestDir (autoStartPath "git-annex" configdir)
-
diff --git a/devel/hs-git-annex/files/patch-git-annex.cabal b/devel/hs-git-annex/files/patch-git-annex.cabal
deleted file mode 100644
index f19e74277f85..000000000000
--- a/devel/hs-git-annex/files/patch-git-annex.cabal
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./git-annex.cabal.orig 2013-03-14 22:09:41.000000000 +0100
-+++ ./git-annex.cabal 2013-03-22 03:43:51.000000000 +0100
-@@ -112,7 +112,7 @@
- if (! os(windows) && ! os(solaris) && ! os(linux))
- CPP-Options: -DWITH_KQUEUE
- C-Sources: Utility/libkqueue.c
-- Includes: sys/event.h
-+ Includes: sys/types.h sys/event.h
-
- if os(linux) && flag(Dbus)
- Build-Depends: dbus (>= 0.10.3)