aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-git-annex
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-01-09 21:32:12 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-01-09 21:32:12 +0000
commit1a75cb1d44d0e805336b016a92a4b2d8d564fdda (patch)
tree604f06bea271b71fb7be1993c1c2ba323b4506e1 /devel/hs-git-annex
parentf27ca4d0f1e1df6ff92a7455ddea39730ec30f60 (diff)
Notes
Diffstat (limited to 'devel/hs-git-annex')
-rw-r--r--devel/hs-git-annex/Makefile6
-rw-r--r--devel/hs-git-annex/files/patch-Setup.hs35
2 files changed, 38 insertions, 3 deletions
diff --git a/devel/hs-git-annex/Makefile b/devel/hs-git-annex/Makefile
index 810593edf12c..3a2a27eb2117 100644
--- a/devel/hs-git-annex/Makefile
+++ b/devel/hs-git-annex/Makefile
@@ -16,10 +16,11 @@ USE_CABAL= bloomfilter dataenc dlist edit-distance extensible-exceptions \
monad-control mtl>=2 network>=2.0 QuickCheck>=2.1 random \
SafeSemaphore SHA text unix-compat utf8-string uuid
-USE_GMAKE= yes
-USES= perl5
+USES= gmake perl5
USE_PERL5= build
+MAN1= git-annex.1 git-annex-shell.1
+
BUILD_DEPENDS+= rsync:${PORTSDIR}/net/rsync \
git:${PORTSDIR}/devel/git \
gsha256sum:${PORTSDIR}/sysutils/coreutils
@@ -42,7 +43,6 @@ PAIRING_DESC= Enable pairing (requires web application)
PRODUCTION_DESC= Production build
TDFA_DESC= Use regex-tdfa for wildcards
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.if ${PORT_OPTIONS:MS3}
diff --git a/devel/hs-git-annex/files/patch-Setup.hs b/devel/hs-git-annex/files/patch-Setup.hs
new file mode 100644
index 000000000000..7f82bdb2d34a
--- /dev/null
+++ b/devel/hs-git-annex/files/patch-Setup.hs
@@ -0,0 +1,35 @@
+--- Setup.hs.orig 2013-08-27 21:23:35.000000000 +0100
++++ Setup.hs 2013-12-08 17:28:34.656382191 +0000
+@@ -19,6 +19,7 @@
+ main = defaultMainWithHooks simpleUserHooks
+ { preConf = configure
+ , postInst = myPostInst
++ , postCopy = myPostCopy
+ }
+
+ configure _ _ = do
+@@ -34,6 +35,15 @@
+ dest = NoCopyDest
+ verbosity = fromFlag installVerbosity
+
++myPostCopy :: Args -> CopyFlags -> PackageDescription -> LocalBuildInfo -> IO ()
++myPostCopy _ (CopyFlags { copyVerbosity, copyDest }) pkg lbi = do
++ installGitAnnexShell dest verbosity pkg lbi
++ installManpages dest verbosity pkg lbi
++ installDesktopFile dest verbosity pkg lbi
++ where
++ dest = fromFlag copyDest
++ verbosity = fromFlag copyVerbosity
++
+ installGitAnnexShell :: CopyDest -> Verbosity -> PackageDescription -> LocalBuildInfo -> IO ()
+ installGitAnnexShell copyDest verbosity pkg lbi =
+ rawSystemExit verbosity "ln"
+@@ -50,7 +60,7 @@
+ installManpages copyDest verbosity pkg lbi =
+ installOrdinaryFiles verbosity dstManDir =<< srcManpages
+ where
+- dstManDir = mandir (absoluteInstallDirs pkg lbi copyDest) </> "man1"
++ dstManDir = prefix (absoluteInstallDirs pkg lbi copyDest) </> "man" </> "man1"
+ srcManpages = zip (repeat srcManDir)
+ <$> filterM doesFileExist manpages
+ srcManDir = ""