aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-git-annex
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-12-20 02:23:04 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-12-20 02:23:04 +0000
commitf6f83c9efc2c46d2970746758e2c682bb8a518ec (patch)
tree290f2ea61305744bf0f477895c56b92acaeb361f /devel/hs-git-annex
parentaf071cfdc1f8578bd1523b823e683074a3139a34 (diff)
Notes
Diffstat (limited to 'devel/hs-git-annex')
-rw-r--r--devel/hs-git-annex/Makefile51
-rw-r--r--devel/hs-git-annex/distinfo4
-rw-r--r--devel/hs-git-annex/files/patch-Build__InstallDesktopFile.hs20
-rw-r--r--devel/hs-git-annex/files/patch-Makefile11
-rw-r--r--devel/hs-git-annex/pkg-descr2
-rw-r--r--devel/hs-git-annex/pkg-plist6
6 files changed, 68 insertions, 26 deletions
diff --git a/devel/hs-git-annex/Makefile b/devel/hs-git-annex/Makefile
index e13ac9eba878..5f53970f9dd8 100644
--- a/devel/hs-git-annex/Makefile
+++ b/devel/hs-git-annex/Makefile
@@ -1,25 +1,22 @@
-# New ports collection makefile for: git-annex
-# Date created: 8 June 2011
-# Whom: frase@frase.id.au
-#
+# Created by: frase@frase.id.au
# $FreeBSD$
-#
PORTNAME= git-annex
-PORTVERSION= 3.20120807
+PORTVERSION= 3.20121211
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Manage files with git, without checking their contents into git
LICENSE= GPLv3
-FILE_LICENSE= GPL
+FILE_LICENSE= COPYRIGHT
CABAL_SETUP= Setup.hs
-USE_CABAL= bloomfilter dataenc edit-distance hslogger HTTP IfElse json \
- lifted-base MissingH monad-control mtl network pcre-light \
- QuickCheck>=2.1 SHA text transformers-base utf8-string
+USE_CABAL= async bloomfilter dataenc edit-distance hslogger HTTP IfElse \
+ json lifted-base MissingH monad-control mtl network pcre-light \
+ QuickCheck>=2.1 SafeSemaphore SHA text transformers-base \
+ utf8-string
USE_GMAKE= yes
USE_PERL5_BUILD= yes
@@ -33,13 +30,16 @@ RUN_DEPENDS+= rsync:${PORTSDIR}/net/rsync \
EXECUTABLE= git-annex git-annex-shell
STANDALONE= yes
-OPTIONS_DEFINE= S3 ASSISTANT
+OPTIONS_DEFINE= S3 ASSISTANT INOTIFY WEBAPP PAIRING
OPTIONS_DEFAULT= S3 ASSISTANT
S3_DESC= S3 support
ASSISTANT_DESC= 'assistant' and 'watch' commands
+INOTIFY_DESC= File system notifications support
+WEBAPP_DESC= Web application (req. assistant)
+PAIRING_DESC= Enable pairing (req. web application)
-.include <bsd.port.options.mk>
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.if ${PORT_OPTIONS:MS3}
CONFIGURE_ARGS+= --flags="S3"
@@ -55,5 +55,32 @@ USE_CABAL+= stm>=2.3
CONFIGURE_ARGS+= --flags="-Assistant"
.endif
+.if ${PORT_OPTIONS:MINOTIFY}
+CONFIGURE_ARGS+= --flags="Inotify"
+USE_CABAL+= kqueue
+.else
+CONFIGURE_ARGS+= --flags="-Inotify"
+.endif
+
+.if ${PORT_OPTIONS:MWEBAPP} && ${PORT_OPTIONS:MASSISTANT}
+CONFIGURE_ARGS+= --flags="Webapp"
+USE_CABAL+= yesod yesod-static case-insensitive http-types \
+ transformers wai wai-logger warp blaze-builder \
+ blaze-html crypto-api hamlet clientsession \
+ yesod-default>=1.1.0 data-default
+.else
+CONFIGURE_ARGS+= --flags="-Webapp"
+.endif
+
+.if ${PORT_OPTIONS:MWEBAPP} && ${PORT_OPTIONS:MPAIRING}
+CONFIGURE_ARGS+= --flags="Pairing"
+USE_CABAL+= network-multicast network-info
+.else
+CONFIGURE_ARGS+= --flags="-Pairing"
+.endif
+
+# Disable all the other options
+CONFIGURE_ARGS+= --flags="-DNS -XMPP -Dbus"
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/devel/hs-git-annex/distinfo b/devel/hs-git-annex/distinfo
index 4de2446bd2cb..78258a0755df 100644
--- a/devel/hs-git-annex/distinfo
+++ b/devel/hs-git-annex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/git-annex-3.20120807.tar.gz) = 89c2a504c5570e2162809a81ee470f41709fb6b7a32c3f18f59f2fd8e5a149fb
-SIZE (cabal/git-annex-3.20120807.tar.gz) = 1183955
+SHA256 (cabal/git-annex-3.20121211.tar.gz) = 3b6d9d7d8d44c7939813a4798a78b76a02efef655030d742149eda3779daa13e
+SIZE (cabal/git-annex-3.20121211.tar.gz) = 2068316
diff --git a/devel/hs-git-annex/files/patch-Build__InstallDesktopFile.hs b/devel/hs-git-annex/files/patch-Build__InstallDesktopFile.hs
new file mode 100644
index 000000000000..de4e212d205a
--- /dev/null
+++ b/devel/hs-git-annex/files/patch-Build__InstallDesktopFile.hs
@@ -0,0 +1,20 @@
+--- ./Build/InstallDesktopFile.hs.orig 2012-10-17 03:24:57.000000000 +0200
++++ ./Build/InstallDesktopFile.hs 2012-11-06 11:26:23.567300019 +0100
+@@ -59,11 +59,15 @@
+
+ writeFDODesktop :: FilePath -> IO ()
+ writeFDODesktop command = do
+- datadir <- ifM systemwideInstall ( return systemDataDir, userDataDir )
++ prefix <- catchMaybeIO (getEnv "PREFIX")
++ let (sddir,scdir) = case prefix of
++ Just p -> (p </> "share", p </> "etc/xdg")
++ Nothing -> (systemDataDir, systemConfigDir)
++ datadir <- ifM systemwideInstall ( return sddir, userDataDir )
+ writeDesktopMenuFile (desktop command)
+ =<< inDestDir (desktopMenuFilePath "git-annex" datadir)
+
+- configdir <- ifM systemwideInstall ( return systemConfigDir, userConfigDir )
++ configdir <- ifM systemwideInstall ( return scdir, userConfigDir )
+ installAutoStart command
+ =<< inDestDir (autoStartPath "git-annex" configdir)
+
diff --git a/devel/hs-git-annex/files/patch-Makefile b/devel/hs-git-annex/files/patch-Makefile
deleted file mode 100644
index ef1edc58c8da..000000000000
--- a/devel/hs-git-annex/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Makefile.orig 2011-11-22 20:21:04.000000000 +0100
-+++ ./Makefile 2011-12-03 14:33:37.000000000 +0100
-@@ -90,6 +90,8 @@
- IKIWIKI=ikiwiki
- endif
-
-+manuals: $(mans)
-+
- docs: $(mans)
- $(IKIWIKI) doc html -v --wikiname git-annex --plugin=goodstuff \
- --no-usedirs --disable-plugin=openid --plugin=sidebar \
diff --git a/devel/hs-git-annex/pkg-descr b/devel/hs-git-annex/pkg-descr
index 71347a4b5354..177cad81ff08 100644
--- a/devel/hs-git-annex/pkg-descr
+++ b/devel/hs-git-annex/pkg-descr
@@ -9,4 +9,4 @@ same git repository with regularly versioned files, which is convenient
for maintaining documents, Makefiles, etc that are associated with annexed
files but that benefit from full revision control.
-WWW: http://git-annex.branchable.com/
+WWW: http://git-annex.branchable.com/
diff --git a/devel/hs-git-annex/pkg-plist b/devel/hs-git-annex/pkg-plist
new file mode 100644
index 000000000000..2a403c147879
--- /dev/null
+++ b/devel/hs-git-annex/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+etc/xdg/autostart/git-annex.desktop
+share/applications/git-annex.desktop
+@dirrmtry etc/xdg/autostart
+@dirrmtry etc/xdg
+@dirrmtry share/applications