aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-gtk2hs-buildtools
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
committerGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
commit109269205e521bb1d2d87678a391e5adefff88d6 (patch)
tree93f1f9278a9a48902904b7ff4a5ce711c10efe08 /devel/hs-gtk2hs-buildtools
parentad7295cafd0e46ece6fcbf594ef39a767c296d0e (diff)
downloadports-109269205e521bb1d2d87678a391e5adefff88d6.tar.gz
ports-109269205e521bb1d2d87678a391e5adefff88d6.zip
Notes
Diffstat (limited to 'devel/hs-gtk2hs-buildtools')
-rw-r--r--devel/hs-gtk2hs-buildtools/Makefile5
-rw-r--r--devel/hs-gtk2hs-buildtools/files/patch-c2hs__c__CAST.hs22
2 files changed, 23 insertions, 4 deletions
diff --git a/devel/hs-gtk2hs-buildtools/Makefile b/devel/hs-gtk2hs-buildtools/Makefile
index 765b9092ec7b..ebdd2539b32e 100644
--- a/devel/hs-gtk2hs-buildtools/Makefile
+++ b/devel/hs-gtk2hs-buildtools/Makefile
@@ -2,16 +2,13 @@
PORTNAME= gtk2hs-buildtools
PORTVERSION= 0.12.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Tools to build the Gtk2Hs suite of User Interface Libraries
LICENSE= GPLv2
-FILE_LICENSE= COPYING
-
-CABAL_SETUP= Setup.hs
USE_CABAL= random
USE_ALEX= yes
diff --git a/devel/hs-gtk2hs-buildtools/files/patch-c2hs__c__CAST.hs b/devel/hs-gtk2hs-buildtools/files/patch-c2hs__c__CAST.hs
new file mode 100644
index 000000000000..0fd4c3e3910b
--- /dev/null
+++ b/devel/hs-gtk2hs-buildtools/files/patch-c2hs__c__CAST.hs
@@ -0,0 +1,22 @@
+--- ./c2hs/c/CAST.hs.orig 2012-11-12 00:26:43.000000000 +0100
++++ ./c2hs/c/CAST.hs 2013-05-28 11:02:33.000000000 +0200
+@@ -1125,6 +1125,9 @@
+ put_ bh (CTypedef ae) = do
+ putByte bh 4
+ put_ bh ae
++ put_ bh (CThread af) = do
++ putByte bh 5
++ put_ bh af
+ get bh = do
+ h <- getByte bh
+ case h of
+@@ -1143,6 +1146,9 @@
+ 4 -> do
+ ae <- get bh
+ return (CTypedef ae)
++ 5 -> do
++ af <- get bh
++ return (CThread af)
+
+ instance Binary CTypeQual where
+ put_ bh (CConstQual aa) = do