aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-haddock/Makefile
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-05-21 18:46:56 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-05-21 18:46:56 +0000
commit985b690b0ad4d5f04d4ff52a01cc0b8c4b9ea58f (patch)
treed238e8a79503112c76795ef963c70d4d490a5145 /devel/hs-haddock/Makefile
parentd604fa2d4be279984cf7e93349b7675e37d91248 (diff)
downloadports-985b690b0ad4d5f04d4ff52a01cc0b8c4b9ea58f.tar.gz
ports-985b690b0ad4d5f04d4ff52a01cc0b8c4b9ea58f.zip
Notes
Diffstat (limited to 'devel/hs-haddock/Makefile')
-rw-r--r--devel/hs-haddock/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/hs-haddock/Makefile b/devel/hs-haddock/Makefile
new file mode 100644
index 000000000000..9efe0ed23afc
--- /dev/null
+++ b/devel/hs-haddock/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: haddock
+# Date created: 09 May 2002
+# Whom: Oliver Braun <obraun@informatik.unibw-muenchen.de>
+#
+# $FreeBSD$
+
+PORTNAME= haddock
+PORTVERSION= 0.2
+CATEGORIES= devel
+MASTER_SITES= http://www.haskell.org/haddock/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= obraun@informatik.unibw-muenchen.de
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${LOCALBASE}/share/sgml/docbook/dsssl/modular:${PORTSDIR}/textproc/dsssl-docbook-modular \
+ ${LOCALBASE}/share/sgml/docbook/catalog:${PORTSDIR}/textproc/docbook \
+ ${LOCALBASE}/share/sgml/iso8879:${PORTSDIR}/textproc/iso8879 \
+ ${LOCALBASE}/share/sgml/docbook/3.1:${PORTSDIR}/textproc/docbook-310 \
+ jade:${PORTSDIR}/textproc/jade
+.endif
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//g}
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+post-build:
+.if !defined(NOPORTDOCS)
+ @(cd ${WRKSRC}/haddock/doc && \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} html)
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @(cd ${WRKSRC}/haddock/doc && ${CP} -R haddock ${PREFIX}/share/doc)
+.endif
+
+.include <bsd.port.mk>