aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-haddock/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2007-01-22 11:18:29 +0000
committerVolker Stolz <vs@FreeBSD.org>2007-01-22 11:18:29 +0000
commitf9a5f50eaf8117e9a6d27def563e4b4e87d29f11 (patch)
treeea0f95cdf49a980bb46150b6ce862f70ed8af0af /devel/hs-haddock/Makefile
parent281656eb8fac8672093609c02b1687793cc808c2 (diff)
Notes
Diffstat (limited to 'devel/hs-haddock/Makefile')
-rw-r--r--devel/hs-haddock/Makefile29
1 files changed, 22 insertions, 7 deletions
diff --git a/devel/hs-haddock/Makefile b/devel/hs-haddock/Makefile
index 4cd21d7c3690..536b31b9a88d 100644
--- a/devel/hs-haddock/Makefile
+++ b/devel/hs-haddock/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= haddock
-PORTVERSION= 0.7
-PORTREVISION= 1
+PORTVERSION= 0.8
CATEGORIES= devel haskell
MASTER_SITES= http://www.haskell.org/haddock/
PKGNAMEPREFIX= hs-
@@ -28,28 +27,44 @@ BUILD_DEPENDS+= ${LOCALBASE}/share/sgml/docbook/dsssl/modular:${PORTSDIR}/textpr
.endif
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//g}
+CONFIGURE_ARGS= --prefix=${PREFIX}
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf:259:env
+
PLIST_SUB+= HADDOCK_VERSION=${PORTVERSION}
+PORTDOCS= *
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-IGNORE= Needs perl >= 5.6
+IGNORE= needs perl >= 5.6
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/share/sgml/catalog||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/local/share/sgml/catalog||' ${WRKSRC}/doc/configure.ac
+
+do-configure:
+ cd ${WRKSRC} && runhaskell Setup.lhs configure --ghc ${CONFIGURE_ARGS}
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/doc && ${AUTOCONF} && ./configure ${CONFIGURE_ARGS}
+.endif
+
+do-build:
+ cd ${WRKSRC} && runhaskell Setup.lhs build
post-build:
.if !defined(NOPORTDOCS)
- @(cd ${WRKSRC}/haddock/doc && \
+ @(cd ${WRKSRC}/doc && \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} html)
.endif
+do-install:
+ cd ${WRKSRC} && runhaskell Setup.lhs install
+
post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/haddock
.if !defined(NOPORTDOCS)
- @(cd ${WRKSRC}/haddock/doc && ${CP} -R haddock ${PREFIX}/share/doc)
+ @(cd ${WRKSRC}/doc && ${CP} -R haddock ${PREFIX}/share/doc)
.endif
.include <bsd.port.post.mk>