aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-hashable
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2011-08-13 20:36:01 +0000
committerGabor Pali <pgj@FreeBSD.org>2011-08-13 20:36:01 +0000
commit3b4bf11e3a9b104861d510c9c7c77a7369bc93b2 (patch)
tree1a60c92eae2e2d16f078110a5bffc3b5cbd4f4cb /devel/hs-hashable
parent52f3ff5d86e096241e6ed1380de2d1fe9c8174b1 (diff)
downloadports-3b4bf11e3a9b104861d510c9c7c77a7369bc93b2.tar.gz
ports-3b4bf11e3a9b104861d510c9c7c77a7369bc93b2.zip
Notes
Diffstat (limited to 'devel/hs-hashable')
-rw-r--r--devel/hs-hashable/Makefile21
-rw-r--r--devel/hs-hashable/distinfo2
-rw-r--r--devel/hs-hashable/pkg-descr6
3 files changed, 29 insertions, 0 deletions
diff --git a/devel/hs-hashable/Makefile b/devel/hs-hashable/Makefile
new file mode 100644
index 000000000000..efa640baf0d7
--- /dev/null
+++ b/devel/hs-hashable/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-hashable
+# Date created: July 17, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= hashable
+PORTVERSION= 1.1.2.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A class for types that can be converted to a hash value
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= text>=0.11.0.5
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-hashable/distinfo b/devel/hs-hashable/distinfo
new file mode 100644
index 000000000000..05e9c80f9447
--- /dev/null
+++ b/devel/hs-hashable/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/hashable-1.1.2.1.tar.gz) = 9df1d1333b11967bf5b714e957c5f75688e6f73f9dfb77da556b5696b21cbdce
+SIZE (cabal/hashable-1.1.2.1.tar.gz) = 8406
diff --git a/devel/hs-hashable/pkg-descr b/devel/hs-hashable/pkg-descr
new file mode 100644
index 000000000000..7626cba88a8f
--- /dev/null
+++ b/devel/hs-hashable/pkg-descr
@@ -0,0 +1,6 @@
+This package defines a class, Hashable, for types that can be converted
+to a hash value. This class exists for the benefit of hashing-based data
+structures. The package provides instances for basic types and a way to
+combine hash values.
+
+WWW: http://github.com/tibbe/hashable