aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-haskell-platform/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-12-20 02:23:04 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-12-20 02:23:04 +0000
commitf6f83c9efc2c46d2970746758e2c682bb8a518ec (patch)
tree290f2ea61305744bf0f477895c56b92acaeb361f /devel/hs-haskell-platform/Makefile
parentaf071cfdc1f8578bd1523b823e683074a3139a34 (diff)
downloadports-f6f83c9efc2c46d2970746758e2c682bb8a518ec.tar.gz
ports-f6f83c9efc2c46d2970746758e2c682bb8a518ec.zip
Notes
Diffstat (limited to 'devel/hs-haskell-platform/Makefile')
-rw-r--r--devel/hs-haskell-platform/Makefile65
1 files changed, 32 insertions, 33 deletions
diff --git a/devel/hs-haskell-platform/Makefile b/devel/hs-haskell-platform/Makefile
index 37c23e1ec2b4..67ca1e722a84 100644
--- a/devel/hs-haskell-platform/Makefile
+++ b/devel/hs-haskell-platform/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: haskell-platform
-# Date created: April 23, 2011
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= haskell-platform
-PORTVERSION= 2012.2.0.0
-PORTREVISION= 1
+PORTVERSION= 2012.4.0.0
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
@@ -16,32 +10,37 @@ COMMENT= The Haskell Platform
LICENSE= BSD
METAPORT= yes
-USE_CABAL= cgi==3001.1.7.4_4,1 \
- fgl==5.4.2.4_2 \
- GLUT==2.1.2.1_5,1 \
- haskell-src==1.0.1.5_1 \
- html==1.0.1.2_4 \
- HTTP==4000.2.3_1 \
- HUnit==1.2.4.2_2 \
- mtl==2.1.1_1 \
- network==2.3.0.13_1 \
- OpenGL==2.2.3.1_2,1 \
- parallel==3.2.0.2_1 \
- parsec==3.1.2_1 \
- QuickCheck==2.4.2_1 \
- random==1.0.1.1_1 \
- regex-base==0.93.2_4 \
- regex-compat==0.95.1_2 \
- regex-posix==0.95.1_2 \
- stm==2.3_1 \
- syb==0.3.6.1_1 \
- text=0.11.2.0_1 \
- transformers==0.3.0.0_1 \
- xhtml==3000.2.1_1 \
- zlib==0.5.3.3_1 \
- cabal-install==0.14.0_1 \
- alex==3.0.1_1 \
- happy==1.18.9_1
+
+USE_CABAL= async==2.0.1.3 \
+ cgi==3001.1.7.4_5,1 \
+ fgl==5.4.2.4_3 \
+ GLUT==2.1.2.1_6,1 \
+ haskell-src==1.0.1.5_2 \
+ html==1.0.1.2_5 \
+ HTTP==4000.2.5 \
+ HUnit==1.2.5.1 \
+ mtl==2.1.2 \
+ network==2.3.1.0 \
+ OpenGL==2.2.3.1_3,1 \
+ parallel==3.2.0.3 \
+ parsec==3.1.3 \
+ primitive==0.5.0.1 \
+ QuickCheck==2.5.1.1 \
+ random==1.0.1.1_2 \
+ regex-base==0.93.2_5 \
+ regex-compat==0.95.1_3 \
+ regex-posix==0.95.2 \
+ split==0.2.1.1 \
+ stm==2.4 \
+ syb==0.3.7 \
+ text==0.11.2.3 \
+ transformers==0.3.0.0_2 \
+ vector==0.10.0.1 \
+ xhtml==3000.2.1_2 \
+ zlib==0.5.4.0 \
+ cabal-install==0.14.0_2 \
+ alex==3.0.2 \
+ happy==1.18.10
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>