aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-hdoc
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-06-03 20:52:29 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-06-03 20:52:29 +0000
commit46e9ab0ca5e504d3509678b4d43a41d938650e75 (patch)
treea34afe36b374e7894e236fb8cee020928d36c967 /devel/hs-hdoc
parentbe44ec14c77de91f8ac86e25372545e0e39e9bcb (diff)
downloadports-46e9ab0ca5e504d3509678b4d43a41d938650e75.tar.gz
ports-46e9ab0ca5e504d3509678b4d43a41d938650e75.zip
Notes
Diffstat (limited to 'devel/hs-hdoc')
-rw-r--r--devel/hs-hdoc/Makefile14
-rw-r--r--devel/hs-hdoc/files/patch-Main.hs11
-rw-r--r--devel/hs-hdoc/files/patch-hsparser__HsLexer.lhs11
3 files changed, 35 insertions, 1 deletions
diff --git a/devel/hs-hdoc/Makefile b/devel/hs-hdoc/Makefile
index e02f149fbb83..bea3abc5d2bf 100644
--- a/devel/hs-hdoc/Makefile
+++ b/devel/hs-hdoc/Makefile
@@ -6,7 +6,7 @@
PORTNAME= hdoc
PORTVERSION= 0.8.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= devel haskell
MASTER_SITES= http://staff.fmi.uni-passau.de/~groessli/hdoc/
PKGNAMEPREFIX= hs-
@@ -39,4 +39,16 @@ post-install:
cd ${WRKSRC}/docs && ${INSTALL_DATA} hdoc.pdf ${DOCSDIR}
.endif
+post-patch:
+ @${REINPLACE_CMD} 's|import List|import Data.List| ; \
+ s|import Char|import Data.Char| ; \
+ s|import Ratio|import Data.Ratio| ; \
+ s|import Monad|import Control.Monad| ; \
+ s|import IO|import System.IO.Error| ; \
+ s|import Directory|import System.Directory| ; \
+ s|import Maybe|import Data.Maybe| ; \
+ s|import Array|import Data.Array| ; \
+ s|import System[^\.]|import System.Exit|' \
+ `${FIND} ${WRKSRC} -name '*.*hs'`
+
.include <bsd.port.mk>
diff --git a/devel/hs-hdoc/files/patch-Main.hs b/devel/hs-hdoc/files/patch-Main.hs
new file mode 100644
index 000000000000..bbddbb29a822
--- /dev/null
+++ b/devel/hs-hdoc/files/patch-Main.hs
@@ -0,0 +1,11 @@
+--- ./Main.hs.orig 2004-05-18 00:27:27.000000000 +0200
++++ ./Main.hs 2012-05-13 11:20:13.000000000 +0200
+@@ -5,7 +5,7 @@
+ import List
+ import Maybe
+ import Monad
+-import System
++import System.Environment
+ import GetOpt
+
+ import Parser
diff --git a/devel/hs-hdoc/files/patch-hsparser__HsLexer.lhs b/devel/hs-hdoc/files/patch-hsparser__HsLexer.lhs
new file mode 100644
index 000000000000..bdcfa7540150
--- /dev/null
+++ b/devel/hs-hdoc/files/patch-hsparser__HsLexer.lhs
@@ -0,0 +1,11 @@
+--- ./hsparser/HsLexer.lhs.orig 2004-05-18 01:40:34.000000000 +0200
++++ ./hsparser/HsLexer.lhs 2012-05-13 11:20:41.000000000 +0200
+@@ -19,7 +19,7 @@
+ import HsParseUtils
+ import HsSyn(SrcLoc(..))
+
+-import Char
++import Char hiding (isSymbol)
+ import Ratio
+ import Numeric
+ \end{code}