aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-hmake
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-02-01 22:27:37 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-02-01 22:27:37 +0000
commit62772e1d1fdd42753c011d1ac7223ddccac42f72 (patch)
tree5bd1042e6d3fdb2c04cefa18f0d5f5100c46d400 /devel/hs-hmake
parentabb3cabfd611da290763adb7a531c6b0246885ce (diff)
Update to 3.09 and unbreak on 5.x
Notes
Notes: svn path=/head/; revision=127878
Diffstat (limited to 'devel/hs-hmake')
-rw-r--r--devel/hs-hmake/Makefile3
-rw-r--r--devel/hs-hmake/distinfo4
-rw-r--r--devel/hs-hmake/files/patch-src::interpreter::HInteractive.hs73
3 files changed, 76 insertions, 4 deletions
diff --git a/devel/hs-hmake/Makefile b/devel/hs-hmake/Makefile
index fc415be6404b..6fd05f1e6a22 100644
--- a/devel/hs-hmake/Makefile
+++ b/devel/hs-hmake/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= hmake
-PORTVERSION= 3.08
-PORTREVISION= 1
+PORTVERSION= 3.09
CATEGORIES= devel haskell
MASTER_SITES= http://www.haskell.org/hmake/ \
ftp://ftp.cs.york.ac.uk/pub/haskell/hmake/ \
diff --git a/devel/hs-hmake/distinfo b/devel/hs-hmake/distinfo
index bf0b35b2cff9..0beebb97786e 100644
--- a/devel/hs-hmake/distinfo
+++ b/devel/hs-hmake/distinfo
@@ -1,2 +1,2 @@
-MD5 (hmake-3.08.tar.gz) = c01c9137185a89e29bec389718696a66
-SIZE (hmake-3.08.tar.gz) = 74439
+MD5 (hmake-3.09.tar.gz) = 72ac1fbca710dd8be5926600b119b4f4
+SIZE (hmake-3.09.tar.gz) = 100103
diff --git a/devel/hs-hmake/files/patch-src::interpreter::HInteractive.hs b/devel/hs-hmake/files/patch-src::interpreter::HInteractive.hs
new file mode 100644
index 000000000000..951eb4f93ca6
--- /dev/null
+++ b/devel/hs-hmake/files/patch-src::interpreter::HInteractive.hs
@@ -0,0 +1,73 @@
+--- src/interpreter/HInteractive.hs.orig Tue Feb 1 23:15:37 2005
++++ src/interpreter/HInteractive.hs Tue Feb 1 23:22:21 2005
+@@ -347,39 +347,37 @@
+ help = "hi - help command does not work in hbc < 0.9999.5"
+
+ #else
+-banner = "\
+-\__ __ __ _____________________________________\n\
+-\|| || ______ ___ || _ ____ hmake interactive (hi):\n\
+-\||___|| || || || ___|| ||/ ||__|| Copyright (c) May 2000\n\
+-\||---|| || || || ||__|| ||\\_ ||__ http://www.cs.york.ac.uk/fp/hmake/\n\
+-\|| || Report bugs to: malcolm@cs.york.ac.uk\n\
+-\|| || Version: "++hmakeVersion++" -------------------------------------"
++banner = "__ __ __ _____________________________________\n" ++
++ "|| || ______ ___ || _ ____ hmake interactive (hi):\n" ++
++ "||___|| || || || ___|| ||/ ||__|| Copyright (c) May 2000\n" ++
++ "||---|| || || || ||__|| ||\\_ ||__ http://www.cs.york.ac.uk/fp/hmake/\n" ++
++ "|| || Report bugs to: malcolm@cs.york.ac.uk\n" ++
++ "|| || Version: "++hmakeVersion++" -------------------------------------"
+
+
+-help = "\
+-\Commands (can be abbreviated to first letter):\n\
+-\ <expr> evaluate expression\n\
+-\ :type <expr> show type of expression [nhc98 only]\n\
+-\ :quit quit\n\
+-\ :Quit quit\n\
+-\ :load mod [mod...] load modules (note, not filenames)\n\
+-\ :load clear all modules\n\
+-\ :also mod [mod...] load additional modules (note, not filenames)\n\
+-\ :reload repeat last load command\n\
+-\ :freshen remove, recompile, and reload all current modules\n\
+-\ :module mod set module scope for evaluating expressions\n\
+-\ :edit file edit filename\n\
+-\ :edit edit current module\n\
+-\ :cd dir change directory\n\
+-\ :cd show current directory\n\
+-\ :dir list current directory\n\
+-\ :hc compiler set Haskell compiler to use\n\
+-\ :hc show current compiler and other available compilers\n\
+-\ :set options set hmake/compiler options\n\
+-\ :unset options remove hmake/compiler options\n\
+-\ :observe name debug function 'name' with 'Hood' [coming soon]\n\
+-\ :trace [on|off] switch on/off debugging with 'Hat' [nhc98 only]\n\
+-\ :!command shell escape\n\
+-\ :version show hmake version\n\
+-\ :? display this list of commands"
++help = "Commands (can be abbreviated to first letter):\n" ++
++ " <expr> evaluate expression\n" ++
++ " :type <expr> show type of expression [nhc98 only]\n" ++
++ " :quit quit\n" ++
++ " :Quit quit\n" ++
++ " :load mod [mod...] load modules (note, not filenames)\n" ++
++ " :load clear all modules\n" ++
++ " :also mod [mod...] load additional modules (note, not filenames)\n" ++
++ " :reload repeat last load command\n" ++
++ " :freshen remove, recompile, and reload all current modules\n" ++
++ " :module mod set module scope for evaluating expressions\n" ++
++ " :edit file edit filename\n" ++
++ " :edit edit current module\n" ++
++ " :cd dir change directory\n" ++
++ " :cd show current directory\n" ++
++ " :dir list current directory\n" ++
++ " :hc compiler set Haskell compiler to use\n" ++
++ " :hc show current compiler and other available compilers\n" ++
++ " :set options set hmake/compiler options\n" ++
++ " :unset options remove hmake/compiler options\n" ++
++ " :observe name debug function 'name' with 'Hood' [coming soon]\n" ++
++ " :trace [on|off] switch on/off debugging with 'Hat' [nhc98 only]\n" ++
++ " :!command shell escape\n" ++
++ " :version show hmake version\n" ++
++ " :? display this list of commands"
+ #endif