aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-hmake
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-09-02 15:38:45 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-09-02 15:38:45 +0000
commit7d5781e5ab3aa2c4d9f46985acec697caae1c173 (patch)
treefb0e55efa60858746649977ee5813f549bfbad04 /devel/hs-hmake
parent9acc5ac910695e85c7d24401bfecd5d6e6da0d7f (diff)
Notes
Diffstat (limited to 'devel/hs-hmake')
-rw-r--r--devel/hs-hmake/Makefile13
-rw-r--r--devel/hs-hmake/files/patch-src_hmake_Config.hs20
-rw-r--r--devel/hs-hmake/files/patch-src_hmake_MkConfig.hs20
-rw-r--r--devel/hs-hmake/files/patch-src_hmake_PackageConfig.hs22
-rw-r--r--devel/hs-hmake/pkg-plist1
5 files changed, 71 insertions, 5 deletions
diff --git a/devel/hs-hmake/Makefile b/devel/hs-hmake/Makefile
index 3df8f10ffb65..89c1f0e9a0cc 100644
--- a/devel/hs-hmake/Makefile
+++ b/devel/hs-hmake/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hmake
PORTVERSION= 3.14
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel haskell
MASTER_SITES= http://www.haskell.org/hmake/ \
ftp://ftp.cs.york.ac.uk/pub/haskell/hmake/ \
@@ -17,11 +17,10 @@ PKGNAMEPREFIX= hs-
MAINTAINER= haskell@FreeBSD.org
COMMENT= Intelligent compilation management tool for Haskell programs
-BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-.if exists(${LOCALBASE}/lib/libreadline.so)
-LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
-.endif
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-readline>=1.0.1.0:${PORTSDIR}/devel/hs-readline
RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
HAS_CONFIGURE= YES
CONFIGURE_ARGS+= --prefix=${PREFIX}
@@ -35,6 +34,10 @@ PLIST_SUB+= ARCH=ix86
PLIST_SUB+= ARCH=amd64
.endif
+.if exists(${LOCALBASE}/lib/libreadline.so)
+LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
+.endif
+
do-install:
# cheat a bit, otherwise LIBDIR gets clobbered
(cd ${WRKSRC} && ./configure --install)
diff --git a/devel/hs-hmake/files/patch-src_hmake_Config.hs b/devel/hs-hmake/files/patch-src_hmake_Config.hs
new file mode 100644
index 000000000000..322bd0ca7bf2
--- /dev/null
+++ b/devel/hs-hmake/files/patch-src_hmake_Config.hs
@@ -0,0 +1,20 @@
+--- src/hmake/Config.hs.orig 2007-11-23 14:26:05.000000000 +0000
++++ src/hmake/Config.hs 2009-07-16 07:56:15.000000000 +0000
+@@ -272,14 +272,14 @@
+ ok <- doesFileExist ghcpkg0
+ let ghcpkg = if ok then ghcpkg0 else dirname fullpath++"/ghc-pkg"
+ -- pkgs <- runAndReadStdout (ghcpkg++" --list-packages")
+- pkgs <- runAndReadStdout (ghcpkg++" -l")
++ pkgs <- runAndReadStdout (ghcpkg++" list")
+ let pkgsOK = filter (\p-> any (`isPrefixOf` p)
+ ["std","base","haskell98"])
+ (deComma pkgs)
+ idirs <- mapM (\p-> runAndReadStdout
+- (ghcpkg++" --show-package="
++ (ghcpkg++" field "
+ ++deVersion (ghcsym>=604) p
+- ++" --field=import_dirs"))
++ ++" import_dirs"))
+ pkgsOK
+ return config{ includePaths = pkgDirs libdir (nub idirs) }
+ where
diff --git a/devel/hs-hmake/files/patch-src_hmake_MkConfig.hs b/devel/hs-hmake/files/patch-src_hmake_MkConfig.hs
new file mode 100644
index 000000000000..37e20a61b1f2
--- /dev/null
+++ b/devel/hs-hmake/files/patch-src_hmake_MkConfig.hs
@@ -0,0 +1,20 @@
+--- src/hmake/MkConfig.hs.orig 2006-07-07 16:01:16.000000000 +0000
++++ src/hmake/MkConfig.hs 2009-07-16 07:56:44.000000000 +0000
+@@ -258,14 +258,14 @@
+ ok <- doesFileExist ghcpkg0
+ let ghcpkg = if ok then ghcpkg0 else dirname fullpath++"/ghc-pkg"
+ -- pkgs <- runAndReadStdout (ghcpkg++" --list-packages")
+- pkgs <- runAndReadStdout (ghcpkg++" -l")
++ pkgs <- runAndReadStdout (ghcpkg++" list")
+ let pkgsOK = filter (\p-> any (`isPrefixOf` p)
+ ["std","base","haskell98"])
+ (deComma pkgs)
+ idirs <- mapM (\p-> runAndReadStdout
+- (ghcpkg++" --show-package="
++ (ghcpkg++" field "
+ ++deVersion (ghcsym>=604) p
+- ++" --field=import_dirs"))
++ ++" import_dirs"))
+ pkgsOK
+ return config{ includePaths = pkgDirs libdir (nub idirs) }
+ else do ioError (userError ("Can't find ghc includes at "++incdir1))
diff --git a/devel/hs-hmake/files/patch-src_hmake_PackageConfig.hs b/devel/hs-hmake/files/patch-src_hmake_PackageConfig.hs
new file mode 100644
index 000000000000..ed21f08cac62
--- /dev/null
+++ b/devel/hs-hmake/files/patch-src_hmake_PackageConfig.hs
@@ -0,0 +1,22 @@
+--- src/hmake/PackageConfig.hs.orig 2008-04-25 10:28:08.000000000 +0000
++++ src/hmake/PackageConfig.hs 2009-07-16 07:57:07.000000000 +0000
+@@ -55,7 +55,7 @@
+ -- ghcpkg <- runAndReadStdout
+ -- ("echo `" ++ ghc ++ " --print-libdir`/bin/ghc-pkg")
+ -- pkgs <- runAndReadStdout (ghcpkg++" --list-packages")
+- pkgs <- runAndReadStdout (ghcpkg++" -l")
++ pkgs <- runAndReadStdout (ghcpkg++" list")
+ let (ok,bad) = partition (\p-> elemBy versionMatch p (deComma pkgs))
+ packages
+ when (not (null bad))
+@@ -63,8 +63,8 @@
+ ++concat (intersperse ", " bad)
+ ++" not available (according to ghc-pkg)"))
+ idirs <- mapM (\p-> runAndReadStdout
+- (ghcpkg++" --show-package="++p
+- ++" --field=import_dirs"))
++ (ghcpkg++" field "++p
++ ++" import_dirs"))
+ ok
+ return (pkgDirs libdir idirs)
+ where
diff --git a/devel/hs-hmake/pkg-plist b/devel/hs-hmake/pkg-plist
index 6cbfd8ae1ca1..7e6c27a24876 100644
--- a/devel/hs-hmake/pkg-plist
+++ b/devel/hs-hmake/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
bin/harch
bin/hi
bin/hmake