aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-hoogle
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-01-03 04:53:50 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-01-03 04:53:50 +0000
commite341fa6f8c0de52b8c8a1ab10fb5d793d9c4a50b (patch)
treecfcaa533ead5b3eea8b5f92e94effa664969f973 /devel/hs-hoogle
parent859b64a2596f652eb7c578722ad082a2578ddb4b (diff)
Hoogle is a Haskell API search engine, which allows you to
search many standard Haskell libraries by either function name, or by approximate type signature. WWW: http://www.haskell.org/hoogle/ PR: ports/142145 Submitted by: Jacula Modyun <jacula(at)gmail.com>
Notes
Notes: svn path=/head/; revision=247039
Diffstat (limited to 'devel/hs-hoogle')
-rw-r--r--devel/hs-hoogle/Makefile86
-rw-r--r--devel/hs-hoogle/distinfo3
-rw-r--r--devel/hs-hoogle/pkg-descr5
-rw-r--r--devel/hs-hoogle/pkg-plist4
4 files changed, 98 insertions, 0 deletions
diff --git a/devel/hs-hoogle/Makefile b/devel/hs-hoogle/Makefile
new file mode 100644
index 000000000000..9e5510f80bc7
--- /dev/null
+++ b/devel/hs-hoogle/Makefile
@@ -0,0 +1,86 @@
+# New ports collection makefile for: hs-hoogle
+# Date created: December 20 2009
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hoogle
+PORTVERSION= 4.0.7
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= jacula@gmail.com
+COMMENT= Haskell API Search
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-safe>=0.2:${PORTSDIR}/devel/hs-safe \
+ hs-uniplate>=1.2.0.3:${PORTSDIR}/devel/hs-uniplate
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-safe>=0.2:${PORTSDIR}/devel/hs-safe \
+ hs-uniplate>=1.2.0.3:${PORTSDIR}/devel/hs-uniplate
+LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+
+GHC_VERSION= 6.10.4
+HOOGLE_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DATADIR= ${PREFIX}/share/${DISTNAME}
+PORTDATA= *
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+HOOGLE_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ HOOGLE_VERSION=${HOOGLE_VERSION} \
+ HOOGLE_LIBDIR_REL=${HOOGLE_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.15
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal
+.if !defined(NOPORTDATA)
+ cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
+.else
+ cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX} \
+ --datadir='' --datasubdir='' --docdir='${DOCSDIR}'
+.endif
+
+do-build:
+ cd ${WRKSRC} && ${SETUP_CMD} build
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --executables --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${SETUP_CMD} install
+.if !defined(NOPORTDATA)
+ ${MKDIR} ${DATADIR} && ${INSTALL_DATA} ${WRKSRC}/README.txt ${DATADIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/hs-hoogle/distinfo b/devel/hs-hoogle/distinfo
new file mode 100644
index 000000000000..0f8e04c5fcf9
--- /dev/null
+++ b/devel/hs-hoogle/distinfo
@@ -0,0 +1,3 @@
+MD5 (hoogle-4.0.7.tar.gz) = 903f96c6b25796c4e7290e0c134486d1
+SHA256 (hoogle-4.0.7.tar.gz) = 3d757c4c0897deae18cc6fa1db26e27025f452f4a4f117c55c675695c424640d
+SIZE (hoogle-4.0.7.tar.gz) = 1763525
diff --git a/devel/hs-hoogle/pkg-descr b/devel/hs-hoogle/pkg-descr
new file mode 100644
index 000000000000..4adab8bfab05
--- /dev/null
+++ b/devel/hs-hoogle/pkg-descr
@@ -0,0 +1,5 @@
+Hoogle is a Haskell API search engine, which allows you to
+search many standard Haskell libraries by either function
+name, or by approximate type signature.
+
+WWW: http://www.haskell.org/hoogle/
diff --git a/devel/hs-hoogle/pkg-plist b/devel/hs-hoogle/pkg-plist
new file mode 100644
index 000000000000..e5508266df85
--- /dev/null
+++ b/devel/hs-hoogle/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/hoogle
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%