aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-hoogle
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2011-07-10 16:30:20 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2011-07-10 16:30:20 +0000
commit72aec0acb142e791287e7f81df2783bc36b1d5c9 (patch)
tree1a1112b344e67e61eb62e2581d4e12e803b55466 /devel/hs-hoogle
parenta5b68f24f9a5537c9e9814147d61d6f50b624686 (diff)
downloadports-72aec0acb142e791287e7f81df2783bc36b1d5c9.tar.gz
ports-72aec0acb142e791287e7f81df2783bc36b1d5c9.zip
Notes
Diffstat (limited to 'devel/hs-hoogle')
-rw-r--r--devel/hs-hoogle/Makefile10
-rw-r--r--devel/hs-hoogle/distinfo4
-rw-r--r--devel/hs-hoogle/files/patch-hoogle.cabal48
-rw-r--r--devel/hs-hoogle/files/patch-src__General__Web.hs11
-rw-r--r--devel/hs-hoogle/files/patch-src__Web__Server.hs11
-rw-r--r--devel/hs-hoogle/pkg-descr5
6 files changed, 42 insertions, 47 deletions
diff --git a/devel/hs-hoogle/Makefile b/devel/hs-hoogle/Makefile
index 05ebec750f89..24c3454a9458 100644
--- a/devel/hs-hoogle/Makefile
+++ b/devel/hs-hoogle/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= hoogle
-PORTVERSION= 4.2.1
-PORTREVISION= 2
+PORTVERSION= 4.2.5
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
@@ -16,9 +15,10 @@ COMMENT= Haskell API Search
LICENSE= GPLv2
CABAL_SETUP= Setup.hs
-USE_CABAL= binary blaze-builder>=0.2 cmdargs>=0.6 enumerator>=0.4 \
- haskell-src-exts>=1.9 parsec safe tagsoup>=0.11 \
- transformers>=0.2 uniplate>=1.6 wai>=0.3 warp>=0.3
+USE_CABAL= binary blaze-builder>=0.2 case-insensitive>=0.2 cmdargs>=0.7 \
+ enumerator>=0.4 haskell-src-exts>=1.9 http-types>=0.6 \
+ parsec>=2.1 safe tagsoup>=0.11 transformers>=0.2 uniplate>=1.6 \
+ wai>=0.4 warp>=0.4
EXECUTABLE= hoogle
diff --git a/devel/hs-hoogle/distinfo b/devel/hs-hoogle/distinfo
index f539de4b20e0..35e47063ee65 100644
--- a/devel/hs-hoogle/distinfo
+++ b/devel/hs-hoogle/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/hoogle-4.2.1.tar.gz) = 7bacacc4783ee4df825eaf3ce46ffcfcf5e277fc2d0969fedd5c2093ecd7808c
-SIZE (cabal/hoogle-4.2.1.tar.gz) = 107296
+SHA256 (cabal/hoogle-4.2.5.tar.gz) = f6b01a065f486db0432784e2065bdf789dde7921258b2cfec3b382fa8b64d995
+SIZE (cabal/hoogle-4.2.5.tar.gz) = 114297
diff --git a/devel/hs-hoogle/files/patch-hoogle.cabal b/devel/hs-hoogle/files/patch-hoogle.cabal
index 902a40039146..ab4a7dc5a9f1 100644
--- a/devel/hs-hoogle/files/patch-hoogle.cabal
+++ b/devel/hs-hoogle/files/patch-hoogle.cabal
@@ -1,22 +1,40 @@
---- ./hoogle.cabal.orig 2011-01-26 12:16:52.000000000 +0100
-+++ ./hoogle.cabal 2011-03-13 06:06:29.686517189 +0100
-@@ -35,7 +35,7 @@
+--- ./hoogle.cabal.orig 2011-06-12 15:14:55.000000000 +0200
++++ ./hoogle.cabal 2011-06-25 19:26:25.000000000 +0200
+@@ -40,10 +40,10 @@
array, bytestring, containers, directory, filepath, process, random,
safe,
binary,
-- parsec == 2.1.*,
+- parsec >= 2.1,
+- transformers == 0.2.*,
+- uniplate == 1.6.*,
+- haskell-src-exts >= 1.9 && < 1.12
+ parsec,
- transformers == 0.2.*,
- uniplate == 1.6.*,
- haskell-src-exts >= 1.9 && < 1.11
-@@ -108,8 +108,8 @@
- tagsoup >= 0.11 && < 0.13,
- enumerator == 0.4.*,
- blaze-builder == 0.2.*,
-- wai == 0.3.0,
-- warp == 0.3.0,
-+ wai == 0.3.*,
-+ warp == 0.3.*,
++ transformers >= 0.2,
++ uniplate >= 1.6,
++ haskell-src-exts >= 1.9
+
+ if !os(mingw32)
+ build-depends: unix
+@@ -107,14 +107,14 @@
+
+ build-depends:
+ time, old-time, old-locale,
+- cmdargs == 0.7.*,
+- tagsoup >= 0.11 && < 0.13,
+- enumerator == 0.4.*,
+- blaze-builder >= 0.2 && < 0.4,
+- http-types == 0.6.*,
+- case-insensitive == 0.2.*,
+- wai == 0.4.*,
+- warp == 0.4.*,
++ cmdargs >= 0.7,
++ tagsoup >= 0.11,
++ enumerator >= 0.4,
++ blaze-builder >= 0.2,
++ http-types >= 0.6,
++ case-insensitive >= 0.2,
++ wai >= 0.4,
++ warp >= 0.4,
Cabal >= 1.8 && < 1.11
other-modules:
diff --git a/devel/hs-hoogle/files/patch-src__General__Web.hs b/devel/hs-hoogle/files/patch-src__General__Web.hs
deleted file mode 100644
index b4a2697497f9..000000000000
--- a/devel/hs-hoogle/files/patch-src__General__Web.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/General/Web.hs.orig 2011-01-26 12:16:52.000000000 +0100
-+++ ./src/General/Web.hs 2011-03-13 06:06:29.688516885 +0100
-@@ -15,7 +15,7 @@
-
- import General.System
- import General.Base
--import Network.Wai
-+import Network.Wai hiding(statusOK)
- import Blaze.ByteString.Builder(toLazyByteString)
- import Data.Enumerator.List(consume)
- import qualified Data.ByteString.Lazy.Char8 as LBS
diff --git a/devel/hs-hoogle/files/patch-src__Web__Server.hs b/devel/hs-hoogle/files/patch-src__Web__Server.hs
deleted file mode 100644
index 22ce4419a216..000000000000
--- a/devel/hs-hoogle/files/patch-src__Web__Server.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/Web/Server.hs.orig 2011-01-26 12:16:52.000000000 +0100
-+++ ./src/Web/Server.hs 2011-03-13 06:06:43.636623976 +0100
-@@ -10,7 +10,7 @@
- import General.System
- import Control.Concurrent
-
--import Network.Wai
-+import Network.Wai hiding(statusOK)
- import Network.Wai.Handler.Warp
- import qualified Data.ByteString.Lazy.Char8 as LBS
- import qualified Data.ByteString.Char8 as BS
diff --git a/devel/hs-hoogle/pkg-descr b/devel/hs-hoogle/pkg-descr
index 4adab8bfab05..580f3a626271 100644
--- a/devel/hs-hoogle/pkg-descr
+++ b/devel/hs-hoogle/pkg-descr
@@ -1,5 +1,4 @@
-Hoogle is a Haskell API search engine, which allows you to
-search many standard Haskell libraries by either function
-name, or by approximate type signature.
+Hoogle is a Haskell API search engine, which allows you to search many standard
+Haskell libraries by either function name, or by approximate type signature.
WWW: http://www.haskell.org/hoogle/