aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-lazysmallcheck/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-03-14 15:19:34 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-03-14 15:19:34 +0000
commit33d8bc0ad7796a724cdbd92d932787952fda5703 (patch)
tree5cb182a01a2253a0fe7d84c725066e634dcc7503 /devel/hs-lazysmallcheck/Makefile
parentc32f91aef2c65b505f8b9b86351dadc0d7e24fea (diff)
Notes
Diffstat (limited to 'devel/hs-lazysmallcheck/Makefile')
-rw-r--r--devel/hs-lazysmallcheck/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/devel/hs-lazysmallcheck/Makefile b/devel/hs-lazysmallcheck/Makefile
new file mode 100644
index 000000000000..aa62399d16a6
--- /dev/null
+++ b/devel/hs-lazysmallcheck/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: hs-lazysmallcheck-ghc
+# Date created: March 11, 2009
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lazysmallcheck
+PORTVERSION= 0.3
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+PKGNAMESUFFIX= -ghc
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A library for demand-driven testing of Haskell programs
+
+BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+
+GHC_VERSION= 6.8.3
+CABALCMD= ${LOCALBASE}/bin/runghc Setup.hs
+CABALDIR= lib/ghc-${GHC_VERSION}/cabal
+
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${CABALDIR}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= LICENSE html
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${PREFIX}/${CABALDIR} --libsubdir='' --datasubdir=''
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+PLIST_SUB+= RMLIC="@comment "
+.else
+PLIST_SUB+= RMLIC=""
+.endif
+
+do-configure:
+ cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+
+do-build:
+ cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${CABALCMD} haddock
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${CABALCMD} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${CABALDIR}/${PORTNAME}-register.sh
+
+.include <bsd.port.mk>