aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-vault
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-06-03 19:15:34 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-06-03 19:15:34 +0000
commitaa7f8f5971924c5ce40171ba59637a0922d8f563 (patch)
tree6be43396dc42d11787bdfef9e360a2e840bdee22 /devel/hs-vault
parent635a68e21b3b9b014c75192b7d05916798c83f95 (diff)
Notes
Diffstat (limited to 'devel/hs-vault')
-rw-r--r--devel/hs-vault/Makefile22
-rw-r--r--devel/hs-vault/distinfo2
-rw-r--r--devel/hs-vault/pkg-descr7
3 files changed, 31 insertions, 0 deletions
diff --git a/devel/hs-vault/Makefile b/devel/hs-vault/Makefile
new file mode 100644
index 000000000000..0c2475f2c78e
--- /dev/null
+++ b/devel/hs-vault/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-vault
+# Date created: April 7, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= vault
+PORTVERSION= 0.2.0.0
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A persistent store for values of arbitrary types
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= hashable unordered-containers>=0.2.1.0
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-vault/distinfo b/devel/hs-vault/distinfo
new file mode 100644
index 000000000000..8697d83731c8
--- /dev/null
+++ b/devel/hs-vault/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/vault-0.2.0.0.tar.gz) = 5b0797d80cb229ae470ffa43a66f0f13e29d916b5fc28a9c4b8e2f11f73c68c3
+SIZE (cabal/vault-0.2.0.0.tar.gz) = 4761
diff --git a/devel/hs-vault/pkg-descr b/devel/hs-vault/pkg-descr
new file mode 100644
index 000000000000..0deb88790668
--- /dev/null
+++ b/devel/hs-vault/pkg-descr
@@ -0,0 +1,7 @@
+A "vault" is a typed, persistent store for values of arbitrary types. It's
+like having first-class access to the storage space behind IORefs. The
+data structure is analogous to a bank vault, where you can access different
+bank boxes with different keys; hence the name. Also provided is a "locker"
+type, representing a store for a single element.
+
+WWW: https://github.com/HeinrichApfelmus/vault