aboutsummaryrefslogtreecommitdiff
path: root/devel/htable
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-28 08:37:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-28 08:37:45 +0000
commite478a2e7bf1c1a765b0d07ad09915fbe15c8b5e1 (patch)
treea073ba7d929deca4ab0f3fe3066398dccf7fc6dc /devel/htable
parent50a0b78f3241e955437faac4b9e352f757a6139c (diff)
Notes
Diffstat (limited to 'devel/htable')
-rw-r--r--devel/htable/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/devel/htable/Makefile b/devel/htable/Makefile
index 122876a4daff..e0ddb4fb1bac 100644
--- a/devel/htable/Makefile
+++ b/devel/htable/Makefile
@@ -10,18 +10,17 @@ MASTER_SITE_SUBDIR= culot
MAINTAINER= culot@FreeBSD.org
COMMENT= Lightweight implementation of hash tables in C
-USE_GMAKE= yes
+USES= gmake
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAN3= htable.3
-PLIST_FILES= include/htable.h
+PLIST_FILES= include/htable.h \
+ man/man3/htable.3.gz
NO_BUILD= yes
-NO_STAGE= yes
do-install:
- ${INSTALL_DATA} ${WRKSRC}/src/htable.h ${PREFIX}/include
- ${INSTALL_MAN} ${WRKSRC}/src/htable.3 ${MAN3PREFIX}/man/man3
+ ${INSTALL_DATA} ${WRKSRC}/src/htable.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_MAN} ${WRKSRC}/src/htable.3 ${STAGEDIR}${MAN3PREFIX}/man/man3
regression-test:
cd ${WRKSRC}/tst && ${GMAKE} test