aboutsummaryrefslogtreecommitdiff
path: root/devel/hub
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-10-21 13:47:50 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-10-21 13:47:50 +0000
commit5206edb2e2a47b31ee66177daef9799bed21d2c1 (patch)
tree4d9af18c03b1746538787a749a35c74b7ccbf8c2 /devel/hub
parent58aeae4e93679c57c31c5bbf5518939ccafd7320 (diff)
downloadports-5206edb2e2a47b31ee66177daef9799bed21d2c1.tar.gz
ports-5206edb2e2a47b31ee66177daef9799bed21d2c1.zip
Notes
Diffstat (limited to 'devel/hub')
-rw-r--r--devel/hub/Makefile39
-rw-r--r--devel/hub/distinfo2
-rw-r--r--devel/hub/pkg-descr4
3 files changed, 45 insertions, 0 deletions
diff --git a/devel/hub/Makefile b/devel/hub/Makefile
new file mode 100644
index 000000000000..320938f05d6e
--- /dev/null
+++ b/devel/hub/Makefile
@@ -0,0 +1,39 @@
+# Created by: Simon Olofsson <simon@olofsson.de>
+# $FreeBSD$
+
+PORTNAME= hub
+PORTVERSION= 1.10.2
+CATEGORIES= devel
+
+MAINTAINER= simon@olofsson.de
+COMMENT= Introduces git to GitHub
+
+USE_GITHUB= yes
+GH_ACCOUNT= defunkt
+GH_TAGNAME= v${DISTVERSION}
+GH_COMMIT= 16b388a
+
+USE_RUBY= yes
+USE_RAKE= yes
+
+PLIST_FILES= bin/hub \
+ etc/bash_completion.d/hub \
+ share/zsh/site-functions/_hub
+PLIST_DIRSTRY= etc/bash_completion.d \
+ share/zsh/site-functions share/zsh
+MAN1= hub.1
+
+do-build:
+ @cd ${WRKSRC} && ${RAKE_BIN} standalone
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/hub ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/hub.1 ${MAN1PREFIX}/man/man1
+
+post-install:
+ ${MKDIR} ${PREFIX}/etc/bash_completion.d
+ ${INSTALL_DATA} ${WRKSRC}/etc/hub.bash_completion.sh ${PREFIX}/etc/bash_completion.d/hub
+ ${MKDIR} ${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKSRC}/etc/hub.zsh_completion ${PREFIX}/share/zsh/site-functions/_hub
+
+.include <bsd.port.mk>
diff --git a/devel/hub/distinfo b/devel/hub/distinfo
new file mode 100644
index 000000000000..8fe47f48722e
--- /dev/null
+++ b/devel/hub/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hub-1.10.2.tar.gz) = 3bd8cf160062dac2dcdad176d14a88237fb4018522ef3a584a83c3f812d5b1c5
+SIZE (hub-1.10.2.tar.gz) = 54805
diff --git a/devel/hub/pkg-descr b/devel/hub/pkg-descr
new file mode 100644
index 000000000000..9992fe736871
--- /dev/null
+++ b/devel/hub/pkg-descr
@@ -0,0 +1,4 @@
+hub is a command line tool that wraps git in order to extend it with extra
+features and commands that make working with GitHub easier.
+
+WWW: http://defunkt.io/hub/