aboutsummaryrefslogtreecommitdiff
path: root/devel/i386-rtems-gcj/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-09-18 15:19:10 +0000
committerAde Lovett <ade@FreeBSD.org>2000-09-18 15:19:10 +0000
commitcc9f432bd929f8645fbed0bee22c32a0da7690c1 (patch)
tree7ff0c99b03556e73f87b750824e5572b9b74e0ed /devel/i386-rtems-gcj/Makefile
parent1b3513bc8124a5b535cb37d45d3387ae3e0a61cd (diff)
downloadports-cc9f432bd929f8645fbed0bee22c32a0da7690c1.tar.gz
ports-cc9f432bd929f8645fbed0bee22c32a0da7690c1.zip
Notes
Diffstat (limited to 'devel/i386-rtems-gcj/Makefile')
-rw-r--r--devel/i386-rtems-gcj/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/devel/i386-rtems-gcj/Makefile b/devel/i386-rtems-gcj/Makefile
index 7d89f51556ae..9244c8aed26b 100644
--- a/devel/i386-rtems-gcj/Makefile
+++ b/devel/i386-rtems-gcj/Makefile
@@ -7,19 +7,18 @@
PORTNAME= gcj
PORTVERSION= 2.95.2
+PORTREVISION= 9
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.oarcorp.com/pub/rtems/betas/rtems-4.5.0-beta/c_tools/source/ \
- http://www.thehousleys.net/rtems-4.5.0b3/
+MASTER_SITES= ftp://ftp.oarcorp.com/pub/rtems/snapshots/c_tools/source/ \
+ http://rtems.thehousleys.net/
DISTFILES= ${JAVANAME}.tar.gz ${NEWLIBNAME}.tar.gz
-PATCHFILES= ${JAVANAME}-rtems-20000531.diff.gz \
- ${NEWLIBNAME}-rtems-20000606.diff.gz
-PATCH_SITES= ftp://ftp.oarcorp.com/pub/rtems/betas/rtems-4.5.0-beta/c_tools/source/ \
- http://www.thehousleys.net/rtems-4.5.0b3/
+PATCHFILES= ${JAVANAME}-rtems-20000724.diff.gz \
+ ${NEWLIBNAME}-rtems-20000828.diff
+PATCH_SITES= ftp://ftp.oarcorp.com/pub/rtems/snapshots/c_tools/source/ \
+ http://rtems.thehousleys.net/
MAINTAINER= jim@thehousleys.net
-BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf
-
DIST_SUBDIR= rtems
LCLTARGET?= i386-rtems
@@ -29,13 +28,14 @@ NEWLIBNAME= newlib-1.8.2
MASTERDIR= ${.CURDIR}/../i386-rtems-gcj
PLIST= ${PKGDIR}/PLIST.${LCLTARGET}
-BUILD_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
+BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
+ ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
RUN_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
PKGNAMEPREFIX= ${LCLTARGET}-
USE_GMAKE= yes
GNU_CONFIGURE= yes
-ALL_TARGET= all info
+ALL_TARGET= all
CONFIGURE_TARGET?= --target=${LCLTARGET}
CONFIGURE_ARGS?= --with-gnu-as --with-gnu-ld --with-newlib --verbose \