aboutsummaryrefslogtreecommitdiff
path: root/devel/ice
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2015-12-27 17:40:15 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2015-12-27 17:40:15 +0000
commitee955dc4f8a9df0b1f005631a7eaa747d361e466 (patch)
treeffef14dad47251519a39a6d1b19c418777340f56 /devel/ice
parentd05e4290c025e181f76dd8663ab283f9b35e909c (diff)
downloadports-ee955dc4f8a9df0b1f005631a7eaa747d361e466.tar.gz
ports-ee955dc4f8a9df0b1f005631a7eaa747d361e466.zip
Notes
Diffstat (limited to 'devel/ice')
-rw-r--r--devel/ice/Makefile20
-rw-r--r--devel/ice/distinfo4
-rw-r--r--devel/ice/files/patch-cpp-test-Glacier2-override-Client.cpp152
-rw-r--r--devel/ice/files/patch-cpp-test-Ice-hold-AllTests.cpp49
-rw-r--r--devel/ice/files/patch-cpp-test-Ice-properties-run.py11
-rw-r--r--devel/ice/files/patch-python-test-Ice-properties-run.py11
-rw-r--r--devel/ice/files/patch-scripts-TestUtil.py12
-rw-r--r--devel/ice/pkg-plist31
8 files changed, 52 insertions, 238 deletions
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 71a8c8d5043d..72c267178e1a 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= Ice
-PORTVERSION= 3.6.0
-PORTREVISION= 1
+PORTVERSION= 3.6.1
DISTVERSIONPREFIX= v
CATEGORIES= devel
@@ -24,15 +23,13 @@ LIB_DEPENDS+= libIce.so.${LIB_VRS}:${PORTSDIR}/devel/ice
PLIST_SUB+= LIB_VERSION="${PORTVERSION}" LIB_VRS="${LIB_VRS}"
.endif
-OPTIONS_DEFINE?= DEBUG TESTS
-OPTIONS_DEFAULT?= TESTS
-TESTS_DESC?= Build and run tests (requires lang/python)
+OPTIONS_DEFINE?= DEBUG TEST
.include <bsd.port.options.mk>
USES+= iconv gmake
-.if ${PORT_OPTIONS:MTESTS} && ${SLAVE_PORT} == "no"
+.if ${PORT_OPTIONS:MTEST} && ${SLAVE_PORT} == "no"
USES+= python:build
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}passlib>0:${PORTSDIR}/security/py-passlib
.endif
@@ -62,7 +59,7 @@ BROKEN_sparc64= Does not compile on ${ARCH}
MAKE_ENV+= LP64=yes
.endif
-.if !${PORT_OPTIONS:MTESTS}
+.if !${PORT_OPTIONS:MTEST}
MAKE_ENV+= NOTESTS=yes
.endif
@@ -135,13 +132,8 @@ post-patch:
s|%%PREFIX%%|${PREFIX}|g; \
s|%%LOCALBASE%%|${LOCALBASE}|g;' ${WRKSRC}/php/config/Make.rules.php
-.if ${PORT_OPTIONS:MTESTS}
-TEST_CMD= @cd ${BUILD_WRKSRC} && ${PYTHON_CMD} ./allTests.py
-check regression-test test: build
- ${TEST_CMD}
-
-pre-install: regression-test
-.endif
+do-test-TEST-on:
+ @cd ${BUILD_WRKSRC} && ${PYTHON_CMD} ./allTests.py
.if ${SLAVE_PORT} == "no"
post-install:
diff --git a/devel/ice/distinfo b/devel/ice/distinfo
index d47f85d037e0..d5efe163c2b9 100644
--- a/devel/ice/distinfo
+++ b/devel/ice/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zeroc-ice-Ice-v3.6.0_GH0.tar.gz) = 77933580cdc7fade0ebfce517935819e9eef5fc6b9e3f4143b07404daf54e25e
-SIZE (zeroc-ice-Ice-v3.6.0_GH0.tar.gz) = 5300956
+SHA256 (zeroc-ice-Ice-v3.6.1_GH0.tar.gz) = 454d81cb72986c1f04e297a81bca7563e3449a216ad63de8630122d34545ae78
+SIZE (zeroc-ice-Ice-v3.6.1_GH0.tar.gz) = 5338954
diff --git a/devel/ice/files/patch-cpp-test-Glacier2-override-Client.cpp b/devel/ice/files/patch-cpp-test-Glacier2-override-Client.cpp
deleted file mode 100644
index f87e447108ff..000000000000
--- a/devel/ice/files/patch-cpp-test-Glacier2-override-Client.cpp
+++ /dev/null
@@ -1,152 +0,0 @@
---- cpp/test/Glacier2/override/Client.cpp.orig 2015-08-02 15:07:07.945090996 +0200
-+++ cpp/test/Glacier2/override/Client.cpp 2015-08-02 15:08:39.753584996 +0200
-@@ -102,59 +102,105 @@
-
- {
- cout << "testing server request override... " << flush;
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- Ice::Context ctx;
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- ctx["serverOvrd"] = "test";
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- for(int i = 0; i < 5; i++)
- {
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, i, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, i, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, i, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- IceUtil::ThreadControl::sleep(IceUtil::Time::milliSeconds(100));
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- test(callbackReceiverImpl->callbackOK(1, i) < 3);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- }
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(twowayR, 0);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- test(callbackReceiverImpl->callbackOK(1, 0) == 0);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
-
- int count = 0;
- int nRetry = 0;
- do
- {
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- callbackReceiverImpl->hold();
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(onewayR, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(onewayR, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(onewayR, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(onewayR, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(onewayR, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(onewayR, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(onewayR, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(onewayR, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(onewayR, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(onewayR, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(twowayR, 0);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- IceUtil::ThreadControl::sleep(IceUtil::Time::milliSeconds(200 + nRetry * 200));
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- callbackReceiverImpl->activate();
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- test(callbackReceiverImpl->callbackOK(1, 0) == 0);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- count = callbackReceiverImpl->callbackWithPayloadOK(0);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- callbackReceiverImpl->callbackWithPayloadOK(count);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- }
- while(count == 10 && nRetry++ < 10);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- test(count < 10);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
-
- oneway->initiateCallbackWithPayload(twowayR);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(twowayR);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- callbackReceiverImpl->hold();
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(twowayR);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, 0, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, 0, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, 0, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, 0, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, 0, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(twowayR);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- IceUtil::ThreadControl::sleep(IceUtil::Time::milliSeconds(1000));
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- callbackReceiverImpl->activate();
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- test(callbackReceiverImpl->callbackWithPayloadOK(4) == 0);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
-
- int remainingCallbacks = callbackReceiverImpl->callbackOK(1, 0);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- //
- // Occasionally, Glacier2 flushes in the middle of our 5
- // callbacks, so we get more than 1 callback
-@@ -164,26 +210,43 @@
- // time to receive this (these) extra callback(s).
- //
- test(remainingCallbacks <= 4);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- if(remainingCallbacks > 0)
- {
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- test(callbackReceiverImpl->callbackOK(remainingCallbacks, 0) == 0);
- }
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
-
- ctx["_fwd"] = "O";
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
-
- oneway->initiateCallbackWithPayload(twowayR);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- callbackReceiverImpl->hold();
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(twowayR);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, 0, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, 0, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, 0, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, 0, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallback(onewayR, 0, ctx);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- oneway->initiateCallbackWithPayload(twowayR);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- IceUtil::ThreadControl::sleep(IceUtil::Time::milliSeconds(200));
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- callbackReceiverImpl->activate();
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- test(callbackReceiverImpl->callbackWithPayloadOK(3) == 0);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- test(callbackReceiverImpl->callbackOK(1, 0) == 0);
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
-
- cout << "ok" << endl;
- }
diff --git a/devel/ice/files/patch-cpp-test-Ice-hold-AllTests.cpp b/devel/ice/files/patch-cpp-test-Ice-hold-AllTests.cpp
deleted file mode 100644
index abe3c64508dd..000000000000
--- a/devel/ice/files/patch-cpp-test-Ice-hold-AllTests.cpp
+++ /dev/null
@@ -1,49 +0,0 @@
---- cpp/test/Ice/hold/AllTests.cpp.orig 2015-06-23 17:30:20.000000000 +0200
-+++ cpp/test/Ice/hold/AllTests.cpp 2015-08-02 15:05:08.363617996 +0200
-@@ -152,31 +152,46 @@
- ConditionPtr cond = new Condition(true);
- int value = 0;
- Ice::AsyncResultPtr result;
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- while(value < 3000 && cond->value())
- {
-+ if (!value)
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- result = holdSerialized->begin_set(value + 1,
- IceUtilInternal::random(1),
- newCallback_Hold_set(new SetCB(cond, value),
- &SetCB::response,
- &SetCB::exception));
-+ if (!value)
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- ++value;
- if(value % 100 == 0)
- {
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- result->waitForSent();
- }
- }
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- result->waitForCompleted();
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- test(cond->value());
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
-
- for(int i = 0; i < 10000; ++i)
- {
-+ if (value == 3000)
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- holdSerialized->ice_oneway()->setOneway(value + 1, value);
-+ if (value == 3000)
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- ++value;
- if((i % 100) == 0)
- {
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- holdSerialized->ice_oneway()->putOnHold(1);
- }
- }
-+ cout << __LINE__ << " (" << time(0) << ")" << endl;
- }
- cout << "ok" << endl;
-
diff --git a/devel/ice/files/patch-cpp-test-Ice-properties-run.py b/devel/ice/files/patch-cpp-test-Ice-properties-run.py
new file mode 100644
index 000000000000..b99503f630b5
--- /dev/null
+++ b/devel/ice/files/patch-cpp-test-Ice-properties-run.py
@@ -0,0 +1,11 @@
+--- cpp/test/Ice/properties/run.py.orig 2015-12-27 03:21:09.629772970 +0100
++++ cpp/test/Ice/properties/run.py 2015-12-27 03:21:20.836761970 +0100
+@@ -28,7 +28,7 @@
+ #
+ if sys.version_info[0] == 2:
+ configPath = "./config/\xe4\xb8\xad\xe5\x9b\xbd_client.config"
+- decodedPath = configPath.decode("utf-8")
++ decodedPath = configPath
+ else:
+ configPath = "./config/\u4e2d\u56fd_client.config"
+ decodedPath = configPath # No need to decode with Python3, strings are already Unicode
diff --git a/devel/ice/files/patch-python-test-Ice-properties-run.py b/devel/ice/files/patch-python-test-Ice-properties-run.py
new file mode 100644
index 000000000000..da98dc879c6f
--- /dev/null
+++ b/devel/ice/files/patch-python-test-Ice-properties-run.py
@@ -0,0 +1,11 @@
+--- python/test/Ice/properties/run.py.orig 2015-12-27 02:42:11.742927971 +0100
++++ python/test/Ice/properties/run.py 2015-12-27 03:06:41.640921970 +0100
+@@ -26,7 +26,7 @@
+ #
+ if sys.version_info[0] == 2:
+ configPath = "./config/\xe4\xb8\xad\xe5\x9b\xbd_client.config"
+- decodedPath = configPath.decode("utf-8")
++ decodedPath = configPath
+ else:
+ configPath = "./config/\u4e2d\u56fd_client.config"
+ decodedPath = configPath # No need to decode with Python3, strings are already Unicode
diff --git a/devel/ice/files/patch-scripts-TestUtil.py b/devel/ice/files/patch-scripts-TestUtil.py
index bd301767de25..e014e83c7af5 100644
--- a/devel/ice/files/patch-scripts-TestUtil.py
+++ b/devel/ice/files/patch-scripts-TestUtil.py
@@ -26,15 +26,15 @@
def getCppCompiler():
compiler = ""
if os.environ.get("CPP_COMPILER", "") != "":
-@@ -311,7 +330,7 @@
- if(p.wait() != 0):
+@@ -324,7 +324,7 @@
print("uname failed:\n" + p.stdout.read().strip())
sys.exit(1)
-- if p.stdout.readline().decode('UTF-8').strip() == "x86_64" and os.environ.get("LP64", "") != "no":
-+ if p.stdout.readline().decode('UTF-8').strip() in ["x86_64", "amd64"] and os.environ.get("LP64", "") != "no":
+ line = p.stdout.readline().decode('UTF-8').strip()
+- if line == "x86_64" and os.environ.get("LP64", "") != "no":
++ if line in ["x86_64", "amd64"] and os.environ.get("LP64", "") != "no":
x64 = True
-
- #
+ elif line == "armv7l":
+ armv7l = True
@@ -1887,7 +1906,7 @@
if lang == "java":
addLdPath(os.path.join(getIceDir("cpp"), "bin", "x64" if x64 else ""), env) # Add bin for db53_vc100.dll
diff --git a/devel/ice/pkg-plist b/devel/ice/pkg-plist
index fcf4628a6ff2..a1efa1c9374e 100644
--- a/devel/ice/pkg-plist
+++ b/devel/ice/pkg-plist
@@ -134,6 +134,7 @@ include/Ice/ProxyF.h
include/Ice/ProxyFactoryF.h
include/Ice/ProxyHandle.h
include/Ice/ReferenceF.h
+include/Ice/RegisterPlugins.h
include/Ice/RemoteLogger.h
include/Ice/RequestHandlerF.h
include/Ice/ResponseHandlerF.h
@@ -237,49 +238,49 @@ include/Slice/PythonUtil.h
include/Slice/RubyUtil.h
include/Slice/Util.h
lib/libFreeze.so
-lib/libFreeze.so.3.6.0
+lib/libFreeze.so.3.6.1
lib/libFreeze.so.36
lib/libGlacier2.so
-lib/libGlacier2.so.3.6.0
+lib/libGlacier2.so.3.6.1
lib/libGlacier2.so.36
lib/libGlacier2CryptPermissionsVerifier.so
-lib/libGlacier2CryptPermissionsVerifier.so.3.6.0
+lib/libGlacier2CryptPermissionsVerifier.so.3.6.1
lib/libGlacier2CryptPermissionsVerifier.so.36
lib/libIce.so
-lib/libIce.so.3.6.0
+lib/libIce.so.3.6.1
lib/libIce.so.36
lib/libIceBox.so
-lib/libIceBox.so.3.6.0
+lib/libIceBox.so.3.6.1
lib/libIceBox.so.36
lib/libIceDiscovery.so
-lib/libIceDiscovery.so.3.6.0
+lib/libIceDiscovery.so.3.6.1
lib/libIceDiscovery.so.36
lib/libIceGrid.so
-lib/libIceGrid.so.3.6.0
+lib/libIceGrid.so.3.6.1
lib/libIceGrid.so.36
lib/libIceLocatorDiscovery.so
-lib/libIceLocatorDiscovery.so.3.6.0
+lib/libIceLocatorDiscovery.so.3.6.1
lib/libIceLocatorDiscovery.so.36
lib/libIcePatch2.so
-lib/libIcePatch2.so.3.6.0
+lib/libIcePatch2.so.3.6.1
lib/libIcePatch2.so.36
lib/libIceSSL.so
-lib/libIceSSL.so.3.6.0
+lib/libIceSSL.so.3.6.1
lib/libIceSSL.so.36
lib/libIceStorm.so
-lib/libIceStorm.so.3.6.0
+lib/libIceStorm.so.3.6.1
lib/libIceStorm.so.36
lib/libIceStormService.so
-lib/libIceStormService.so.3.6.0
+lib/libIceStormService.so.3.6.1
lib/libIceStormService.so.36
lib/libIceUtil.so
-lib/libIceUtil.so.3.6.0
+lib/libIceUtil.so.3.6.1
lib/libIceUtil.so.36
lib/libIceXML.so
-lib/libIceXML.so.3.6.0
+lib/libIceXML.so.3.6.1
lib/libIceXML.so.36
lib/libSlice.so
-lib/libSlice.so.3.6.0
+lib/libSlice.so.3.6.1
lib/libSlice.so.36
man/man1/dumpdb.1.gz
man/man1/glacier2router.1.gz