aboutsummaryrefslogtreecommitdiff
path: root/devel/ice
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2016-04-06 13:08:51 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2016-04-06 13:08:51 +0000
commitafb254820dbed31b644d253dab86e8ed01275cda (patch)
tree8e8739eddfb8556fe036062a31e52a84cd8e83a6 /devel/ice
parentf7d6d5a3b2a7c750da6cfcdfd5de6333c348faca (diff)
downloadports-afb254820dbed31b644d253dab86e8ed01275cda.tar.gz
ports-afb254820dbed31b644d253dab86e8ed01275cda.zip
Notes
Diffstat (limited to 'devel/ice')
-rw-r--r--devel/ice/Makefile2
-rw-r--r--devel/ice/distinfo4
-rw-r--r--devel/ice/files/patch-cpp-test-Ice-objects-Makefile28
-rw-r--r--devel/ice/files/patch-cpp-test-IceSSL-configuration-AllTests.cpp74
-rw-r--r--devel/ice/files/patch-python-config-Make.rules40
-rw-r--r--devel/ice/pkg-plist34
6 files changed, 63 insertions, 119 deletions
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 68a27437c70d..efb18b78a757 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Ice
-PORTVERSION= 3.6.1
+PORTVERSION= 3.6.2
DISTVERSIONPREFIX= v
CATEGORIES= devel
diff --git a/devel/ice/distinfo b/devel/ice/distinfo
index d5efe163c2b9..09bf187cf4d6 100644
--- a/devel/ice/distinfo
+++ b/devel/ice/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zeroc-ice-Ice-v3.6.1_GH0.tar.gz) = 454d81cb72986c1f04e297a81bca7563e3449a216ad63de8630122d34545ae78
-SIZE (zeroc-ice-Ice-v3.6.1_GH0.tar.gz) = 5338954
+SHA256 (zeroc-ice-Ice-v3.6.2_GH0.tar.gz) = 5e9305a5eb6081c8f128d63a5546158594e9f115174fc91208f645dbe2fc02fe
+SIZE (zeroc-ice-Ice-v3.6.2_GH0.tar.gz) = 5393239
diff --git a/devel/ice/files/patch-cpp-test-Ice-objects-Makefile b/devel/ice/files/patch-cpp-test-Ice-objects-Makefile
new file mode 100644
index 000000000000..de44a26171c3
--- /dev/null
+++ b/devel/ice/files/patch-cpp-test-Ice-objects-Makefile
@@ -0,0 +1,28 @@
+--- cpp.orig/test/Ice/objects/Makefile.orig 2016-04-05 23:00:02.156584966 +0200
++++ cpp/test/Ice/objects/Makefile 2016-04-05 23:44:31.611624964 +0200
+@@ -12,9 +12,9 @@
+ CLIENT = $(call mktestname,client)
+ SERVER = $(call mktestname,server)
+ COLLOCATED = $(call mktestname,collocated)
+-TESTLIBNAME = libTestDerived.a
++TESTLIBNAME = libTestDerived.so
+
+-TARGETS = $(CLIENT) $(SERVER) $(COLLOCATED)
++TARGETS = $(CLIENT) $(SERVER) $(COLLOCATED) $(TESTLIBNAME)
+
+ SLICE_OBJS = Test.o \
+ Derived.o \
+@@ -47,11 +47,11 @@
+
+ $(TESTLIBNAME): $(SLICE_OBJS)
+ rm -f $@
+- $(call mklib,$@,$(SLICE_OBJS))
++ $(call mkshlib,$@,$(TESTLIBNAME),$(SLICE_OBJS),$(LIBS))
+
+ $(CLIENT): $(COBJS) $(TESTLIBNAME)
+ rm -f $@
+- $(call mktest,$@,$(COBJS) -lTestDerived $(LIBS))
++ $(call mktest,$@,-lTestDerived $(COBJS) $(LIBS))
+
+ $(SERVER): $(SOBJS)
+ rm -f $@
diff --git a/devel/ice/files/patch-cpp-test-IceSSL-configuration-AllTests.cpp b/devel/ice/files/patch-cpp-test-IceSSL-configuration-AllTests.cpp
index b7c516dba6cc..316888270243 100644
--- a/devel/ice/files/patch-cpp-test-IceSSL-configuration-AllTests.cpp
+++ b/devel/ice/files/patch-cpp-test-IceSSL-configuration-AllTests.cpp
@@ -1,79 +1,5 @@
--- cpp/test/IceSSL/configuration/AllTests.cpp.orig 2015-06-23 15:30:20.000000000 +0000
+++ cpp/test/IceSSL/configuration/AllTests.cpp 2015-09-15 00:15:34.865304987 +0000
-@@ -7,6 +7,7 @@
- //
- // **********************************************************************
-
-+#include <openssl/ssl.h>
- #include <Ice/Ice.h>
- #include <IceSSL/Plugin.h>
- #include <TestCommon.h>
-@@ -1292,14 +1293,22 @@
- InitializationData initData;
- initData.properties = createClientProps(defaultProps, defaultDir, defaultHost, p12, "c_rsa_ca1", "cacert1");
- initData.properties->setProperty("IceSSL.VerifyPeer", "0");
-+# ifdef SSL_TXT_TLSV1_1
-+ initData.properties->setProperty("IceSSL.Protocols", "tlsv1_1");
-+# else
- initData.properties->setProperty("IceSSL.Protocols", "ssl3");
-+# endif
- CommunicatorPtr comm = initialize(initData);
-
- Test::ServerFactoryPrx fact = Test::ServerFactoryPrx::checkedCast(comm->stringToProxy(factoryRef));
- test(fact);
- Test::Properties d = createServerProps(defaultProps, defaultDir, defaultHost, p12, "s_rsa_ca1", "cacert1");
- d["IceSSL.VerifyPeer"] = "0";
-+# ifdef SSL_TXT_TLSV1_1
-+ d["IceSSL.Protocols"] = "tlsv1_0";
-+# else
- d["IceSSL.Protocols"] = "tls";
-+# endif
- Test::ServerPrx server = fact->createServer(d);
- try
- {
-@@ -1329,7 +1340,11 @@
- test(fact);
- d = createServerProps(defaultProps, defaultDir, defaultHost, p12, "s_rsa_ca1", "cacert1");
- d["IceSSL.VerifyPeer"] = "0";
-+# ifdef SSL_TXT_TLSV1_1
-+ d["IceSSL.Protocols"] = "tlsv1_1, tlsv1_0";
-+# else
- d["IceSSL.Protocols"] = "tls, ssl3";
-+# endif
- server = fact->createServer(d);
- try
- {
-@@ -1351,6 +1362,7 @@
- InitializationData initData;
- initData.properties = createClientProps(defaultProps, defaultDir, defaultHost, p12, "c_rsa_ca1", "cacert1");
- initData.properties->setProperty("IceSSL.VerifyPeer", "0");
-+ // on modern openssl this simply fails as ssl3 is not supported by the client
- initData.properties->setProperty("IceSSL.Protocols", "ssl3");
- CommunicatorPtr comm = initialize(initData);
-
-@@ -1386,14 +1398,22 @@
- {
- InitializationData initData;
- initData.properties = createClientProps(defaultProps, defaultDir, defaultHost, p12, "", "cacert1");
-+# ifdef SSL_TXT_TLSV1_1
-+ initData.properties->setProperty("IceSSL.Protocols", "tlsv1_1");
-+# else
- initData.properties->setProperty("IceSSL.Protocols", "ssl3");
-+# endif
- CommunicatorPtr comm = initialize(initData);
-
- Test::ServerFactoryPrx fact = Test::ServerFactoryPrx::checkedCast(comm->stringToProxy(factoryRef));
- test(fact);
- Test::Properties d = createServerProps(defaultProps, defaultDir, defaultHost, p12, "s_rsa_ca1", "");
- d["IceSSL.VerifyPeer"] = "0";
-+# ifdef SSL_TXT_TLSV1_1
-+ d["IceSSL.Protocols"] = "tls, tls1_1, tls1_2";
-+# else
- d["IceSSL.Protocols"] = "ssl3, tls, tls1_1, tls1_2";
-+# endif
- Test::ServerPrx server = fact->createServer(d);
- try
- {
@@ -3164,6 +3184,7 @@
#endif
}
diff --git a/devel/ice/files/patch-python-config-Make.rules b/devel/ice/files/patch-python-config-Make.rules
index f6926ad9913c..5c02b88cf666 100644
--- a/devel/ice/files/patch-python-config-Make.rules
+++ b/devel/ice/files/patch-python-config-Make.rules
@@ -1,5 +1,5 @@
---- python/config/Make.rules.orig 2015-06-23 15:30:20.000000000 +0000
-+++ python/config/Make.rules 2015-06-27 23:26:40.586161355 +0000
+--- python/config/Make.rules.orig 2016-04-05 22:33:01.425700968 +0200
++++ python/config/Make.rules 2016-04-05 22:29:23.200712968 +0200
@@ -11,7 +11,8 @@
# Select an installation base directory. The directory will be created
# if it does not exist.
@@ -10,7 +10,7 @@
#
# The "root directory" for runpath embedded in executables. Can be set
-@@ -49,7 +50,7 @@
+@@ -50,7 +51,7 @@
# version used for building the Ice extension, then set PYTHON to
# the specific to the location of the python interpreter.
#
@@ -19,37 +19,23 @@
PYTHON_VERSION ?= python$(shell $(PYTHON) -c "import sys; import distutils.sysconfig as ds; sys.stdout.write(ds.get_python_version())")
-@@ -91,9 +92,9 @@
- include $(top_srcdir)/../config/Make.common.rules
- endif
-
--ifndef usr_dir_install
--RPATH_DIR = $(prefix)/$(libsubdir)
--endif
-+#ifndef usr_dir_install
-+#RPATH_DIR = $(prefix)/$(libsubdir)
-+#endif
-
- install_bindir = $(prefix)/$(binsubdir)
-
-@@ -108,17 +109,17 @@
+@@ -105,16 +106,16 @@
libdir = $(top_srcdir)/python
-ifndef usr_dir_install
-- install_pythondir = $(prefix)/python
-- install_libdir = $(prefix)/python
+- install_pythondir = $(prefix)/python
+- install_libdir = $(prefix)/python
-else
+#ifndef usr_dir_install
-+# install_pythondir = $(prefix)/python
-+# install_libdir = $(prefix)/python
++# install_pythondir = $(prefix)/python
++# install_libdir = $(prefix)/python
+#else
#
# The install_dir script says where python wants site-packages installed.
#
-
-- install_pythondir = $(shell $(PYTHON) $(top_srcdir)/config/install_dir)
-- install_libdir = $(install_pythondir)
+- install_pythondir = $(shell $(PYTHON) $(top_srcdir)/config/install_dir)
+- install_libdir = $(install_pythondir)
-endif
+ install_pythondir = %%PYTHON_SITELIBDIR%%/Ice
+ install_libdir = %%PYTHON_SITELIBDIR%%/Ice
@@ -57,7 +43,7 @@
ifeq ($(UNAME),SunOS)
ifeq ($(LP64),yes)
-@@ -127,14 +128,10 @@
+@@ -123,14 +124,10 @@
endif
endif
@@ -76,7 +62,7 @@
CPPFLAGS =
ICECPPFLAGS = -I$(slicedir)
-@@ -143,10 +140,7 @@
+@@ -139,10 +136,7 @@
ifdef ice_src_dist
SLICE2PY = $(PYTHON) $(top_srcdir)/config/s2py.py
@@ -88,7 +74,7 @@
else
ifeq ($(UNAME),Darwin)
SLICE2PY = /usr/local/bin/slice2py
-@@ -171,7 +165,7 @@
+@@ -167,7 +161,7 @@
all:: $(SRCS)
diff --git a/devel/ice/pkg-plist b/devel/ice/pkg-plist
index a1efa1c9374e..2200f390aa70 100644
--- a/devel/ice/pkg-plist
+++ b/devel/ice/pkg-plist
@@ -3,12 +3,14 @@ bin/glacier2router
bin/icebox
bin/iceboxadmin
bin/icegridadmin
+bin/icegriddb
bin/icegridnode
bin/icegridregistry
bin/icepatch2calc
bin/icepatch2client
bin/icepatch2server
bin/icestormadmin
+bin/icestormdb
bin/icestormmigrate
bin/slice2cpp
bin/slice2cs
@@ -238,61 +240,63 @@ include/Slice/PythonUtil.h
include/Slice/RubyUtil.h
include/Slice/Util.h
lib/libFreeze.so
-lib/libFreeze.so.3.6.1
+lib/libFreeze.so.3.6.2
lib/libFreeze.so.36
lib/libGlacier2.so
-lib/libGlacier2.so.3.6.1
+lib/libGlacier2.so.3.6.2
lib/libGlacier2.so.36
lib/libGlacier2CryptPermissionsVerifier.so
-lib/libGlacier2CryptPermissionsVerifier.so.3.6.1
+lib/libGlacier2CryptPermissionsVerifier.so.3.6.2
lib/libGlacier2CryptPermissionsVerifier.so.36
lib/libIce.so
-lib/libIce.so.3.6.1
+lib/libIce.so.3.6.2
lib/libIce.so.36
lib/libIceBox.so
-lib/libIceBox.so.3.6.1
+lib/libIceBox.so.3.6.2
lib/libIceBox.so.36
lib/libIceDiscovery.so
-lib/libIceDiscovery.so.3.6.1
+lib/libIceDiscovery.so.3.6.2
lib/libIceDiscovery.so.36
lib/libIceGrid.so
-lib/libIceGrid.so.3.6.1
+lib/libIceGrid.so.3.6.2
lib/libIceGrid.so.36
lib/libIceLocatorDiscovery.so
-lib/libIceLocatorDiscovery.so.3.6.1
+lib/libIceLocatorDiscovery.so.3.6.2
lib/libIceLocatorDiscovery.so.36
lib/libIcePatch2.so
-lib/libIcePatch2.so.3.6.1
+lib/libIcePatch2.so.3.6.2
lib/libIcePatch2.so.36
lib/libIceSSL.so
-lib/libIceSSL.so.3.6.1
+lib/libIceSSL.so.3.6.2
lib/libIceSSL.so.36
lib/libIceStorm.so
-lib/libIceStorm.so.3.6.1
+lib/libIceStorm.so.3.6.2
lib/libIceStorm.so.36
lib/libIceStormService.so
-lib/libIceStormService.so.3.6.1
+lib/libIceStormService.so.3.6.2
lib/libIceStormService.so.36
lib/libIceUtil.so
-lib/libIceUtil.so.3.6.1
+lib/libIceUtil.so.3.6.2
lib/libIceUtil.so.36
lib/libIceXML.so
-lib/libIceXML.so.3.6.1
+lib/libIceXML.so.3.6.2
lib/libIceXML.so.36
lib/libSlice.so
-lib/libSlice.so.3.6.1
+lib/libSlice.so.3.6.2
lib/libSlice.so.36
man/man1/dumpdb.1.gz
man/man1/glacier2router.1.gz
man/man1/icebox.1.gz
man/man1/iceboxadmin.1.gz
man/man1/icegridadmin.1.gz
+man/man1/icegriddb.1.gz
man/man1/icegridnode.1.gz
man/man1/icegridregistry.1.gz
man/man1/icepatch2calc.1.gz
man/man1/icepatch2client.1.gz
man/man1/icepatch2server.1.gz
man/man1/icestormadmin.1.gz
+man/man1/icestormdb.1.gz
man/man1/icestormmigrate.1.gz
man/man1/slice2cpp.1.gz
man/man1/slice2cs.1.gz