aboutsummaryrefslogtreecommitdiff
path: root/devel/icu
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2008-02-07 05:31:44 +0000
committerMikhail Teterin <mi@FreeBSD.org>2008-02-07 05:31:44 +0000
commit409149d56c7b70f6945a3829d8a32dc2adb17e34 (patch)
tree9ef02dbfb3dcc66d99ecda368987a8db685303d3 /devel/icu
parent2cae171d4dee5b2765946986acceacabe5776444 (diff)
downloadports-409149d56c7b70f6945a3829d8a32dc2adb17e34.tar.gz
ports-409149d56c7b70f6945a3829d8a32dc2adb17e34.zip
Notes
Diffstat (limited to 'devel/icu')
-rw-r--r--devel/icu/Makefile19
-rw-r--r--devel/icu/distinfo6
-rw-r--r--devel/icu/files/patch-enum-bug50
-rw-r--r--devel/icu/files/patch-install8
-rw-r--r--devel/icu/files/patch-intltest64
-rw-r--r--devel/icu/files/patch-putil9
-rw-r--r--devel/icu/pkg-plist12
7 files changed, 40 insertions, 128 deletions
diff --git a/devel/icu/Makefile b/devel/icu/Makefile
index 850c0f53166f..9af315ba9303 100644
--- a/devel/icu/Makefile
+++ b/devel/icu/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= icu
-PORTVERSION= 3.6
+PORTVERSION= 3.8.1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- ftp://ftp.software.ibm.com/software/globalization/icu/${PORTVERSION}/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}
DISTNAME= icu4c-${PORTVERSION:S/./_/g}
EXTRACT_SUFX= -src.tgz
@@ -17,7 +16,7 @@ EXTRACT_SUFX= -src.tgz
MAINTAINER= mi@aldan.algebra.com
COMMENT= International Components for Unicode (from IBM)
-OPTIONS= THREADS "Build multi-threaded version of the library" off
+OPTIONS= THREADS "Build thread-safe version of the library" on
CONFLICTS= icu2-[0-9]*
INSTALLS_SHLIB= yes
@@ -30,6 +29,7 @@ CONFIGURE_ARGS+= ${OPSYS}
CONFIGURE_ARGS+= --enable-shared
CONFIGURE_ARGS+= --enable-static
CONFIGURE_ARGS+= --enable-samples=no
+ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
USE_GMAKE= yes
@@ -49,7 +49,7 @@ MAN8+= gensprep.8
MAN8+= genuca.8
ICUMAJOR= ${PORTVERSION:S/.//:R}
-PLIST_SUB+= ICUMAJOR=${ICUMAJOR} ICUMINOR=0
+PLIST_SUB+= ICUMAJOR=${ICUMAJOR} ICUMINOR=1
PLIST_SUB+= ICUVER=${PORTVERSION}
.include <bsd.port.pre.mk>
@@ -62,12 +62,13 @@ CXXFLAGS:= ${CXXFLAGS:N-funroll-loops:N-O*:N-*strict-aliasing} -O2 -fno-strict-a
.endif
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
-.if defined(WITH_THREADS)
-CONFIGURE_ARGS+= --enable-threads=yes
+.if defined(WITHOUT_THREADS)
+CONFIGURE_ARGS+= --enable-threads=no
+.else
+# This builds thread-safe, but not the thread-using version:
+CONFIGURE_ARGS+= --enable-weak-threads
post-patch:
${REINPLACE_CMD} -e 's,\(THREADSC.*FLAGS\).*,\1=${PTHREAD_CFLAGS},g' ${WRKSRC}/config/mh-bsd-gcc
-.else
-CONFIGURE_ARGS+= --enable-threads=no
.endif
iotest cintltst intltest:
diff --git a/devel/icu/distinfo b/devel/icu/distinfo
index b1b38eb69616..0f8fe7c770f0 100644
--- a/devel/icu/distinfo
+++ b/devel/icu/distinfo
@@ -1,3 +1,3 @@
-MD5 (icu4c-3_6-src.tgz) = 6243f7a19e03e05403ce84e597510d4c
-SHA256 (icu4c-3_6-src.tgz) = 5135e8d69d6206d320515df7aeee7027711ab1aef9d8dbf29571a97a9746b041
-SIZE (icu4c-3_6-src.tgz) = 10183358
+MD5 (icu4c-3_8_1-src.tgz) = a827dbc9d909febd4ec39b90386868ba
+SHA256 (icu4c-3_8_1-src.tgz) = 16dda09dff3f770e629313a4c50a82fee88baf87d89a3bb2a28806be07766cee
+SIZE (icu4c-3_8_1-src.tgz) = 10998841
diff --git a/devel/icu/files/patch-enum-bug b/devel/icu/files/patch-enum-bug
deleted file mode 100644
index 4c254481a0dc..000000000000
--- a/devel/icu/files/patch-enum-bug
+++ /dev/null
@@ -1,50 +0,0 @@
---- i18n/regexcmp.h Thu Oct 20 10:54:02 2005
-+++ i18n/regexcmp.h Mon Dec 11 13:42:54 2006
-@@ -38,9 +38,6 @@
- // to the depth of parentheses nesting
- // that is allowed in the rules.
-
--enum EParseAction {dummy01, dummy02}; // Placeholder enum for the specifier for
-- // actions that are specified in the
-- // rule parsing state table.
- struct RegexTableEl;
- class RegexPattern;
-
-@@ -83,7 +80,7 @@
- private:
-
-
-- UBool doParseActions(EParseAction a);
-+ UBool doParseActions(int a);
- void error(UErrorCode e); // error reporting convenience function.
-
- UChar32 nextCharLL();
---- i18n/regexcmp.cpp Wed Feb 1 22:37:14 2006
-+++ 118n/regexcmp.cpp Mon Dec 11 13:43:21 2006
-@@ -191,7 +191,7 @@
- // We've found the row of the state table that matches the current input
- // character from the rules string.
- // Perform any action specified by this row in the state table.
-- if (doParseActions((EParseAction)tableEl->fAction) == FALSE) {
-+ if (doParseActions(tableEl->fAction) == FALSE) {
- // Break out of the state machine loop if the
- // the action signalled some kind of error, or
- // the action was to exit, occurs on normal end-of-rules-input.
-@@ -321,7 +321,7 @@
- //
- //
- //------------------------------------------------------------------------------
--UBool RegexCompile::doParseActions(EParseAction action)
-+UBool RegexCompile::doParseActions(int action)
- {
- UBool returnVal = TRUE;
-
-@@ -342,7 +342,7 @@
-
- // Standard open nonCapture paren action emits the two NOPs and
- // sets up the paren stack frame.
-- doParseActions((EParseAction)doOpenNonCaptureParen);
-+ doParseActions(doOpenNonCaptureParen);
- break;
-
- case doPatFinish:
diff --git a/devel/icu/files/patch-install b/devel/icu/files/patch-install
new file mode 100644
index 000000000000..9af0afc80593
--- /dev/null
+++ b/devel/icu/files/patch-install
@@ -0,0 +1,8 @@
+--- Makefile.in 2007-12-12 13:58:06.000000000 -0500
++++ Makefile.in 2008-01-28 15:20:56.000000000 -0500
+@@ -126,5 +126,4 @@
+ $(INSTALL_DATA) @platform_make_fragment@ $(DESTDIR)$(pkgdatadir)/config/@platform_make_fragment_name@
+ $(INSTALL_SCRIPT) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(pkgdatadir)/mkinstalldirs
+- $(INSTALL_SCRIPT) $(top_srcdir)/install-sh $(DESTDIR)$(pkgdatadir)/install-sh
+ $(INSTALL_DATA) $(top_srcdir)/../license.html $(DESTDIR)$(pkgdatadir)/license.html
+ $(INSTALL_SCRIPT) $(top_builddir)/config/icu-config $(DESTDIR)$(bindir)/icu-config
diff --git a/devel/icu/files/patch-intltest b/devel/icu/files/patch-intltest
deleted file mode 100644
index 61b6baec5887..000000000000
--- a/devel/icu/files/patch-intltest
+++ /dev/null
@@ -1,64 +0,0 @@
-This fixes the test code as addressing the problem(s) documented in
-FreeBSD's
-
- http://www.freebsd.org/cgi/query-pr.cgi?pr=102629
-
-and ICU's
-
- http://bugs.icu-project.org/cgi-bin/icu-bugs?findid=5366
-
---- test/intltest/restsnew.cpp Tue Dec 27 17:21:28 2005
-+++ test/intltest/restsnew.cpp Tue Nov 7 11:35:57 2006
-@@ -1,5 +1,5 @@
- /********************************************************************
- * COPYRIGHT:
-- * Copyright (c) 1997-2005, International Business Machines Corporation and
-+ * Copyright (c) 1997-2006, International Business Machines Corporation and
- * others. All Rights Reserved.
- ********************************************************************/
-@@ -35,9 +35,9 @@
- //***************************************************************************************
-
--#define CONFIRM_EQ(actual,expected) if ((expected)==(actual)) { record_pass(); } else { record_fail(); errln(action + (UnicodeString)" returned " + (actual) + (UnicodeString)" instead of " + (expected) + (UnicodeString)"\n"); }
--#define CONFIRM_GE(actual,expected) if ((actual)>=(expected)) { record_pass(); } else { record_fail(); errln(action + (UnicodeString)" returned " + (actual) + (UnicodeString)" instead of x >= " + (expected) + (UnicodeString)"\n"); }
--#define CONFIRM_NE(actual,expected) if ((expected)!=(actual)) { record_pass(); } else { record_fail(); errln(action + (UnicodeString)" returned " + (actual) + (UnicodeString)" instead of x != " + (expected) + (UnicodeString)"\n"); }
-+#define CONFIRM_EQ(actual,expected) if ((expected)==(actual)) { record_pass(); } else { record_fail(); errln(action + (UnicodeString)" returned " + (actual) + (UnicodeString)" instead of " + (expected)); }
-+#define CONFIRM_GE(actual,expected) if ((actual)>=(expected)) { record_pass(); } else { record_fail(); errln(action + (UnicodeString)" returned " + (actual) + (UnicodeString)" instead of x >= " + (expected)); }
-+#define CONFIRM_NE(actual,expected) if ((expected)!=(actual)) { record_pass(); } else { record_fail(); errln(action + (UnicodeString)" returned " + (actual) + (UnicodeString)" instead of x != " + (expected)); }
-
--#define CONFIRM_UErrorCode(actual,expected) if ((expected)==(actual)) { record_pass(); } else { record_fail(); errln(action + (UnicodeString)" returned " + (UnicodeString)u_errorName(actual) + (UnicodeString)" instead of " + (UnicodeString)u_errorName(expected) + (UnicodeString)"\n"); }
-+#define CONFIRM_UErrorCode(actual,expected) if ((expected)==(actual)) { record_pass(); } else { record_fail(); errln(action + (UnicodeString)" returned " + (UnicodeString)u_errorName(actual) + (UnicodeString)" instead of " + (UnicodeString)u_errorName(expected)); }
-
- //***************************************************************************************
-@@ -198,4 +198,12 @@
- NewResourceBundleTest::TestResourceBundles()
- {
-+ UErrorCode status = U_ZERO_ERROR;
-+ loadTestData(status);
-+ if(U_FAILURE(status))
-+ {
-+ errln("Could not load testdata.dat %s " + UnicodeString(u_errorName(status)));
-+ return;
-+ }
-+
- testTag("only_in_Root", TRUE, FALSE, FALSE);
- testTag("only_in_te", FALSE, TRUE, FALSE);
-@@ -432,10 +440,16 @@
- logln("Testing ResourceBundle(UErrorCode)\n");
- ResourceBundle defaultresource(err);
-+ ResourceBundle explicitdefaultresource(NULL, Locale::getDefault(), err);
- if(U_FAILURE(err)){
- errln("Construction of default resourcebundle failed");
- return;
- }
-- if(strcmp(defaultresource.getLocale().getName(), Locale::getDefault().getName()) != 0){
-- errln("Construction of default resourcebundle didn't take the defaultlocale\n");
-+ // You can't compare the default locale to the resolved locale in the
-+ // resource bundle due to aliasing, keywords in the default locale
-+ // or the chance that the machine running these tests is using a locale
-+ // that isn't available in ICU.
-+ if(strcmp(defaultresource.getLocale().getName(), explicitdefaultresource.getLocale().getName()) != 0){
-+ errln("Construction of default resourcebundle didn't take the defaultlocale. Expected %s Got %s err=%s\n",
-+ explicitdefaultresource.getLocale().getName(), defaultresource.getLocale().getName(), u_errorName(err));
- }
-
diff --git a/devel/icu/files/patch-putil b/devel/icu/files/patch-putil
new file mode 100644
index 000000000000..f102043ddb96
--- /dev/null
+++ b/devel/icu/files/patch-putil
@@ -0,0 +1,9 @@
+--- common/putil.c 2007-12-12 13:57:26.000000000 -0500
++++ common/putil.c 2008-01-28 13:04:02.000000000 -0500
+@@ -577,5 +577,5 @@
+ /* These platforms are likely to use Olson timezone IDs. */
+ #define CHECK_LOCALTIME_LINK 1
+-#if defined(U_LINUX)
++#if defined(U_LINUX) || defined(U_BSD)
+ #define TZDEFAULT "/etc/localtime"
+ #define TZZONEINFO "/usr/share/zoneinfo/"
diff --git a/devel/icu/pkg-plist b/devel/icu/pkg-plist
index b2916ad5d5b0..2b9df0bd0602 100644
--- a/devel/icu/pkg-plist
+++ b/devel/icu/pkg-plist
@@ -24,7 +24,9 @@ include/layout/LETypes.h
include/layout/LayoutEngine.h
include/layout/ParagraphLayout.h
include/layout/RunArrays.h
+include/layout/loengine.h
@dirrm include/layout
+include/unicode/basictz.h
include/unicode/brkiter.h
include/unicode/calendar.h
include/unicode/caniter.h
@@ -40,6 +42,8 @@ include/unicode/dcfmtsym.h
include/unicode/decimfmt.h
include/unicode/docmain.h
include/unicode/dtfmtsym.h
+include/unicode/dtptngen.h
+include/unicode/dtrule.h
include/unicode/fieldpos.h
include/unicode/fmtable.h
include/unicode/format.h
@@ -51,14 +55,15 @@ include/unicode/measure.h
include/unicode/msgfmt.h
include/unicode/normlzr.h
include/unicode/numfmt.h
-include/unicode/ppalmos.h
include/unicode/parseerr.h
include/unicode/parsepos.h
include/unicode/platform.h
+include/unicode/ppalmos.h
include/unicode/putil.h
include/unicode/pwin32.h
include/unicode/rbbi.h
include/unicode/rbnf.h
+include/unicode/rbtz.h
include/unicode/regex.h
include/unicode/rep.h
include/unicode/resbund.h
@@ -73,6 +78,8 @@ include/unicode/symtable.h
include/unicode/tblcoll.h
include/unicode/timezone.h
include/unicode/translit.h
+include/unicode/tzrule.h
+include/unicode/tztrans.h
include/unicode/ubidi.h
include/unicode/ubrk.h
include/unicode/ucal.h
@@ -91,6 +98,7 @@ include/unicode/ucsdet.h
include/unicode/ucurr.h
include/unicode/udat.h
include/unicode/udata.h
+include/unicode/udatpg.h
include/unicode/udeprctd.h
include/unicode/udraft.h
include/unicode/uenum.h
@@ -137,6 +145,7 @@ include/unicode/utrace.h
include/unicode/utrans.h
include/unicode/utypes.h
include/unicode/uversion.h
+include/unicode/vtzone.h
@dirrm include/unicode
lib/icu/%%ICUVER%%/Makefile.inc
lib/icu/current
@@ -165,7 +174,6 @@ lib/libsicuio.a
lib/libicuio.so.%%ICUMAJOR%%.%%ICUMINOR%%
lib/libicuio.so
lib/libicuio.so.%%ICUMAJOR%%
-lib/libsicutu.a
lib/libicutu.so.%%ICUMAJOR%%.%%ICUMINOR%%
lib/libicutu.so.%%ICUMAJOR%%
lib/libicutu.so