aboutsummaryrefslogtreecommitdiff
path: root/devel/idlefork/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-09-21 16:18:14 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-09-21 16:18:14 +0000
commit97a4678e0af16dab8b2531d723828cb25d5930b6 (patch)
tree94a7b4f16f20cc09a4ad38b21932634afd066a3c /devel/idlefork/Makefile
parent11127aef68ebb5690f2e70f733612b64fe8c93b2 (diff)
Notes
Diffstat (limited to 'devel/idlefork/Makefile')
-rw-r--r--devel/idlefork/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/idlefork/Makefile b/devel/idlefork/Makefile
new file mode 100644
index 000000000000..9b9f244119ba
--- /dev/null
+++ b/devel/idlefork/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: idle
+# Date created: 13 April 2000
+# Whom: Maxim Sobolev <sobomax@altavista.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= idle
+PORTVERSION= 0.5
+CATEGORIES= devel
+MASTER_SITES= http://www.python.org/idle/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= sobomax@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/python:${PORTSDIR}/lang/python
+RUN_DEPENDS= ${LOCALBASE}/lib/python1.5/site-packages/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
+do-build:
+ ${LOCALBASE}/bin/python \
+ ${LOCALBASE}/lib/python1.5/compileall.py ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/idle/Icons
+ @cd ${WRKSRC} && \
+ ${INSTALL_DATA} *.py? help.txt ${PREFIX}/share/idle
+ @${INSTALL_DATA} ${WRKSRC}/Icons/* ${PREFIX}/share/idle/Icons
+ @printf "#!/bin/sh\n${LOCALBASE}/bin/python ${PREFIX}/share/idle/idle.pyc\n" \
+ > ${WRKDIR}/idle.sh
+ @${INSTALL_SCRIPT} ${WRKDIR}/idle.sh ${PREFIX}/bin/idle
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/idle
+ @cd ${WRKSRC} && ${INSTALL_DATA} NEWS.txt README.txt TODO.txt \
+ extend.txt ${PREFIX}/share/doc/idle
+.endif
+
+.include <bsd.port.mk>