aboutsummaryrefslogtreecommitdiff
path: root/devel/imake-4
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-06 17:34:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-06 17:34:48 +0000
commitdd64637baf5614686dbe544352d62c59ac5cb779 (patch)
tree22b29a564542ecf91d17f02a1244236df1377772 /devel/imake-4
parent4e6c2f5ad4a0990fecc8aee69123f2f511078bff (diff)
downloadports-dd64637baf5614686dbe544352d62c59ac5cb779.tar.gz
ports-dd64637baf5614686dbe544352d62c59ac5cb779.zip
Notes
Diffstat (limited to 'devel/imake-4')
-rw-r--r--devel/imake-4/Makefile6
-rw-r--r--devel/imake-4/files/patch-d35
2 files changed, 38 insertions, 3 deletions
diff --git a/devel/imake-4/Makefile b/devel/imake-4/Makefile
index a7e896a090ad..dbb222eb7cfb 100644
--- a/devel/imake-4/Makefile
+++ b/devel/imake-4/Makefile
@@ -18,6 +18,7 @@ COMMENT= Imake and other utilities from XFree86
PREFIX?= ${X11BASE}
USE_PERL5= YES
+USE_REINPLACE= yes
.ifdef USE_IMAKE
.error You have `USE_IMAKE' variable defined either in environment or in make(1) arguments. Please undefine and try again.
@@ -66,6 +67,11 @@ InstallXdmConfig?= YES
InstallXinitConfig?= YES
InstallAppDefFiles?= YES
+pre-configure:
+ @${REINPLACE_CMD} -e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g ; \
+ s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/cf/FreeBSD.cf
+
post-install:
@${MKHTMLINDEX} ${PREFIX}/lib/X11/doc/html
diff --git a/devel/imake-4/files/patch-d b/devel/imake-4/files/patch-d
index 3b1b280c237c..9c63e1fad9dd 100644
--- a/devel/imake-4/files/patch-d
+++ b/devel/imake-4/files/patch-d
@@ -1,6 +1,35 @@
---- cf/FreeBSD.cf.orig Fri May 4 05:12:35 2001
-+++ cf/FreeBSD.cf Mon Jun 4 19:31:27 2001
-@@ -444,14 +444,14 @@
+--- cf/FreeBSD.cf.orig Tue Jan 14 21:52:12 2003
++++ cf/FreeBSD.cf Fri Feb 6 12:27:55 2004
+@@ -89,14 +89,14 @@
+ # endif
+ # define HasPosixThreads YES
+ # define ThreadedX YES
+-# define SystemMTDefines -D_REENTRANT -D_THREAD_SAFE
++# define SystemMTDefines %%PTHREAD_CFLAGS%%
+ /*
+ * FreeBSD has tread-safe api but no getpwnam_r yet.
+ */
+ # define HasThreadSafeAPI YES
+ # define MTSafeAPIDefines -DXUSE_MTSAFE_API -DXNO_MTSAFE_PWDAPI
+ # if HasLibPthread
+-# define ThreadsLibraries -lpthread
++# define ThreadsLibraries %%PTHREAD_LIBS%%
+ # else
+ # if OSRelVersion >= 500043
+ # define BuildThreadStubLibrary NO
+@@ -106,9 +106,9 @@
+ # define NeedUIThrStubs YES
+ # endif
+ # if (OSRelVersion >= 500016)
+-# define ThreadsLibraries -lc_r
++# define ThreadsLibraries %%PTHREAD_LIBS%%
+ # else
+-# define ThreadsLibraries -pthread
++# define ThreadsLibraries %%PTHREAD_LIBS%%
+ # endif
+ # define SharedX11Reqs $(LDPRELIB) $(XTHRSTUBLIB)
+ # define SharedXtReqs $(LDPRELIB) $(XLIBONLY) $(SMLIB) $(ICELIB) $(XTHRSTUBLIB)
+@@ -485,14 +485,14 @@
/* The GCC strength-reduce bug is fixed for FreeBSD 2.1.5 and later */
#ifndef DefaultGcc2i386Opt
#if OSMajorVersion > 2 || (OSMajorVersion == 2 && OSMinorVersion > 1) || (OSMajorVersion == 2 && OSMinorVersion == 1 && OSTeenyVersion >= 5)