aboutsummaryrefslogtreecommitdiff
path: root/devel/imake/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2011-12-02 16:04:12 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2011-12-02 16:04:12 +0000
commit42ca1cf3d22a0283f6fd0e185ec2240be3917713 (patch)
tree64da40f648f7312ab0b87953b2cabccf92731479 /devel/imake/Makefile
parenta5d12af7f1619ef27fdcf8c8dbb04f5809d86b5b (diff)
downloadports-42ca1cf3d22a0283f6fd0e185ec2240be3917713.tar.gz
ports-42ca1cf3d22a0283f6fd0e185ec2240be3917713.zip
Notes
Diffstat (limited to 'devel/imake/Makefile')
-rw-r--r--devel/imake/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/imake/Makefile b/devel/imake/Makefile
index fa9ac23f4f43..d4d95da49a57 100644
--- a/devel/imake/Makefile
+++ b/devel/imake/Makefile
@@ -39,4 +39,16 @@ MAN1= ccmakedep.1 \
post-patch:
@${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/mkhtmlindex.pl
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# clang's cpp destroys whitespace, particularly hard tabs in makefiles,
+# which is fatal for imake.
+.if defined(CC) && ${CC} == "clang"
+RUN_DEPENDS+= ucpp:{PORTSDIR}/devel/ucpp
+CONFIGURE_ENV+= ac_cv_path_RAWCPP="ucpp -s"
+
+post-build:
+ ${REINPLACE_CMD} -e 's|^configdirspec= *|configdirspec=|' ${WRKSRC}/xmkmf
+.endif
+
+.include <bsd.port.post.mk>