aboutsummaryrefslogtreecommitdiff
path: root/devel/imake
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
commit92ea0d614b10bd99ce43a611721c7c4003cd79a5 (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /devel/imake
parentffbb85145227efbc987e5d09cab804f896bf37f5 (diff)
Notes
Diffstat (limited to 'devel/imake')
-rw-r--r--devel/imake/Makefile22
-rw-r--r--devel/imake/distinfo4
-rw-r--r--devel/imake/files/patch-xmkmf.cpp17
3 files changed, 17 insertions, 26 deletions
diff --git a/devel/imake/Makefile b/devel/imake/Makefile
index ba6d0ebe3235..a91239b35550 100644
--- a/devel/imake/Makefile
+++ b/devel/imake/Makefile
@@ -1,8 +1,8 @@
-# Created by: Eric Anholt <ahnholt@FreeBSD.org>
+# Created by: Eric Anholt <anholt@FreeBSD.org>
# $FreeBSD$
PORTNAME= imake
-PORTVERSION= 1.0.4
+PORTVERSION= 1.0.5
PORTEPOCH= 1
CATEGORIES= devel
@@ -11,13 +11,17 @@ COMMENT= Imake and other utilities from X.Org
RUN_DEPENDS= gccmakedep:${PORTSDIR}/devel/gccmakedep \
makedepend:${PORTSDIR}/devel/makedepend \
- ${PREFIX}/lib/X11/config/xorg.cf:${PORTSDIR}/x11/xorg-cf-files
+ ${LOCALBASE}/lib/X11/config/xorg.cf:${PORTSDIR}/x11/xorg-cf-files
USE_PERL5= yes
XORG_CAT= util
USE_XORG= xproto
+# clang's cpp destroys whitespace, particularly hard tabs in makefiles,
+# which is fatal for imake.
+CPPFLAGS+= -DDEFAULT_CC=\\\"gcc\\\"
+
.ifdef USE_IMAKE
.error You have `USE_IMAKE' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
@@ -34,16 +38,14 @@ MAN1= ccmakedep.1 \
post-patch:
@${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/mkhtmlindex.pl
+ @${REINPLACE_CMD} 's/test.*-traditional.*;/true;/' ${WRKSRC}/configure
.include <bsd.port.pre.mk>
-.if defined(CC) && ${CC:T:M*clang*} == "clang" || ${OSVERSION} >= 1000024
-BUILD_DEPENDS+= ucpp:${PORTSDIR}/devel/ucpp
-RUN_DEPENDS+= ucpp:${PORTSDIR}/devel/ucpp
-CONFIGURE_ENV+= ac_cv_path_RAWCPP="ucpp -s"
-
-post-build:
- ${REINPLACE_CMD} -e 's|^configdirspec= *|configdirspec=|' ${WRKSRC}/xmkmf
+# Attempt to force use of GNU cpp, if it is installed as /usr/bin/gcpp.
+.if (${OSVERSION} >= 900506 && ${OSVERSION} < 1000000) || \
+ ${OSVERSION} >= 1000010
+CONFIGURE_ENV+= ac_cv_path_RAWCPP="gcpp"
.endif
.include <bsd.port.post.mk>
diff --git a/devel/imake/distinfo b/devel/imake/distinfo
index 1e2fe2cdcd7d..cfd49ab14d9f 100644
--- a/devel/imake/distinfo
+++ b/devel/imake/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/util/imake-1.0.4.tar.bz2) = acb27ff09e3083000441a8d555fbedbf35ecb4ad52d2bd5b8680dce853f146fe
-SIZE (xorg/util/imake-1.0.4.tar.bz2) = 140773
+SHA256 (xorg/util/imake-1.0.5.tar.bz2) = 99ce77ce73892d262522ee621032cef2fad2d30a36088b1305a156af4ee21cc1
+SIZE (xorg/util/imake-1.0.5.tar.bz2) = 148503
diff --git a/devel/imake/files/patch-xmkmf.cpp b/devel/imake/files/patch-xmkmf.cpp
index a08866e3855f..94a238332a9f 100644
--- a/devel/imake/files/patch-xmkmf.cpp
+++ b/devel/imake/files/patch-xmkmf.cpp
@@ -1,17 +1,6 @@
---- work/imake-1.0.2/xmkmf.cpp 2004-04-23 18:42:00.000000000 +0000
-+++ xmkmf.cpp 2009-12-14 20:51:01.695597560 +0000
-@@ -53,6 +53,10 @@
- args="-I$topdir/config/cf -DTOPDIR=$topdir -DCURDIR=$curdir"
- fi
-
-+if [ -n "$CPP" -a -z "$IMAKECPP" ];then
-+ export IMAKECPP=$CPP
-+fi
-+
- echo imake $imake_defines $args
- case "$do_all" in
- yes)
-@@ -68,3 +72,12 @@
+--- xmkmf.cpp.orig 2012-03-08 06:47:32.000000000 +0100
++++ xmkmf.cpp 2013-03-17 22:53:14.000000000 +0100
+@@ -64,3 +64,12 @@
imake $imake_defines $args
;;
esac