aboutsummaryrefslogtreecommitdiff
path: root/devel/ipython
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2013-03-22 10:02:18 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2013-03-22 10:02:18 +0000
commitd021bbcf170495bf4758b08f20cff4a7173e2407 (patch)
treeb06b53c8dd1acb223b81f849931074bf2a153ce6 /devel/ipython
parent4205102326df72244de6995b00a05e2a4c14e05e (diff)
Notes
Diffstat (limited to 'devel/ipython')
-rw-r--r--devel/ipython/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/devel/ipython/Makefile b/devel/ipython/Makefile
index c78ab13a67e6..632b93daca2e 100644
--- a/devel/ipython/Makefile
+++ b/devel/ipython/Makefile
@@ -14,7 +14,6 @@ COMMENT= An enhanced Interactive Python shell
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2:${PORTSDIR}/databases/py-sqlite3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pexpect>=2:${PORTSDIR}/misc/py-pexpect \
${PYTHON_PKGNAMEPREFIX}sqlite3>=2:${PORTSDIR}/databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}pyzmq>=2.1.4:${PORTSDIR}/devel/py-pyzmq
USE_PYTHON= yes
USE_PYDISTUTILS=yes
@@ -22,10 +21,11 @@ USE_PYDISTUTILS=yes
MAN1= ipcluster.1 ipcontroller.1 ipengine.1 iplogger.1 \
ipython.1 irunner.1 pycolor.1
-OPTIONS_DEFINE= X11 HTML_NOTEBOOK
-OPTIONS_DEFAULT=X11
+OPTIONS_DEFINE= X11 HTML_NOTEBOOK ZMQ
+OPTIONS_DEFAULT=X11 ZMQ
HTML_NOTEBOOK_DESC= HTML notebook support
+ZMQ_DESC= ZMQ support (parallel computing, qt console, notebook)
.include <bsd.port.options.mk>
@@ -39,6 +39,10 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:${PORTSDIR}/x11-toolkits/py-qt4-
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=2.0:${PORTSDIR}/www/py-tornado
.endif
+.if ${PORT_OPTIONS:MZMQ}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pyzmq>=2.1.4:${PORTSDIR}/devel/py-pyzmq
+.endif
+
post-patch:
.if ! ${PORT_OPTIONS:MEXAMPLES}
${REINPLACE_CMD} -e "s# + example_files##g" ${WRKSRC}/setupbase.py