aboutsummaryrefslogtreecommitdiff
path: root/devel/ipython
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2014-01-06 13:30:01 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2014-01-06 13:30:01 +0000
commit69c40977bcabc8b667831f1d229e415ef0b2b22f (patch)
tree2a88f3f9dba9494eb7deff2a37a0026ae25b755e /devel/ipython
parent5010cb0edae2b52ece6974f69407f274bef83d8a (diff)
Notes
Diffstat (limited to 'devel/ipython')
-rw-r--r--devel/ipython/Makefile8
-rw-r--r--devel/ipython/pkg-plist7
2 files changed, 9 insertions, 6 deletions
diff --git a/devel/ipython/Makefile b/devel/ipython/Makefile
index 82860ad2c5ce..0eec9340c9cb 100644
--- a/devel/ipython/Makefile
+++ b/devel/ipython/Makefile
@@ -12,21 +12,17 @@ COMMENT= An enhanced Interactive Python shell
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2:${PORTSDIR}/databases/py-sqlite3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pexpect>=2:${PORTSDIR}/misc/py-pexpect \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>=2:${PORTSDIR}/databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=2:${PORTSDIR}/databases/py-sqlite3
USE_PYTHON= yes
USE_PYDISTUTILS=yes
-MAN1= ipcluster.1 ipcontroller.1 ipengine.1 iplogger.1 \
- ipython.1 irunner.1 pycolor.1
-
OPTIONS_DEFINE= X11 HTML_NOTEBOOK ZMQ
OPTIONS_DEFAULT=X11 ZMQ
HTML_NOTEBOOK_DESC= HTML notebook support
ZMQ_DESC= ZMQ support (parallel computing, qt console, notebook)
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
@@ -46,7 +42,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pyzmq>=2.1.4:${PORTSDIR}/devel/py-pyzmq
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
- cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/ipython/pkg-plist b/devel/ipython/pkg-plist
index 0bec745435ab..624c1dd45ecf 100644
--- a/devel/ipython/pkg-plist
+++ b/devel/ipython/pkg-plist
@@ -6,6 +6,13 @@ bin/iptest
bin/ipython
bin/irunner
bin/pycolor
+man/man1/ipcluster.1.gz
+man/man1/ipcontroller.1.gz
+man/man1/ipengine.1.gz
+man/man1/iplogger.1.gz
+man/man1/ipython.1.gz
+man/man1/irunner.1.gz
+man/man1/pycolor.1.gz
%%PYTHON_SITELIBDIR%%/IPython/__init__.py
%%PYTHON_SITELIBDIR%%/IPython/__init__.pyc
%%PYTHON_SITELIBDIR%%/IPython/__init__.pyo