aboutsummaryrefslogtreecommitdiff
path: root/devel/itext
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2008-04-09 09:40:17 +0000
committerAlex Dupre <ale@FreeBSD.org>2008-04-09 09:40:17 +0000
commit17668122155eaebc7bcea23ab244dbbb6245cb41 (patch)
treeb153ce6930185473c0b13fe144c7d3d594704e9c /devel/itext
parent7174a986cd5855c150067953de7c4e7d4ef5f68b (diff)
downloadports-17668122155eaebc7bcea23ab244dbbb6245cb41.tar.gz
ports-17668122155eaebc7bcea23ab244dbbb6245cb41.zip
Notes
Diffstat (limited to 'devel/itext')
-rw-r--r--devel/itext/Makefile11
-rw-r--r--devel/itext/distinfo6
-rw-r--r--devel/itext/files/patch-ant_compile.xml10
-rw-r--r--devel/itext/files/patch-core_com_lowagie_text_pdf_PdfPKCS7.java11
4 files changed, 25 insertions, 13 deletions
diff --git a/devel/itext/Makefile b/devel/itext/Makefile
index 66c990554cd5..7be99380dc00 100644
--- a/devel/itext/Makefile
+++ b/devel/itext/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= itext
-PORTVERSION= 2.0.8
+PORTVERSION= 2.1.0
PORTEPOCH= 1
CATEGORIES= devel java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
@@ -22,23 +22,24 @@ RUN_DEPENDS= ${JAVAJARDIR}/bcmail.jar:${PORTSDIR}/java/bouncycastle
WRKSRC= ${WRKDIR}/src
EXTRACT_AFTER_ARGS= | (${MKDIR} ${WRKSRC} && ${TAR} -xf - -C ${WRKSRC})
-USE_DOS2UNIX= yes
-DOS2UNIX_REGEX= .*\.xml
USE_JAVA= yes
JAVA_VERSION= 1.4+
USE_ANT= yes
-ALL_TARGET= jar
+ALL_TARGET= jar jar.rtf
MAKE_ENV= ANT_INCLUDE_SHARED_JARS=YES
.if !defined(NOPORTDOCS)
ALL_TARGET+= javadoc
PORTDOCS= *
.endif
-PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
+ %%JAVAJARDIR%%/${PORTNAME}-rtf.jar
do-install:
@${INSTALL_DATA} ${WRKDIR}/lib/iText.jar \
${JAVAJARDIR}/${PORTNAME}.jar
+ @${INSTALL_DATA} ${WRKDIR}/lib/iText-rtf.jar \
+ ${JAVAJARDIR}/${PORTNAME}-rtf.jar
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/apidocs
@${CP} -R ${WRKDIR}/build/docs/* ${DOCSDIR}/apidocs
diff --git a/devel/itext/distinfo b/devel/itext/distinfo
index f91c871815a9..5db400ee7e97 100644
--- a/devel/itext/distinfo
+++ b/devel/itext/distinfo
@@ -1,3 +1,3 @@
-MD5 (iText-src-2.0.8.tar.gz) = a3901ad59d49e400bef67ba0fc95a860
-SHA256 (iText-src-2.0.8.tar.gz) = 218329b02607d0d82b60274c368af53fbfe80d590c6ef4e137271a6e9e436937
-SIZE (iText-src-2.0.8.tar.gz) = 1156727
+MD5 (iText-src-2.1.0.tar.gz) = 16ba8c3097e20083169c41584bb96a80
+SHA256 (iText-src-2.1.0.tar.gz) = 741f578c8430ecbeee40f042e4663efa62859957a8170efaf5d49d6e2eae343b
+SIZE (iText-src-2.1.0.tar.gz) = 1175892
diff --git a/devel/itext/files/patch-ant_compile.xml b/devel/itext/files/patch-ant_compile.xml
index ca0aa30a14fc..50d1c43858ce 100644
--- a/devel/itext/files/patch-ant_compile.xml
+++ b/devel/itext/files/patch-ant_compile.xml
@@ -1,10 +1,10 @@
---- ant/compile.xml.orig 2008-02-17 18:49:03.000000000 +0100
-+++ ant/compile.xml 2008-02-17 18:50:44.000000000 +0100
-@@ -81,6 +81,7 @@
+--- ant/compile.xml.orig 2008-03-19 18:26:17.000000000 +0100
++++ ant/compile.xml 2008-04-08 08:19:52.000000000 +0200
+@@ -85,6 +85,7 @@
<include name="**/*.txt"/>
</fileset>
</copy>
-+ <mkdir dir="${itext.lib}"/>
- <jar jarfile="${itext.jar}" basedir="${itext.bin}" excludes="com/lowagie/rups/**,com/lowagie/examples/**,**/*.cmap,**/*.properties,com/lowagie/text/pdf/fonts/cmaps/**">
++ <mkdir dir="${itext.lib}" />
+ <jar jarfile="${itext.jar}" basedir="${itext.bin}">
<manifest>
<attribute name="Main-Class" value="com.lowagie.tools.ToolboxAvailable"/>
diff --git a/devel/itext/files/patch-core_com_lowagie_text_pdf_PdfPKCS7.java b/devel/itext/files/patch-core_com_lowagie_text_pdf_PdfPKCS7.java
new file mode 100644
index 000000000000..0bae4b9f79eb
--- /dev/null
+++ b/devel/itext/files/patch-core_com_lowagie_text_pdf_PdfPKCS7.java
@@ -0,0 +1,11 @@
+--- core/com/lowagie/text/pdf/PdfPKCS7.java.orig 2008-04-08 08:11:56.000000000 +0200
++++ core/com/lowagie/text/pdf/PdfPKCS7.java 2008-04-08 08:14:15.000000000 +0200
+@@ -97,7 +97,7 @@
+ import org.bouncycastle.asn1.DERUTCTime;
+ import org.bouncycastle.jce.provider.X509CRLParser;
+ import org.bouncycastle.jce.provider.X509CertParser;
+-import org.bouncycastle.util.StreamParsingException;
++import org.bouncycastle.x509.util.StreamParsingException;
+
+ /**
+ * This class does all the processing related to signing and verifying a PKCS#7