aboutsummaryrefslogtreecommitdiff
path: root/devel/ixlib
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2008-08-27 15:59:25 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2008-08-27 15:59:25 +0000
commite391e994adbb5f3578791c29eec39d748c55040a (patch)
treed9ca8d8a4a457b750c01e7e0dfe73a80b3255d13 /devel/ixlib
parente76c1a14ce787a8d5f49ee8fef9e89687d0058ea (diff)
downloadports-e391e994adbb5f3578791c29eec39d748c55040a.tar.gz
ports-e391e994adbb5f3578791c29eec39d748c55040a.zip
Notes
Diffstat (limited to 'devel/ixlib')
-rw-r--r--devel/ixlib/Makefile4
-rw-r--r--devel/ixlib/files/patch-src::ixlib_garbage.hh13
2 files changed, 11 insertions, 6 deletions
diff --git a/devel/ixlib/Makefile b/devel/ixlib/Makefile
index 0204e1cd9aa5..de79f00cb4ef 100644
--- a/devel/ixlib/Makefile
+++ b/devel/ixlib/Makefile
@@ -27,10 +27,6 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= Does not compile on !i386
-.endif
-
pre-configure:
${CP} ${LTMAIN} ${WRKSRC}
diff --git a/devel/ixlib/files/patch-src::ixlib_garbage.hh b/devel/ixlib/files/patch-src::ixlib_garbage.hh
index 5e2a03071b51..1c913a76f2a3 100644
--- a/devel/ixlib/files/patch-src::ixlib_garbage.hh
+++ b/devel/ixlib/files/patch-src::ixlib_garbage.hh
@@ -1,5 +1,5 @@
---- src/ixlib_garbage.hh.orig Tue Jun 19 16:16:29 2001
-+++ src/ixlib_garbage.hh Fri Dec 1 19:56:04 2006
+--- src/ixlib_garbage.hh.orig 2001-06-20 01:16:29.000000000 +0200
++++ src/ixlib_garbage.hh 2008-08-27 17:54:47.000000000 +0200
@@ -126,24 +126,24 @@
// compiler generates one, which is *ahem* - fatal
ref(ref const &src)
@@ -216,6 +216,15 @@
return oldinst;
}
};
+@@ -440,7 +440,7 @@
+
+ private:
+ hash_value hash(T const *ptr) const {
+- unsigned u = reinterpret_cast<unsigned>(ptr);
++ uintptr_t u = reinterpret_cast<uintptr_t>(ptr);
+ return (u ^ (u >> 8) ^ (u >> 16) ^ (u >> 24)) & HASH_MAX;
+ }
+ instance_data *getHashEntry(T const *instance) {
@@ -482,7 +482,7 @@